Closed Bug 1089462 Opened 5 years ago Closed 5 years ago

object field with field being an empty string doesn't show up in Browser Toolbox (formerly Browser debugger)

Categories

(Firefox :: Untriaged, defect)

32 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 924295

People

(Reporter: peter.kehl, Unassigned)

Details

Attachments

(2 files)

375 bytes, application/vnd.mozilla.xul+xml
Details
8.98 KB, image/png
Details
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

Have privileged Javascript that sets a field in an object, and that field name is an empty string. See attached XUL. Then debug it in Browser Toolbox.


Actual results:

The empty field (and its value) doesn't show up in Browser Toolbox. See attached screenshot.


Expected results:

The empty field (and its value) should show up.
Attached file emptyStringField.xul
Attached image bug1.png
screenshot
As you can see from the screenshot, an empty field shows up only if you specifically add a watch for it, e.g. o[ '' ].
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 924295
You need to log in before you can comment on or make changes to this bug.