Error Display instead of Localization project details @http://mozilla.locamotion.org/ta/firefox/ Page

RESOLVED FIXED

Status

Mozilla Localizations
ta / Tamil
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: அருண் குமார்-Arun Kumar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8511803 [details]
Error in Server Screenshot

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141013200110

Steps to reproduce:

Steps to reproduce
1. Logged into http://mozilla.locamotion.org using my userr name
2. Change the interface language to "Tamil-ta" and Save
3. Visit http://mozilla.locamotion.org/ta/firefox/ this page.




Actual results:


வழங்கியில் பிழை

பிழை ஏற்பட்டுள்ளது. உமது பொறுமைக்கு நன்றி.

unsupported format character '(' (0x28) at index 2

If you need assistance, you may refer to this error as d1ea3f6c2f5e4a108c662f9d08e907bf.



Expected results:

It should show the project status details of project.
It happens to all the projects in Tamil @http://mozilla.locamotion.org/ta/

Comment 1

4 years ago
This is occurring for long time, we cannot have interface language as Tamil.
Once interface language is changed to English, we can proceed without any errors.

I remember long back I reported this to Jeff and he logged a bug.

Jeff: could say that status.
Flags: needinfo?(jbeatty)
I remember filing the bug, but I'm not sure I remember how that was resolved. The Pootle team since then moved away from bugzilla to toward github issues, but I've CC'd Dwayne to provide info.
Flags: needinfo?(jbeatty) → needinfo?(dwayne)
Group: core-security

Comment 3

4 years ago
The error is caused because there are a number of translated variables in the Pootle translations for Tamil.  The easiest way to fix this is if you take the current ta Pootle UI translations and review them in an offline PO editor.

You can get the two files from these URLs:

https://raw.githubusercontent.com/translate/pootle/master/pootle/locale/ta/pootle.po
https://raw.githubusercontent.com/translate/pootle/master/pootle/locale/ta/pootle_js.po

I'll resolve this as fixed here.  When they are done reviewing the translations please report an issue against Pootle at https://github.com/translate/pootle/issues and we can include those translation on mlo.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(dwayne)
Resolution: --- → FIXED
Hi Dwayne, Thanks for giving us the information on this issue.
I have already corrected the strings in the above mentioned .po files at Github itself.

I have forked and I will do "pull request" for the same.
Is it ok ?

Thanks
Arun
This issue has been fixed on pootle. Now it is working without any issues.
You need to log in before you can comment on or make changes to this bug.