Page takes forever to lay out and spikes CPU to 100%

RESOLVED DUPLICATE of bug 77114

Status

()

RESOLVED DUPLICATE of bug 77114
17 years ago
17 years ago

People

(Reporter: bzbarsky, Assigned: attinasi)

Tracking

({perf})

Trunk
mozilla0.9.8
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

Build: 2001-11-01-08 (and current cvs build) both on linux

Steps to reproduce:

1)  Load URL
2)  Try to use the ui for the next 2-3 seconds

We seem to be spending lots of time in nsCSSFrameConstructor::FindFrameWithContent

Total hit count: 520
Count %Total  Function Name
 53   10.2     nsCSSFrameConstructor::FindFrameWithContent(nsIPresContext *,
nsIFrame *, nsIContent *, nsIContent *, nsFindFrameHint *)
14   2.7     nsCOMPtr_base::~nsCOMPtr_base(void)
11   2.1     chunk_free
11   2.1     nsCOMPtr_base::begin_assignment(void)
9   1.7     nsGenericElement::GetBindingParent(nsIContent **)

Attaching full profile
Keywords: perf

Updated

17 years ago
Target Milestone: --- → mozilla0.9.8

*** This bug has been marked as a duplicate of 77114 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.