Visiting https://webmaker.org/en-US and changing the language to "de", "es", "fr", … leads to 404

RESOLVED WORKSFORME

Status

Webmaker
webmaker.org
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: pollti, Unassigned)

Tracking

Details

(Whiteboard: [nov28], URL)

(Reporter)

Description

4 years ago
Visiting https://webmaker.org/en-US and changing the language (e.g. to "Deutsch (de)") leds to 404 (https://webmaker.org/de? ➔ problem is caused by the question mark).
(Reporter)

Updated

4 years ago
Summary: Visiting https://webmaker.org/en-US and changing the language to "de", "es", "fr", ... leds to 404 → Visiting https://webmaker.org/en-US and changing the language to "de", "es", "fr", … leads to 404

Comment 1

4 years ago
Confirmed. Something to do with the Angular routing perhaps?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [nov14]
* [nov14] is past -- please update to [nov28] train or later
* next steps here?
Whiteboard: [nov14] → [nov28]
(Reporter)

Comment 4

3 years ago
This doesn't lead to 404 anymore, but it shows a bar with a question mark now.

Comment 5

3 years ago
It looks like the original bug has been fixed now. If you change locales, you don't get the question mark added so it's all working now.

However, there's still a bug somewhere in webmaker-i18n where it parses "/de?" differently from "/de" or "/de/?".
(Reporter)

Comment 6

3 years ago
Should we close this bug and open a new one then?
This seems to be fixed now, so I'm closing this bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
actually I filed it here since it is a bug https://github.com/mozilla/webmaker.org/issues/1155
You need to log in before you can comment on or make changes to this bug.