If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash when selecting a url with so at the end

RESOLVED DUPLICATE of bug 108582

Status

()

Core
Networking
--
critical
RESOLVED DUPLICATE of bug 108582
16 years ago
16 years ago

People

(Reporter: Marc Loiselle, Assigned: rpotts (gone))

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Steps to reproduce:

Go to http://jakarta.apache.org/builds/jakarta-tomcat/release/v3.3/bin/linux/i386
Click on mod_jk-3.3-ap13-eapi.so link
Crash immediately everytime 
It should bring up a unknown content type dialog.

Buildid 2001110603 on Win2k

Note: If I shift-click on the link I can download it succesfully
(Reporter)

Comment 1

16 years ago
Crash is in URILDR.DLL

Talkback TB377711001E

Comment 2

16 years ago
Related: bug 108582

Updated

16 years ago
Severity: normal → critical
Keywords: crash
stephend, would you get the stack trace?
That Talkback ID didn't work, so I crashed Moz myself ;-(

Incident ID 37721087
Stack Signature netscp6.exe + 0x1006d (0x0041006d) 32c7170f
Bug ID
Trigger Time 2001-11-07 18:38:15
Email Address stephend@netscape.com
URL visited .
User Comments Crash clicking URL with .so at the end.
Build ID 2001110709
Product ID MozillaTrunk
Platform ID Win32
Trigger Reason Access violation
Stack Trace
netscp6.exe + 0x1006d (0x0041006d)
nsDocumentOpenInfo::DispatchContent
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 375]
nsDocumentOpenInfo::OnStartRequest
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 226]
nsHttpChannel::ProcessNormal
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpChannel.cpp, line 573]
nsHttpChannel::ProcessResponse
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpChannel.cpp, line 543]
nsOnStartRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 126]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 303]
netscp6.exe + 0x16b3 (0x004016b3)
netscp6.exe + 0x121c (0x0040121c)
netscp6.exe + 0x32a8 (0x004032a8)
KERNEL32.DLL + 0x17d08 (0x77e97d08) 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

16 years ago
darin
Assignee: neeti → darin
Depends on: 108582

Comment 6

16 years ago
-> mscott (mr. uriloader)
Assignee: darin → mscott

Comment 7

16 years ago
Rick, crash started showing up after the ProcessCancel case got removed
yesterday. Over to you =).
Assignee: mscott → rpotts
(Reporter)

Comment 8

16 years ago
Comments in bug 108582 indicate that this bug should be fixed now.
(Reporter)

Comment 9

16 years ago
wfm buildid 2001110903 win2k
Basically the same stack and stopped crashing with the same fix.  Marking duplicate.

*** This bug has been marked as a duplicate of 108582 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.