crash in nsBrowserStatusFilter::OnStateChange(nsIWebProgress*, nsIRequest*, unsigned int, tag_nsresult)

RESOLVED DUPLICATE of bug 1061125

Status

()

Toolkit
General
--
critical
RESOLVED DUPLICATE of bug 1061125
4 years ago
3 years ago

People

(Reporter: Andrei Eftimie, Unassigned)

Tracking

({crash})

unspecified
All
Linux
crash
Points:
---

Firefox Tracking Flags

(firefox33 affected, firefox34 affected)

Details

(Whiteboard: [mozmill], crash signature)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-66c50b8e-9527-4a9b-bcbb-84bc12141027.
=============================================================

Stack:
> 0   @0x729b80fc 
> 1 libxul.so nsBrowserStatusFilter::OnStateChange(nsIWebProgress*, nsIRequest*, unsigned int, tag_nsresult)  toolkit/components/statusfilter/nsBrowserStatusFilter.cpp
> 2 libxul.so nsDocLoader::DoFireOnStateChange(nsIWebProgress*, nsIRequest*, int&, tag_nsresult)  uriloader/base/nsDocLoader.cpp
> 3 libxul.so nsDocLoader::doStopDocumentLoad(nsIRequest*, tag_nsresult)  uriloader/base/nsDocLoader.cpp
> 4 libxul.so nsDocLoader::DocLoaderIsEmpty(bool) uriloader/base/nsDocLoader.cpp
> 5 libxul.so nsDocLoader::OnStopRequest(nsIRequest*, nsISupports*, tag_nsresult) uriloader/base/nsDocLoader.cpp
> 6 libxul.so nsLoadGroup::RemoveRequest(nsIRequest*, nsISupports*, tag_nsresult) netwerk/base/src/nsLoadGroup.cpp
> 7 libxul.so nsDocument::DoUnblockOnload() content/base/src/nsDocument.cpp
> 8 libxul.so nsUnblockOnloadEvent::Run() content/base/src/nsDocument.cpp
> 9 libxul.so nsThread::ProcessNextEvent(bool, bool*) xpcom/threads/nsThread.cpp
> 10  libxul.so NS_InvokeByIndex  xpcom/reflect/xptcall/md/unix/xptcinvoke_x86_64_unix.cpp

We've seen crashes with different signatures in regards to this specific mozmill test:
> 03:46:09 TEST-START | testSecurity/testSafeBrowsingNotificationBar.js | setupModule
> 03:46:10 TEST-START | testSecurity/testSafeBrowsingNotificationBar.js | testNotificationBar
> 03:46:32 
> 03:46:32 ###!!! [Child][MessageChannel::SendAndWait] Error: Channel error: cannot send/recv
> 03:46:32 mozcrash INFO | Saved minidump as /home/mozauto/.mozilla/firefox/Crash Reports/pending/7bc6f288-0e2b-6d21-09680a3d-62895a6c.dmp
> 03:46:32 mozcrash INFO | Saved app info as /home/mozauto/.mozilla/firefox/Crash Reports/pending/7bc6f288-0e2b-6d21-09680a3d-62895a6c.extra
> 03:46:37 PROCESS-CRASH | /home/mozauto/jenkins/workspace/release-mozilla-release_remote/data/mozmill-tests/firefox/tests/remote/testSecurity/testSafeBrowsingNotificationBar.js | application crashed [unknown top frame]
> 03:46:37 Crash dump filename: /home/mozauto/jenkins/workspace/release-mozilla-release_remote/data/profile/minidumps/7bc6f288-0e2b-6d21-09680a3d-62895a6c.dmp
> 03:46:37 No symbols path given, can't process dump.
> 03:46:37 MINIDUMP_STACKWALK not set, can't process dump.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1061125
You need to log in before you can comment on or make changes to this bug.