[Usage][Cost Control] Noticeable difference on amount of traffic on the system app, between the data usage list per app and the app detail view.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Cost Control
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: mai, Assigned: salva)

Tracking

(Depends on: 1 bug)

unspecified
2.2 S4 (23jan)
x86_64
Windows 7

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
After "Bug 1077546 - [Cost Control] Add app detail view" was landed, the difference between by application breakdown totals and the total by interface (residual traffic) is visible on the system App detail view. 

Now, the amount of mobile traffic of the System app that is showed on the app list differs from the amount on the app detail view.


STR:
 1. Make reset-gaia 
 2. Don't enable any mobile data network.
 3. Launch Usage and pass the FTU with default values.
 4. Obvserve usage is 0
 5. Press home button
 6. Enable 3G from utility tray
 7. Keep home pressed and return to Usage application
 8. Wait for chart and application breakdown
 9. Go to system app and watching the amount of traffic.
 10. Press on system app and compare the data traffic with the amount of traffic showed on the previous list.

Expected:
 Total amount of data displayed in the breakdown sums up the same amount displayed in the system app detail view.

Actual:
  There is a noticeable difference between the two totals.
(Reporter)

Updated

3 years ago
Depends on: 1083680
status-b2g-v2.2: --- → affected
blocking-b2g: --- → 2.0M?

Comment 1

3 years ago
Hi Salvador,
Which device do you find this bug? Which version do you intend to file this bug?
blocking-b2g: 2.0M? → ---
We should address this problem in the back-end but solving this in the front-end, with a workaround similar to bug 1080473, involves other problems related with how to show the residual traffic in the chart.

Proposed solutions include:
  * To not allow see details for System APP.
  * To include a special label inside System APP detail view saying: `Residual traffic:` and the difference.
  * To distribute the residual traffic each day increasing artificially by-day usage.

We need som UX advice.
blocking-b2g: --- → 2.2?
Flags: needinfo?(jhuang)

Updated

3 years ago
status-b2g-master: --- → affected
triage: blocking.
blocking-b2g: 2.2? → 2.2+

Comment 4

3 years ago
Hi,
From ux perspective, I agree with Salva that not allowing user accesses system app.
And also I'm thinking that maybe using "Others" rather than "System app" would be easier for users to understand? User won't not know what system app means in here.
Flags: needinfo?(jhuang)
Thank you Juwei, I'm taking this bug and not allowing to see details for System app as it was suggested by Mai. I'm going to ask l10n team for changing a string because I don't know if it's too late.
Assignee: nobody → salva
Created attachment 8552466 [details] [review]
Avoiding system to be tapped and showing it as 'Others'

Hello Marina. Do you mind to review the patch, please?
Attachment #8552466 - Flags: review?(marina.rodrigueziglesias)
(Reporter)

Comment 7

3 years ago
Comment on attachment 8552466 [details] [review]
Avoiding system to be tapped and showing it as 'Others'

LGTM. Thanks Salva, r+

PS: Don't forget ask for approval.
Attachment #8552466 - Flags: review?(marina.rodrigueziglesias) → review+
master: 3f46a24ee036a3fb8bd084ffdc20da697f5bea99
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Comment on attachment 8552466 [details] [review]
Avoiding system to be tapped and showing it as 'Others'

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): none
[User impact] if declined: medium, detailed information of System application is innaccurate due to implementation limitations. This could lead to confussion as detailed view shows less usage.
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): low, just disabling system to be shown in detail.
[String changes made]: one string added.
Attachment #8552466 - Flags: approval-gaia-v2.2?

Updated

3 years ago
status-b2g-master: affected → fixed

Updated

3 years ago
Keywords: verifyme
Target Milestone: --- → 2.2 S4 (23jan)

Updated

3 years ago
Attachment #8552466 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/66351730fee0636f083651cbac70c032d4aad4f6
status-b2g-v2.2: affected → fixed

Comment 11

3 years ago
Created attachment 8556280 [details]
video_v2.2.MP4

Hi Marina,
I have verified this issue on Flame 2.2/3.0, but I can not make sure the meaning of step 8~10, I have uploaded the video of Flame v2.2 and v3.0, could you help to check whether this bug was verified pass or not? Thanks!
See attachment:video_v2.2.MP4 and video_v3.0.MP4
STR:
 1. Reset device. 
 2. Don't enable any mobile data network.
 3. Launch Usage and pass the FTU with default values.
 4. Obvserve usage is 0.
 5. Press home button.
 6. Enable 3G from utility tray.
 7. Keep home pressed and return to Usage application.
 8. Wait for chart and application breakdown.
 9. Back to home and launch some apps to use mobile data.
 10. Launch Usage app to check the data traffic.
**On Flame 2.2, the amount of Mobile usage per app(235.83 KB) is not equal to the value of Mobile usage(235.82 KB).
On Flame 3.0, it can't scroll the Mobile usage per app, so I can not check the amount of traffic.

Flame 2.2 build:
Gaia-Rev        cd42b034fd2825c3675ace3a67f5775eb61c2d60
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d824c65a6a2b
Build-ID        20150128002506
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150128.035910
FW-Date         Wed Jan 28 03:59:20 EST 2015
Bootloader      L1TC000118D0

Flame 3.0 build:
Gaia-Rev        ba613ae583a706131c45e885f65d428d4a541a81
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/9b6b80222e66
Build-ID        20150128101733
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150128.134719
FW-Date         Wed Jan 28 13:47:30 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(marina.rodrigueziglesias)

Comment 12

3 years ago
Created attachment 8556283 [details]
video_v3.0.MP4
(Reporter)

Comment 13

3 years ago
Hi Sue,
On the last steps you have to check the following issues:

  * On the App list you have to check that you see the "Others" label instead "System".
  * When you make clic on "Others" nothing happens. (Others doesn't have a detail screen)

Regards,
Marina
Flags: needinfo?(marina.rodrigueziglesias)

Comment 14

3 years ago
(In reply to Marina Rodríguez [:mai] from comment #13)
> Hi Sue,
> On the last steps you have to check the following issues:
> 
>   * On the App list you have to check that you see the "Others" label
> instead "System".
>   * When you make clic on "Others" nothing happens. (Others doesn't have a
> detail screen)
> 
> Regards,
> Marina

Hi Marina,
After the last steps, I can see the "Others" label. And when I click on "Others", nothing happens. (Others doesn't have a detail screen). So this issue has been verified pass on Flame 2.2/3.0
Thanks!
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.