If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox works incorrectly with new Russian timezones

RESOLVED DUPLICATE of bug 1079720

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1079720
3 years ago
3 years ago

People

(Reporter: Arthur, Unassigned)

Tracking

33 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.104 Safari/537.36

Steps to reproduce:

A:
1. Install this update http://support.microsoft.com/kb/2998527/en-us
2. Set your timezone to any Russian timezone (like UTC+3 Moscow)
3. Run this code:
var d = new Date(2008,0,1,23,0);
d.setMinutes(60);
console.log(d.getHours());

B:
1: Open http://dev.sencha.com/deploy/ext-4.0.1/examples/form/field-types.html
2: Click on Time Field selectbox

Example B is caused by the same bug.
This bug is similar to chrome one: https://code.google.com/p/chromium/issues/detail?id=418974


Actual results:

A: 23
B: Warning: Unresponsive script


Expected results:

A: 0
B: Selectbox should contain values

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1079720
You need to log in before you can comment on or make changes to this bug.