Closed Bug 1089598 Opened 6 years ago Closed 6 years ago

yahoo search code for the search activity widget

Categories

(Firefox for Android Graveyard :: Search Activity, defect)

35 Branch
All
Android
defect
Not set
normal

Tracking

(firefox35 fixed, firefox36 fixed, fennec35+)

RESOLVED FIXED
Firefox 36
Tracking Status
firefox35 --- fixed
firefox36 --- fixed
fennec 35+ ---

People

(Reporter: krudnitski, Assigned: Margaret)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

Please use the following search code for the Search Activity widget for Yahoo: mozilla_mobile2_search 

Please uplift this ASAP to beta to match where Yahoo is currently showing as default in en-US
The correct fr value for that tag is mozmob2, not mozilla_mobile2_search.

Karen, I assume the goal here is to split out traffic/revenue for SA searches?
I can write a patch once I get confirmation from mconnor about what we need to change.
Assignee: nobody → margaret.leibovic
(In reply to Karen Rudnitski [:kar] from comment #0)

> Please uplift this ASAP to beta to match where Yahoo is currently showing as
> default in en-US

The search activity is only in aurora, so we only need to uplift this there.
Margaret - thanks, so only aurora :)

Joanne - please see mconnor's thoughts on the search code yahoo sent over. Can you please circle back to Yahoo? :/
Flags: needinfo?(jnagel)
I've already sent email and I'm waiting for confirmation (my contact was out sick yesterday); hoping for an update today.
Flags: needinfo?(jnagel)
Ok, Yahoo has confirmed the use of:  mozmob2  for the widget.
tracking-fennec: ? → 35+
I feel kinda dirty about this, but this is the easiest way to distinguish a search activity search given our current code. I feel like I should update rel="mobile" to be rel="searchactivity" or something like that, but that would require updating the wikipedia plugin as well.

Also, we'll need to update other locales as well, right?
Attachment #8514526 - Flags: review?(mark.finkle)
Comment on attachment 8514526 [details] [diff] [review]
Yahoo search code for the search activity widget

Can you file a bug to switch over to use rel="mobile|tablet|search", because it seems like a the best way forward. We can work on that once the dust settles on all the search provider stuff.
Attachment #8514526 - Flags: review?(mark.finkle) → review+
Depends on: 1092285
Comment on attachment 8514526 [details] [diff] [review]
Yahoo search code for the search activity widget

Approval Request Comment
[Feature/regressing bug #]: search activity v1 (shipping in Fx35)
[User impact if declined]: Yahoo can't distinguish where searches come from
[Describe test coverage new/current, TBPL]: tested locally
[Risks and why]: low-risk, changes a search parameter
[String/UUID change made/needed]: none
Attachment #8514526 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/76297cb7a06f
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 36
Attachment #8514526 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.