Whitelist libraries that can't be directly downloaded

RESOLVED WONTFIX

Status

Marketplace
Validation
P5
normal
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: mat, Unassigned)

Tracking

Points:
---

Details

(Whiteboard: [marketplace-transition])

(Reporter)

Description

3 years ago
For some libraries, official builds don't exist, only the source is available and the developer needs to use the library build system to generate the single (often minified) file. It'd be nice to whitelist those libraries in the validator. We probably need to support static hashes on top of the dynamic ones generated by jslibfetcher.py

It seems to be the case for cordova and enyo.js at least.
jquery-ui had similar issues, last time I looked.

fwiw I looked at a 3 different apps that used a 'enyo.js' file and found each used different minification (possibly just poor examples) but the code /seemed/ to be largely the same.  We may need to put these type of template files through a generic minify step.

Updated

3 years ago
Priority: -- → P5

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Whiteboard: [marketplace-transition]
You need to log in before you can comment on or make changes to this bug.