b2g v2.1 cannot scroll some content

RESOLVED DUPLICATE of bug 1087453

Status

()

Core
Panning and Zooming
RESOLVED DUPLICATE of bug 1087453
3 years ago
3 years ago

People

(Reporter: bkelly, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.1+)

Details

(Reporter)

Description

3 years ago
[Blocking Requested - why for this release]:

I've noticed that I cannot scroll certain content on my v2.1 flame.  The easiest way to see this is:

1) Open dialer app
2) Click on contacts tab at bottom of app
3) Jump down to a contact further down the list with the letter shortcuts
(I get low-res rendering defects at this point, but thats probably a different bug)
4) Open the contact
5) Attempt to scroll to the contact so you can see the "Add Favorite" button at the bottom.

Of course, you need enough data in the contact to require scrolling.

While the steps are for contacts, I have also seen this while browsing other content.  For example, go to forecast.io and try to horizontally scroll some of the daily precipitation graphs.

My device:

Base v188
Full flash of v2.1 KK PVT over that.
Update channel: nightly-b2g34
Build ID: 20141027001201
Gaia Commit: c97463d6
This may be bug 1087453 when noticed in email settings and which has a fix up for review.
OK, lets see if the fix to bug 1087453 takes care of this.
I'm unable to reproduce using the STR in comment 0 on the latest 2.1 flame-kk-eng build and the medium reference workload. I tried a bunch of contacts, they're all scrollable fine.
(Reporter)

Comment 4

3 years ago
Kats, I just updated and I still see the problem.  If I make a video, can I send it to you directly via email?  Unfortunately it will show private contact info, so I don't want to post here.
Flags: needinfo?(bugmail.mozilla)
Sure, email it to me at kats@m.c. Alternatively we can wait until bug 1087453 is uplifted and see if it still happens.
Depends on: 1087453
Flags: needinfo?(bugmail.mozilla)
Triage group reviewed, blocking+ because regression.
blocking-b2g: 2.1? → 2.1+
Leaving unassigned to remind us to test when bug 1087453 is uplifted.
Bug 1087453 has been uplifted. Ben, can you see if this is still happening on a build with that patch?
Flags: needinfo?(bkelly)
(Reporter)

Comment 9

3 years ago
I'll check tomorrow once this hits the OTA update.
(Reporter)

Comment 10

3 years ago
I cannot reproduce this problem on the latest OTA update.  Looks like bug 1087453 fixed it.  Thanks!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(bkelly)
Resolution: --- → DUPLICATE
Duplicate of bug: 1087453
You need to log in before you can comment on or make changes to this bug.