test_browser_navigation.py (& AWFY fxos slaves) are unable to browse the page.

RESOLVED DUPLICATE of bug 1089542

Status

RESOLVED DUPLICATE of bug 1089542
4 years ago
4 years ago

People

(Reporter: nbp, Assigned: jlorenzo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fromAutomation])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
I can reproduce this issue locally with the 3 marionette test which are browsing web pages, and Johan can reproduce it with test_browser_navigation.py.

The test starts fine, we can notice the following:
 - When the test is typing in the search bar, there is no icon / spinner appearing. (Search suggestion is enabled)
 - When the URL is complete, the test tap on the search icon of the keyboard, but the application does not run any search.

Trying to browse manually after the test show the same failure cases.
Trying to browse manually after rebooting works fine.

Strangely, this test does not seems to fail on mozilla-central, and appeared since Oct 24 [1], Changeset e94b66dca22c is the last good changeset tested by FxOS slaves.

[1] http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?startdate=2014-10-24&enddate=2014-10-25
(Assignee)

Updated

4 years ago
Assignee: nobody → jlorenzo
(Assignee)

Comment 1

4 years ago
Created attachment 8511971 [details]
Reduced logcat (without Marionette output)
(Assignee)

Comment 2

4 years ago
I haven't change the tests or marionette (still gaia revision a64a15961e62cbc832e2886a3d4bc7b3e9d3b1c9 on master) since comment 1 and I've able to reproduce on build:
Gaia-Rev        27a1d1baaa8e375b70e043efee67d5f2206c330b
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/88adcf8fef83
Build-ID        20141023040204
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880

Hence this looks like something has changed in the keyboard.
Component: Gaia::UI Tests → Gaia::Keyboard
Whiteboard: [fromAutomation]
(Assignee)

Comment 3

4 years ago
Actually, it was not an issue in gaia.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1089542
You need to log in before you can comment on or make changes to this bug.