Remove nsXULEmitter.cpp from the build

VERIFIED FIXED in mozilla0.9.9

Status

MailNews Core
MIME
P3
normal
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: Scott MacGregor, Assigned: Scott MacGregor)

Tracking

({perf})

Trunk
mozilla0.9.9

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

7.26 KB, patch
Jean-Francois Ducarroz
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
2.65 KB, patch
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

16 years ago
We have an obsolete class that's still part of the build:

nsXULEmitter.cpp/h. 

We need to remove this from the build. 

It will make a small improvment for the first message display since it will make
the emitter DLL smaller. And it will help footprint a little bit.
(Assignee)

Updated

16 years ago
Blocks: 22960
Status: NEW → ASSIGNED
Keywords: nsbeta1, perf
Target Milestone: --- → mozilla0.9.7

Comment 1

16 years ago
Varada can you take a look at this when you get a chance?
Assignee: mscott → varada
Status: ASSIGNED → NEW
Keywords: nsbeta1 → nsbeta1+

Comment 2

16 years ago
Created attachment 57902 [details] [diff] [review]
Patch

This patch removes xulemitter from the build. It builds fine on Win32. Maybe we
need a mac-buddy to remove it from a .mcp file too.

mscott, varada, wanna review this?

Comment 3

16 years ago
Patch attached.  Now all that is needed is testing on linux and mac (to make
sure I didn't break the builds there) and reviews.
QA Contact: esther → stephend

Comment 4

16 years ago
*** Bug 90246 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Priority: -- → P3
Keywords: patch, review
OS: Windows 2000 → All
Hardware: PC → All

Updated

16 years ago
Target Milestone: mozilla0.9.7 → mozilla0.9.8

Comment 5

16 years ago
reassigning to mscott.  It looks like this just needs a review and Varada isn't
currently around.
Assignee: varada → mscott
Target Milestone: mozilla0.9.8 → mozilla0.9.9
(Assignee)

Comment 6

16 years ago
Comment on attachment 57902 [details] [diff] [review]
Patch

sr=mscott

obviously we'll need mac changes to get checked in when we check this in.
Attachment #57902 - Flags: superreview+
(Assignee)

Comment 7

16 years ago
Created attachment 66372 [details] [diff] [review]
initial patch was incomplete...remove all references to the xul emitter
Attachment #57902 - Attachment is obsolete: true
Comment on attachment 66372 [details] [diff] [review]
initial patch was incomplete...remove all references to the xul emitter

R=ducarroz. Still need to remove nsMimeXULEmitter.cpp from mimeEmitter.xml (the
Mac project)
Attachment #66372 - Flags: review+
Comment on attachment 66372 [details] [diff] [review]
initial patch was incomplete...remove all references to the xul emitter

sr=sspitzer
Attachment #66372 - Flags: superreview+
Created attachment 66404 [details] [diff] [review]
complementary patch for the Mac project

Scoot, Seth, can you review it. Thanks
(Assignee)

Comment 11

16 years ago
thanks JF, I had made a similar change on my Mac. I'm not planning on landing
any project changes till after I remove all the code references. I'll let you
know when that's going to happen and we can land together. 
Comment on attachment 66404 [details] [diff] [review]
complementary patch for the Mac project

rs=sspitzer
Attachment #66404 - Flags: superreview+
I checked in the Mac part of the fix. Scott, feel free to close this bug as fixed...
please remove the file from the tree if it's obsolete... we've got enough dead
files hanging around as it is.  thanks.
(Assignee)

Comment 15

16 years ago
the files have been removed from the repository.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
cvs server: mozilla/mailnews/mime/emitters/src/nsMimeXULEmitter.cpp is no longer
in the repository
cvs server: mozilla/mailnews/mime/emitters/src/nsMimeXULEmitter.h is no longer
in the repository

and I checked LXR, too.

Verified FIXED.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.