Closed Bug 1089655 Opened 6 years ago Closed 6 years ago

crash in java.lang.RuntimeException: Unhandled error for GeckoRequest: FindInPage:Find at org.mozilla.gecko.util.GeckoRequest.onError(GeckoRequest.java)

Categories

(Firefox for Android :: General, defect, critical)

36 Branch
All
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 36
Tracking Status
firefox36 --- affected
fennec 36+ ---

People

(Reporter: aaronmt, Assigned: capella)

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-1496792f-f78b-481f-8d18-65c5a2141026.
=============================================================

java.lang.RuntimeException: Unhandled error for GeckoRequest: FindInPage:Find
	at org.mozilla.gecko.util.GeckoRequest.onError(GeckoRequest.java:89)
	at org.mozilla.gecko.GeckoAppShell$4.handleMessage(GeckoAppShell.java:436)
	at org.mozilla.gecko.EventDispatcher.dispatchEvent(EventDispatcher.java:168)
	at org.mozilla.gecko.GeckoAppShell.handleGeckoMessage(GeckoAppShell.java:2348)
	at org.mozilla.gecko.mozglue.GeckoLoader.nativeRun(Native Method)
	at org.mozilla.gecko.mozglue.GeckoLoader.nativeRun(Native Method)
	at org.mozilla.gecko.mozglue.GeckoLoader.nativeRun(Native Method)
	at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:369)
	at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:190)
Looking at the callstack, this could be a problem in the FindHelper.js code. Messaging.jsm says the addListener call must return an object. It looks like the "finder" listener.onMatchesCountResult is always passed an object:
http://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/FindHelper.js#99

Which is then used as a return to the GeckoRequest:
http://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/FindHelper.js#37

Sadly, no logcat in any of the crash reports yet. If anyone can reproduce this, please get a good logcat.
Assignee: nobody → markcapella
tracking-fennec: ? → 36+
Attached patch bug1089655.diffSplinter Review
I haven't run into issues during my own use, but in either case...

I have an unrelated patch in my queue where I use Java->JS messaging in SelectionHandler code and I've had to provide a bit like the attached...
Comment on attachment 8514462 [details] [diff] [review]
bug1089655.diff

Never cast your reviews to the wind :/
Attachment #8514462 - Flags: review?(wjohnston)
Attachment #8514462 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/44161bd0f41c
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 36
You need to log in before you can comment on or make changes to this bug.