Recipient autocomplete: after selecting result entry with [cursor down],[cursor right], confirming with TAB or ENTER cunningly selects the wrong recipient (1st result)

RESOLVED DUPLICATE of bug 1107844

Status

Thunderbird
Address Book
--
critical
RESOLVED DUPLICATE of bug 1107844
4 years ago
4 years ago

People

(Reporter: Brian L, Unassigned)

Tracking

({privacy, ux-trust})

31 Branch
privacy, ux-trust

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Thunderbird/31.2.0

1. Type a letter into "To" field, so autocomplete list shows
2. Press down arrow TWICE, to 2nd result
3. Press right arrow ("To" completes with 2nd result)
4. Press tab (next field gets focus, "To" changes to 1st result)


Actual results:

In step 4, field changes "back" to an address I didn't select.


Expected results:

In step 4, "to" field should stay what I selected in step 2 & 3.

(Thank you volunteer Thunderbird developers!  You Rock!!!)

Comment 1

4 years ago
TB 31.3.0 installed 19/12/2014; Windows 7 Pro;

Confirm above report.
Autocomplete of "to" field offers list; down-arrow to required entry; Tab reverts to first result.

Always reproducible.
New to me with this release.
Brian & djn, thanks 4 reporting/confirming.

This is a keyboard-only variant of bug 1107844, involving [cursor down] and [cursor right](!) for selection of desired contact from autocomplete dropdown results, then upon confirming with tab/enter, results are reverted to 1st match from results list.

Magnus, does your patch in bug 1043310 fix this?

(In reply to djn from comment #1)
> TB 31.3.0 installed 19/12/2014; Windows 7 Pro;
> 
> Confirm above report.
> Autocomplete of "to" field offers list; down-arrow to required entry; [*] Tab
> reverts to first result.

No, only if you also use cursor-right where I added the [*] mark.
Just tabbing out directly after cursor-down keeps the correct address.

> Always reproducible.
> New to me with this release.

Yes.
Severity: normal → critical
Status: UNCONFIRMED → NEW
Depends on: 1107844, 1043310
Ever confirmed: true
Flags: needinfo?(mkmelin+mozilla)
Keywords: privacy, ux-trust
OS: Windows 7 → All
Hardware: x86_64 → All
Summary: Compose recipient autocomplete, tabbing selects the wrong recipient → Recipient autocomplete: after selecting result entry with [cursor down],[cursor right], confirming with TAB or ENTER cunningly selects the wrong recipient (1st result)
Also, just [cursor-right] to select *first* autocomplete suggestion having ">>" should normalize that entry, but currently retains "searchwords >>". Is that covered?
Component: Message Compose Window → Address Book

Comment 4

4 years ago
(In reply to Thomas D. from comment #2)
> This is a keyboard-only variant of bug 1107844, involving [cursor down] and
> [cursor right](!) for selection of desired contact from autocomplete
> dropdown results, then upon confirming with tab/enter, results are reverted
> to 1st match from results list.
> 
> Magnus, does your patch in bug 1043310 fix this?

It should make all cases where you blur (leave) the autocomplete widget to use the thing we found and nothing else. AND, if the text in the autocomplete widget is already one of the search results, we make sure not to change the text. So I'd say yes.
Flags: needinfo?(mkmelin+mozilla)

Comment 5

4 years ago
Same result, repeatable:

Type a partial recipient name
Mouse click on one option
Selected address shows in recipient field
Press "Enter"
Address in recipient field reverts to first address in drop-down list

Thunderbird 31.3.0, Windows 7 64-bit.

Updated

4 years ago
Duplicate of this bug: 1116997

Comment 7

4 years ago
Same exact behavior.  Able to work-around by left-clicking on a different object or field to shift the focus to the body of the message.

Thunderbird 31.3.0, Windows 7 64-bit.

Comment 8

4 years ago
Confirm this.
Present in Thunderbird 31.3.0, Windows 7 64-bit, Windows 10 Preview.
Not present in Thunderbird 24.2.x

Comment 9

4 years ago
Duping to bug 1107844 which was the same core issue.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
No longer depends on: 1107844
Resolution: --- → DUPLICATE
Duplicate of bug: 1107844
(Reporter)

Comment 10

4 years ago
Same issue was reopened in bug 1123532.
You need to log in before you can comment on or make changes to this bug.