VP9 crashes in decode_partition

RESOLVED DUPLICATE of bug 1074860

Status

()

--
critical
RESOLVED DUPLICATE of bug 1074860
5 years ago
4 years ago

People

(Reporter: smichaud, Unassigned)

Tracking

({crash, topcrash-mac})

Trunk
All
macOS
crash, topcrash-mac
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

This isn't going to be easy to diagnose.  It seems to happen mostly (entirely?) on very old graphics hardware, on older versions of OS X.

Operating System 	Percentage 	Number Of Crashes
OS X 10.6 	55.56 %	25
OS X 10.7 	31.11 %	14
OS X 10.9 	11.11 %	5
OS X 10.8 	2.22 %	1

Graphics Adapter Report: The number of crashes for a particular signature by graphics vendor and chipset. Vendor 	Adapter 	Report Count 	Percentage
Advanced Micro Devices, Inc. 	M56 ATI MOBILITY /ATI RADEON X1600	18 	40.000 %
Intel Corporation 	02091028 Intel GM965, Intel X3100	11 	24.444 %
Intel Corporation 	HPQ0006 Mobile Intel(R) 945 Express Chipset Family	7 	15.556 %
0x10de 	0x 407	4 	8.889 %
Advanced Micro Devices, Inc. 	M76 ATI MOBILITY /ATI RADEON HD 2600 XT	2 	4.444 %
Intel Corporation 	Mobile Intel 4 Series Chipset Family Intel Mobile Graphic	1 	2.222 %
0x10de 	0x fc6	1 	2.222 %
0x10de 	0x 602	1 	2.222 %
Here's the only patch I can find in the regression range from comment #1 that I think might be relevant here:

http://hg.mozilla.org/mozilla-central/rev/918f4681e3f0

 Bug 1000686 - Enable Media Source Extensions on non-release builds - r=kentuckyfriedtakahe
author	Chris Double <chris.double@double.co.nz>
	Thu Oct 23 15:47:00 2014 +1300 (at Thu Oct 23 15:47:00 2014 +1300)

Tentatively blocking that bug.
Blocks: 1000686

Comment 4

5 years ago
(In reply to Steven Michaud from comment #3)
>  Bug 1000686 - Enable Media Source Extensions on non-release builds -
> r=kentuckyfriedtakahe
> author	Chris Double <chris.double@double.co.nz>
> 	Thu Oct 23 15:47:00 2014 +1300 (at Thu Oct 23 15:47:00 2014 +1300)
> 
> Tentatively blocking that bug.

The reason this bug appears to be the cause is because it enables MSE support for WebM videos. On YouTube these videos are encoded in VP9. As a result much more VP9 video is being exposed to users of nightly before this landed. It's not the cause of the actual bug as VP9 was in use before that, just not at this level.
EXC_BAD_INSTRUCTION sounds like bug 1074860, and I don't see any reports for builds after 20141104030202.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1074860
There have indeed been none of these in m-c builds made since the patch for bug 1074860 landed.  So this really does seem to be a dup, and to have been fixed.
You need to log in before you can comment on or make changes to this bug.