unable to tab to or select radiobuttons in dialogs

VERIFIED WORKSFORME

Status

()

--
critical
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: bugzilla, Assigned: bryner)

Tracking

({access, regression, sec508})

Trunk
access, regression, sec508
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
noticed this while trying to verify bug 67803. was using the following
commercial bits:

linux [rh6.2] - 2001.11.06.12
winNT - 2001.11.06.12
mac os 10.1 - 2001.11.06.08

recipe:
1. bring up the helper app dialog [clicking download link on http://mozilla.org].
2. hit Tab to cycle through the widgets...

results: the cycle is as follows:

* "always ask..." checkbox
* "advanced" button
* "ok" button [skipped if disabled]
* "cancel" button [order of last two buttons reversed on mac]
* a "dead spot"
* "choose" button [skipped if disabled]

in other words, the radio buttons [specifically, the selected radio button] is
skipped in this cycle --should it be focused where i encounter the "dead spot"
above?

moreover, even if i click one of the radio buttons to display the focus ring:
a. i cannot use the up/down arrow keys to change the selection, *and*
b. tabbing still skips the radio button anyhow
(Reporter)

Comment 1

17 years ago
nominating for 0.9.7.
Severity: normal → major
Keywords: mozilla0.9.7
(Reporter)

Comment 2

17 years ago
hey, would this be related bug 107858 perchance?
(Reporter)

Comment 3

17 years ago
ack! it's not limited to the helper app dialog. i now see this in Preferences.

definitely a regression. possible to fix for moz0.9.6?

1. go to the Navigator panel in Prefs.
2. start tabbing.

observe: radio buttons no longer part of tab cycle, nor can you change 'em with
the arrow keys.
Severity: major → critical
Keywords: mozilla0.9.7 → mozilla0.9.6, regression
Summary: unable to tab to or select radiobuttons w/keybd in helper app dlg → unable to tab to or select radiobuttons in dialogs

Updated

17 years ago
Keywords: access, fcc508

Comment 4

17 years ago
This seems to have to do with the focus of the group. What I see is after
clicking on a radiobutton I can arrow once in any direction and the change will
be made, but not after that, until I click on another button. 

When we click we focus the radiobutton first and then select it. When we arrow
we just select it, which does a check to see if the group if focused before
focusing the radio button.

I'll post a patch that fixes the problem, but I'm not sure about how we want to
deal with the group never succeeding the focus test.
(Reporter)

Comment 5

17 years ago
*** Bug 109895 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
pls reference '109895' -- this is still broken with latest 096 drafts... -GA

Comment 7

17 years ago
Is this only broken on the branch? I have a trunk build from yesterday and its
working. I thought this was broken on the trunk last week, but clearly nothing
has happend in this bug.
(Reporter)

Comment 8

17 years ago
i had seen this while using trunk bits.

i'll recheck this with more recent builds...

Comment 9

17 years ago
I thought I saw it in the trunk but it must have been during the brief span that
I had 0.9.6 installed.  WFM in 2001112104 on Win98SE.
(Reporter)

Comment 10

17 years ago
*** Bug 109895 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

17 years ago
worksforme too (current linux build)

Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 12

17 years ago
just a clarification -- 
This was broken in latest-0.9.6 but is fixed in current Nov26_03 build.  -GA
(Reporter)

Comment 13

17 years ago
whew, dunno what happened, but it is indeed working again. vrfy'd using
2001.11.27-comm bits on linux, mac os x and winnt.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 14

17 years ago
*** Bug 115193 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.