Firefox is refusing to close and takes a lot of CPU until I kill the process.

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Allard, Unassigned)

Tracking

({hang})

33 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141013200257

Steps to reproduce:

I watched a couple of video's on YouTube with the HTML5 player on.


Actual results:

For some reason the browser wouldn't load anymore video's and I had to quit Firefox. I soon discovered that Firefox still was running in the background and taking a lot of CPU, probably max. 70%.

As I can tell, this only happens to me when I play random video's on YouTube, It's not always happens tough.


Expected results:

The browser should have been closed when I clicked the quit button.

Comment 1

3 years ago
Thanks for the report.

Some thing you could try to narrow down the problem:
1) Test in a clean profile https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
2) Make sure you disabled all plugins in the new profile (such as flash and java)
3) Disable hardware acceleration https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems#w_turn-off-hardware-acceleration
4) Test with the latest development version (still using the test profile): http://nightly.mozilla.org/
5) If the problem still persists, obtaining the debugging symbols <https://developer.mozilla.org/en/docs/Using_the_Mozilla_symbol_server#Downloading_symbols_on_Linux_Mac_OS_X> and trying to figure out what's happening during shutdown with gdb might be the way to figure this out.
Flags: needinfo?(allardpruim92)

Updated

3 years ago
Keywords: hang
(Reporter)

Comment 2

3 years ago
Ok I'm a little bit further now. Seems like it really is something with HTML5 because Flash works absolutely fine on YouTube. As soon as I enable the HTML5 player in YouTube the problem seems to be back. However it doesn't always happens and it worked fine until Firefox 33 came out.

A new profile doesn't work, I tried that several times. I also disabled all my plugins and that doesn't solve the problem as well. I haven't tried to disable hardware acceleration yet, so I will leave that as last.
Flags: needinfo?(allardpruim92)

Comment 3

3 years ago
I'm experiencing more or less the same issue with Firefox 36.0.1 on Xubuntu 14.10 x86_64 after visiting certain websites (phoronix.com is one of the triggers) the CPU usage will go op to 12% and remain at that level constantly. 
Closing Firefox the normal way doesn't kill the process, it will remain active and consume 12% of CPU resources, i have to manually kill the process to completely shutdown Firefox.

Comment 4

3 years ago
Turns out we have a simpler way to get a stack trace from hung Firefox on Linux: https://developer.mozilla.org/en-US/docs/How_to_Report_a_Hung_Firefox

I don't know of a way to get troubleshooting info about videos, so this seems like the best chance to get additional information that might shed some light on the source of the problem.
Flags: needinfo?(allardpruim92)
(Reporter)

Comment 5

3 years ago
Strange, as today in Firefox 36 and foreword this doesn't seem to be happening anymore.

Comment 6

2 years ago
Based on comment 5. REOPEN this bug if it happened again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(allardpruim92)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.