Groups and Functional areas are only available to vouched users, but are shown to unvouched users

VERIFIED FIXED

Status

Participation Infrastructure
Phonebook
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: lizzard, Assigned: koddsson)

Tracking

2014-12.6

Details

(Whiteboard: [needsAutomation])

Attachments

(1 attachment)

Created attachment 8512269 [details]
mozillians-unvouched.png

Currently, unvouched users see links on the Mozillians home page that offer to show them Functional Areas and Groups that will show them how to help out. But they can't actually see the functional areas and groups if they are unvouched. I think this is confusing for new contributors. Is this intentional?
It was intentional -- ?needsinfo? williamr -- do we wish to improve this experience/workflow?
Flags: needinfo?(williamr)
OS: Mac OS X → All
Hardware: x86 → All
Duplicate of this bug: 1101010
Assignee: nobody → koddsson
Flags: needinfo?(williamr)
After a brief discussion with :williamr it looks like we want this kind of workflow.
:koddson opened a PR here: https://github.com/mozilla/mozillians/pull/1114

Comment 4

3 years ago
Commits pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/5d29c0560d7739084bf7c7e7e5737a387d0507b1
[fix bug 1089894] Hide homepage links for non vouched users.

https://github.com/mozilla/mozillians/commit/6dfc05593c191a3b94ad7f1e3a90fd3c577fb6de
Merge pull request #1122 from johngian/1089894

[fix bug 1089894] Hide homepage links for non vouched users.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Version: other → next

Updated

3 years ago
Whiteboard: [needsAutomation]
Verified this has been fixed in the following:
-Firefox (34.0.5)/Mac
-Chrome (39.0.2171.95)/Mac

Environments:
-mozillians-dev.allizom.org
-mozillians.allizom.org

Steps to verify:
1. I logged in as a non-vouch user in the Phonebook.
2. In the homepage, I verified that the links did not take the non-vouched user to either the functional-areas or groups page. 
3. Some new text has been added in the home page: "Become vouched and you can browse functional areas!" and "Become vouched and you can browse groups!"
4. Clicking on the word 'vouch' in this new text takes the user to the vouch wiki page (https://wiki.mozilla.org/Mozillians/Vouching)
5. I also verified that nothing broke for the signed-in vouched user. Still working as before.
Status: RESOLVED → VERIFIED
Version: next → 2014-12.6
You need to log in before you can comment on or make changes to this bug.