If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Volume warning toast has no text

RESOLVED DUPLICATE of bug 1088271

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 1088271
3 years ago
3 years ago

People

(Reporter: tchevalier, Unassigned)

Tracking

({regression})

unspecified
x86_64
Linux
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8512300 [details]
Flame 2.2, French

On (at least master), the screen to prevent from hearing damages is completely blank.
We should check if it reproduces on 2.1 and block accordingly.

STR:
Flash a 2.2 build
2. Connect headphones
3. Open FMRadio with high volume

Actual result:
Empty screen + button

Expected:
There's text :)


Gaia-Rev        0888735b2c5932624808147b85a60d698d9d7352
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/da125623d9cb
Build-ID        20141027113017
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880
(Reporter)

Comment 1

3 years ago
2.1 doesn't seem affected (WFM on latest Keon build)
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
(Reporter)

Comment 2

3 years ago
Well… It seems to affect a lot of different areas. Different screens are blank.
I'm pretty sure there is already a bug opened somewhere.
CCing Gandalf and Stas, there's a lot of clean-up work going on on master for l10n.js, they might know if it's related.
Is it reproducible on en-US? Is it reproducible on pseudolocale?
Testing 2.1 locales against master doesn't make sense.

I'll look into that tomorrow if Stas will not to get to this before me.
(In reply to Zibi Braniecki [:gandalf] from comment #4)
> Is it reproducible on en-US? Is it reproducible on pseudolocale?
> Testing 2.1 locales against master doesn't make sense.

I wouldn't have many doubts given the reporter ;-)

@theo
Where else do you see the issue?
(Reporter)

Comment 6

3 years ago
(In reply to Francesco Lodolo [:flod] from comment #5)
> (In reply to Zibi Braniecki [:gandalf] from comment #4)
> > Is it reproducible on en-US? Is it reproducible on pseudolocale?
> > Testing 2.1 locales against master doesn't make sense.

Who said French is a 2.1 locale on master? :)

> 
> @theo
> Where else do you see the issue?

So far, what I see blank:

- Buttons on the permission prompt at first launch of Camera app (will attach screenshot)
- Screens to apply the downloaded OTA + Update notification (Seen on Flame, but can't repro on Keon 2.2)
(Reporter)

Comment 7

3 years ago
Created attachment 8512670 [details]
Geoloc prompt, Camera
(Reporter)

Comment 8

3 years ago
(In reply to Zibi Braniecki [:gandalf] from comment #4)
> Is it reproducible on en-US? Is it reproducible on pseudolocale?

Tested the Geoloc prompt, can't repro with en-US not accented english.
(Reporter)

Comment 9

3 years ago
s/not/nor
Théo, is there anything suspicious-looking in:

  adb logcat | grep L10nError
  adb logcat | grep "JavaScript"

?
I can reproduce the empty dialog on volume warning, but not the Geolocation permission or the OTA update.

In my case I flashed Gaia on the device, are you using the stock build?

Gaia-Rev        f17630d89679e159e0af31516a4b7b9d5e938716
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/88adcf8fef83
Build-ID        20141023040204
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880
(Reporter)

Comment 12

3 years ago
(In reply to Francesco Lodolo [:flod] from comment #11)
> I can reproduce the empty dialog on volume warning, but not the Geolocation
> permission or the OTA update.
> 
> In my case I flashed Gaia on the device, are you using the stock build?
> 
> Gaia-Rev        f17630d89679e159e0af31516a4b7b9d5e938716
> Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/88adcf8fef83
> Build-ID        20141023040204
> Version         36.0a1
> Device-Name     flame
> FW-Release      4.4.2
> FW-Incremental  39
> FW-Date         Thu Oct 16 18:19:14 CST 2014
> Bootloader      L1TC00011880

Yes, stock build from ftp for Flame, and GP build for Keon
NI myself to try to reproduce it today
Flags: needinfo?(gandalf)
This seems like it is a dupe of bug 1088271
That is a dupe.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(gandalf)
Resolution: --- → DUPLICATE
Duplicate of bug: 1088271
You need to log in before you can comment on or make changes to this bug.