[Midori 2.0][Wi-Fi]Can't import certificate by "Manage certificates"

RESOLVED WONTFIX

Status

P2
normal
RESOLVED WONTFIX
4 years ago
9 months ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Mozilla Build ID: 20140916000205
 Created an attachment (id=979957)
 PIC
 
 DEFECT DESCRIPTION:
 Can't import certificate by "Manage certificates"
 
  REPRODUCING PROCEDURES:
 1.Settings->Wi-Fi->Manage certificates->Import certificate
 2.can't import certificate file-->KO
 
 中文:
 1.Settings->Wi-Fi->Manage certificates->Import certificate
 2.不能导入证书-->KO
  EXPECTED BEHAVIOUR:
 Can import certificate by "Manage certificates"
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

4 years ago
Created attachment 8512404 [details]
PIC

Comment 2

4 years ago
PFX/p12 formate certificates file can't be supported by 2.0. and CER formate certificates file can't be import successfully and it will show that "Certificate import failed, this may be due to a damaged certificate file, for example". 

we want to know why? Please help check it? We also want know that if EAP-TLS can be supported well on ffos 2.0?
(In reply to Wang Rong from comment #2)
> PFX/p12 formate certificates file can't be supported by 2.0. and CER formate
> certificates file can't be import successfully and it will show that
> "Certificate import failed, this may be due to a damaged certificate file,
> for example". 

Please provide you test certificate file, DER-encoded certificate shuold be supported.

> we want to know why? Please help check it? We also want know that if EAP-TLS
> can be supported well on ffos 2.0?

This is under developement and it requires newer version of NSS than 2.0, so EAP-TLS won't be supported in 2.0.

Comment 4

4 years ago
Thank you for your reply. 
If EAP-TLS is not supported in 2.0, then "manage certificates" is for which eap method? or will it not be used in 2.0?

Comment 5

4 years ago
certification file import failure block our test of wpa eap. Need your help. Please give feedback asap.
Thanks.
I think we supports EAP-PEAP and EAP-TTLS mode(without user certificate) in 2.0.

Comment 7

4 years ago
then certification file import is not supported in 2.0?
It's supported but limited to import CA certificate in 2.0.

Comment 9

4 years ago
Now I don't have a CA certificate for test.

Can you provide us one CA certificate for certificate import function test to ensure that it works well.

Thanks.

Comment 11

4 years ago
Thanks.
the last question, I need to confirm that besides eap sim/peap/ttls, is there any other eap method else supported in 2.0 already?
No, just three method you listed.
Note that EAP SIM requires wpa_supplicant to get keys from modem and complete the handshaking without gecko, and TTLS doesn't support authenticate by user certificate/private key.

Updated

3 years ago
Blocks: 1258639

Comment 13

9 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.