Closed Bug 1090152 Opened 7 years ago Closed 7 years ago

Status bar is empty on lockscreen on full screen apps

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S9 (21Nov)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: gmarty, Assigned: mikehenrty)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(4 files)

STR:
1. Launch a fullscreen app (Camera or Cut the Rope)
2. Press the power button twice to display the lockscreen
3. See that the status bar is empty

Expected:
The status bar should show icons.

Reproducible on v2.1 and master
[Blocking Requested - why for this release]:
Regression from v1.4 (Bug 972277)
blocking-b2g: --- → 2.1?
Lockscreen not required with today's Flame nightly channel build.

STR:

1. open camera

notice the black strip on top (icon-less status bar?)
hit home button and watch the icons flash in the black strip before the app closes

Triage group reviewed, blocking+ for regression.
blocking-b2g: 2.1? → 2.1+
Keywords: regression
not sure if this is something your team can help.
Flags: needinfo?(timdream)
Let's see if this is under Gregor's radar first?
Flags: needinfo?(anygregor)
Duplicate of this bug: 1091909
qawanted for branch checks. I'll take a look at 2.1 in the meantime.
Assignee: nobody → mhenretty
Flags: needinfo?(timdream)
Flags: needinfo?(anygregor)
Keywords: qawanted
Duplicate of this bug: 1092282
Tested with Shallow Flash on 319mb using Engineering builds

This bug repro's on Flame KK builds: Flame 2.2 KK, Flame 2.1 KK, 

Actual Results: Empty status bar after tapping power button twice while in the camera app or other fullscreen apps.

Repro Rate: 4/4

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141031062029
Gaia: a07994714f0552f89801d6097982308d8b0a1ee1
Gecko: 21fbf1e35090
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141031025654
Gaia: 224dfde17af943b583aa0a97936343c7267c7996
Gecko: 12a56ce89cb9
Version: 34.0 (2.1) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

-----------------------------------------------------------------
-----------------------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.0 KK

Actual Result: Status bar icons do not disappear when checking the lockscreen after running a fullscreen app.

Repro Rate: 0/4

Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141030181855
Gaia: 7b8df9941700c1f6d6d51ff464f0c8ae32008cd2
Gecko: 82a6ed695964
Version: 32.0 (2.0) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: croesch
Whiteboard: [systemsfe]
Target Milestone: --- → 2.1 S8 (7Nov)
Caused by bug 1081319, ie if we backout [1] the problem is fixed. Yura, can you take a look here?

1.) https://github.com/mozilla-b2g/gaia/commit/7c7eecb8f445698cd04f1b8f8a3904d135456f50
Assignee: mhenretty → nobody
Blocks: 1081319
Flags: needinfo?(yzenevich)
See Also: → 1088723
Hi Gregor, Yura is taking PTO. Should we find someone to fix this bug? Or just roll back the patch causing problems.
Flags: needinfo?(anygregor)
David, is there anyone else in your team that can take a look at this regression during Yura is out?
Flags: needinfo?(anygregor) → needinfo?(dbolter)
Yep! Eitan is your man!
Flags: needinfo?(yzenevich)
Flags: needinfo?(eitan)
Flags: needinfo?(dbolter)
(In reply to Ken Chang[:ken] from comment #11)
> Hi Gregor, Yura is taking PTO. Should we find someone to fix this bug? Or
> just roll back the patch causing problems.

Unfortunately, we can't just roll back the patch on bug 1081319 since that one is also a 2.1 blocker. Let's get a fix for this.
I'm going to try and get to this today. I'll reach out if I need help.
Assignee: nobody → mhenretty
Flags: needinfo?(eitan)
Kevin, or Alive, either of you have time for a review?
Attachment #8517132 - Flags: review?(kgrandon)
Attachment #8517132 - Flags: review?(alive)
Comment on attachment 8517132 [details] [review]
[Gaia PR] hide icons in secure app, not lockscreen

Since we're investigating this.. Something that used to happen was that the icons used to animate downward with your drag. Do you know why this is missing, and do you think we could restore it? It kind of sucks that it's not there, and it's distracting to see the icons flash in after you pull down the bar.
Flags: needinfo?(mhenretty)
Attachment #8517132 - Flags: review?(kgrandon)
I think what you are referring to is how the date in the upper left used to animate downward. The icons did not animate (except for the notification count), and the utility tray bar did immediately appear just like it does now. However, I agree with you that it is much more jarring now because the animation is missing and the utility tray bar is a completely different color than most statusbars. The net effect is that it looks like the utility tray just pops in more so than before. The transition went with the utility tray refresh in bug 1038723.

I agree that we should restore this (at least the date part), but it's pretty late in the 2.1 game to polish things like this. Also, the work for this shouldn't be done in this bug. I have filed bug 1094459 to track that.
Flags: needinfo?(mhenretty)
No, I am definitely referring to the icons. In fullscreen apps the icons used to come down with the statusbar, instead of come in after the transition. I think the accessibility work broke this, and it's something that we should fix.
Ah you are right! I didn't realize you meant the statusbar transition on fullscreen apps, and yeah that does look bad. I'll take a look.
(In reply to Kevin Grandon :kgrandon from comment #19)
> No, I am definitely referring to the icons. In fullscreen apps the icons
> used to come down with the statusbar, instead of come in after the
> transition. I think the accessibility work broke this, and it's something
> that we should fix.

Yup, that was caused by bug 1045017, specifically the not(.minimized-tray) part in [1]. I am hesitant to remove that, since I'm not sure why it's there and I might cause another regression. Since Yura is on PTO, I filed bug 1094506 to triage and work on separately.

1.) https://github.com/mozilla-b2g/gaia/commit/60be8b2a07fe250f96fc0379a63ec36b909c0900#diff-19076406e0c835797eb201e0143532c7R52
Comment on attachment 8517132 [details] [review]
[Gaia PR] hide icons in secure app, not lockscreen

Kevin is looking!
Attachment #8517132 - Flags: review?(alive)
Attachment #8517132 - Flags: review?(kgrandon)
I'm confused with all of the resolved bugs in comment 18 and comment 21.

Mike - where is the bug which would track the work to make the icons come down with the statusbar? I still think that this should be the same fix.
Flags: needinfo?(mhenretty)
(In reply to Kevin Grandon :kgrandon from comment #23)
> I'm confused with all of the resolved bugs in comment 18 and comment 21.
> 
> Mike - where is the bug which would track the work to make the icons come
> down with the statusbar? I still think that this should be the same fix.

That's bug 1094351. I duped the bug I filed (bug 1094506) with it, since that one was filed by QA earlier and had a regression window already.
Flags: needinfo?(mhenretty)
Hmm, sounds like bug 1094351 might be more of a dupe of this bug?
See Also: → 1094351
Target Milestone: 2.1 S8 (7Nov) → 2.1 S9 (21Nov)
Duplicate of this bug: 1094126
Comment on attachment 8517132 [details] [review]
[Gaia PR] hide icons in secure app, not lockscreen

So the code looks fine here, but I really don't want to leave an R+ here because I don't think we should land this without fixing the slide-down appearance at the same time. I suppose this could be done in a different bug, but I want to make sure that this is the right approach, so I want to review both at the same time. If this is bug 1094351 then I will definitely keep an eye on that bug.

Sorry for being a pain here, I just definitely want to make sure that we're on track to land the proper appearance transition. I'd be more than happy to review this one + bug 1094351 when it's ready. Maybe bug 1094351 should rebase on top of this patch?
Attachment #8517132 - Flags: review?(kgrandon) → feedback+
Duplicate of this bug: 1094351
After further investigation, bug 1094351 is indeed a duplicate of this bug. But the transition problem mentioned in comment 19 and 27 is a separate problem caused by bug 1045017, and I reopened bug 1094506 to track it.

I also don't think we should block this bug on that problem for two reasons. First, the statusbar transition problem existed for almost two months before it was found during the review of this fix. This patch only restores things to how they worked before bug 1081319 but after bug 1045017 landed. Second, it's a non-trivial fix because after bug 1045017 landed, the statusbar icons no longer live in the minimized-tray statusbar. So if we use css to display the statusbar icons when transitioning the statusbar on pull-down, the icons don't move with the statusbar but instead immediately show up in their final place. Some statusbar rework will have to be done to get them to transition properly again. I do think we should fix this, but probably not in 2.1.

In any case, I know you probably disagree here, but I think we need to make a blocking decision on bug 1094506 separately from this fix.
Comment on attachment 8517132 [details] [review]
[Gaia PR] hide icons in secure app, not lockscreen

I'm hesitant to R+ this because I still strongly believe that we should not land this as-is, without the sliding icons as we used to have.

I think we did a really bad job at landing the accessibility patch, and we need to do a much more careful review pass for these kinds of things in the future.

I'll leave an R+ to fix the blocker for now though. Thanks for the patch.
Attachment #8517132 - Flags: feedback+ → review+
master: https://github.com/mozilla-b2g/gaia/commit/12e2da14efee4fa564759ef64038b6c6cfe4a04b
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Attached file [Gaia v2.1 PR]
[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Bug 1081319.

[User impact] if declined:
Poor UX, statusbar icons will disappear sometimes.

[Testing completed]:
Manual testing, and added integration test.

[Risk to taking this patch] (and alternatives if risky):
CSS only change that is really specific to bug scenario. Low risk of making the situation any worse.

[String changes made]: none.
Attachment #8523173 - Flags: approval-gaia-v2.1?
Verified the issue is fixed on 2.2 Master Flame

Status bar is shown with icons

"Flame 2.2

Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141117040203
Gaia: ddf5b92f43ec27c93ad4fea4fd1207da8936b8e7
Gecko: 21b745197618
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0"
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Attachment #8523173 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Attached video VIDEO0064[1].mp4
This issue still occurs on Flame 2.1
Gaia-Rev        f8d3bf44029e0afc0124600a4bb34dba8fc1ad21
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/f70a67a7f846
Build-ID        20141120001207
Version         34.0
Device-Name     flame
FW-Release      4.4.2
STR:
1. Launch a fullscreen app (Camera or Cut the Rope)
2. Press the power button twice to display the lockscreen

Actual:
See that the status bar is empty

Expected:
The status bar should show icons.
Attached file logcat.txt
This log is for comment 35.
Happen time 10:50
Flags: needinfo?(jocheng)
Flags: needinfo?(jocheng) → needinfo?(hlu)
This issue is verified fixed on on today's nightly Flame 2.1 build. The result from Comment 35 might be before the 2.1 patch was actually landed. 

Result: The status bar icons are displayed properly on the lockscreen from a fullscreen app (tested with Camera, Gallery, Video).

Device: Flame 2.1 (319mb, KK, Shallow Flash)
BuildID: 20141121001202
Gaia: 6c739275e963465658c18c7a9ebaa48cbe927d34
Gecko: 9bfc7a166a94
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: needinfo?(hlu)
You need to log in before you can comment on or make changes to this bug.