If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bad interaction firefox 31.2.0 gmail and file download in Centros 5 GNU/Linux 2.6.18-371.12.1.el5

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: bill, Unassigned)

Tracking

31 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20141015050500

Steps to reproduce:

Firefox upgraded approx 1 week ago. Download works ok before using gmail. (As before
upgrade of firefox). Eg can download .png fine. After click on save attachment button
get zero length file of right name created in home directory and as far as firefox is concerned download never completes. From this point out cannot down load in firefox
outside gmail either. Problem first  noticed yesterday evening.


Actual results:

It appears file download dialogue box was created underneath firefox window. After it was
cancelled the following crash dump appeared on x-term used to start firefox:
which firefox
/opt/ucl/bin/firefox
% /opt/ucl/bin/firefox -v
Mozilla Firefox 31.2.0
% *************************
A coding exception was thrown in a Promise resolution callback.

Full message: TypeError: can't access dead object
See https://developer.mozilla.org/Mozilla/JavaScript_code_modules/Promise.jsm/Promise
Full stack: continueSave@chrome://global/content/contentAreaUtils.js:324:7
internalSave/<@chrome://global/content/contentAreaUtils.js:301:7
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:863:11
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:742:7

*************************

On restarting firefox it starts with "well this is embarrassing" off white screen
(Reporter)

Comment 1

3 years ago
"well this is embarrassing" screen only appears sometimes. I.e. it did not come up last time
(when I filed this bug report)
(Reporter)

Comment 2

3 years ago
Problem seems specific to firefox 31.2.0
ie on another machine Mozilla Firefox 24.8.0 (uname -a
Linux 2.6.32-431.29.2.el6.x86_64 #1 SMP Tue Sep 9 13:45:55 CDT 2014 x86_64 x86_64 x86_64 GNU/Linux )
behaves ok with gmail.
On the original machine Mozilla Firefox 31.1.0 behaves ok with gmail
(https://mail.google.com/mail/....)
Bill
(Reporter)

Comment 3

3 years ago
(In reply to bill from comment #2)

> ie on another machine Mozilla Firefox 24.8.0 (SL6 uname -a
> Linux 2.6.32-431.29.2.el6.x86_64 #1 SMP Tue Sep 9 13:45:55 CDT 2014 x86_64
> x86_64 x86_64 GNU/Linux )
(Reporter)

Comment 4

3 years ago
Hmm the bug is not just in 31.2.0 :-(
Get the same problem with the current version (thought to be 31.0 but see bug 1090355)
on downloading a different file from a non-GMAIL page. The offending page is a mixture
of html and javascript which contains a microsoft word document called 
SueBlackCVMay2014-2page-cv-gggp.doc but on screen the file's name is displayed without the .doc
(another microsoft word document on the same page is displayed with the .doc and downloaded
without problem before I attempted to download SueBlackCVMay2014-2page-cv-gggp.doc
(of course afterwards nothing downloads).
Will try and upload screen shot bugzilla_1090200_sue.png

Notice problem in gmail was related to a .zip file from Japan whose file name contains
non-ascii characters: 写真 2014-10-22 18 11 05 (800x598).zip

Bill
(Reporter)

Comment 5

3 years ago
Created attachment 8512822 [details]
fragement of screenshot of sensitive page show appearence of file name

Fragement of HTML relating to screen shot fragement. Notice no ".doc" in
displayed file name 

</tr><tr class="e4TableValueDark">
				<td>
						<a id="ctl00_cphEdit_dgDataItems_ctl03_hypGridEdit" title="view SueBlackCVMay2014-2page-cv-gggp.doc" href="https://je-s.rcuk.ac.uk/JeS2WebSite/secure/DocEdit/Attachments.aspx?did=1476493&amp;sdcid=21423&amp;ScreenMode=Edit&amp;ItemIndex=1">view</a>
					</td><td>
						<a id="ctl00_cphEdit_dgDataItems_ctl03_hypAttachmentView" href="https://je-s.rcuk.ac.uk/JeS2WebSite/secure/DocEdit/AttachmentViewer.aspx?did=1476493&amp;sdcid=21423&amp;ScreenMode=Edit&amp;ItemIndex=1">SueBlackCVMay2014-2page-cv-ggg</a>
					</td><td>Public understanding consultant: Sue Black: 2-page CV</td><td>N/A</td><td align="right">69 kb</td><td>
						
					</td>
			</tr>
(Reporter)

Comment 6

3 years ago
hmm another random idea;-) Firefox always starts with my home page
http://www.cs.ucl.ac.uk/staff/W.Langdon/ but at present it contains a link which
does not complete but takes a very long time to time out. May be failure of some
down loads to complete is related to firefox still waiting for missing image to timeout?
Bill
(Reporter)

Comment 7

3 years ago
hmm to confirm it also happens with Firefox ESR 31.1.0
(I have another gmail example today)
Bill
(Reporter)

Comment 8

3 years ago
Created attachment 8514265 [details]
bugzilla_1090200_embarrassing.png screen shot of opening firefox message

When the problem is manifest on closing firefox I get a caution box saying (something like)
"cancel download_1", when I accepted it firefox shuts down. When I immediately restart firefox
I get usually get a box saying "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system".
After a few more attempts firefox usually restarts, sometimes with a "well this is embarrassing"
message. I am attaching a screenshot of it.
(Reporter)

Comment 9

3 years ago
Created attachment 8514274 [details]
bugzilla_1090200_cancel_1_download.png screen short of caution box on shutdown

It looks like the non-termination of loading my home page 
http://www.cs.ucl.ac.uk/staff/W.Langdon/
on start up was a red-herring. Ie I have commented out the load of image on
a site which is offline so the start page quickly completes but today's
problem with gmail continues.
  I am uploading a screen shot of an example warning which occurred on clean
shutdown (using power off icon) of firefox.
Bill
(Reporter)

Comment 10

3 years ago
Now running Firefox ESR 31.3.0
gmail version not known
This download problem has not been seen for some weeks.
Bill

Comment 11

2 years ago
Based on Comment 10 this bug will have the status Resolved - Worksforme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.