crash in java.lang.NullPointerException: at org.mozilla.gecko.RestrictedProfiles.getInGuest(RestrictedProfiles.java)

RESOLVED DUPLICATE of bug 1078395

Status

()

Firefox for Android
General
--
critical
RESOLVED DUPLICATE of bug 1078395
4 years ago
4 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({crash})

36 Branch
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(firefox35 affected, firefox36 fixed, fennec35+)

Details

(crash signature)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-bba07a92-5e3b-49c8-b0b7-b452c2141027.
=============================================================

java.lang.NullPointerException
	at org.mozilla.gecko.RestrictedProfiles.getInGuest(RestrictedProfiles.java:41)
	at org.mozilla.gecko.RestrictedProfiles.isAllowed(RestrictedProfiles.java:176)
	at org.mozilla.gecko.RestrictedProfiles.isAllowed(RestrictedProfiles.java:161)
	at org.mozilla.gecko.preferences.GeckoPreferences.setupPreferences(GeckoPreferences.java:730)
	at org.mozilla.gecko.preferences.GeckoPreferences.setupPreferences(GeckoPreferences.java:620)
	at org.mozilla.gecko.preferences.GeckoPreferenceFragment.onCreate(GeckoPreferenceFragment.java:81)
	at android.app.Fragment.performCreate(Fragment.java:1678)
	at android.app.FragmentManagerImpl.moveToState(FragmentManager.java:859)
	at android.app.FragmentManagerImpl.moveToState(FragmentManager.java:1062)
	at android.app.FragmentManagerImpl.moveToState(FragmentManager.java:1044)
	at android.app.FragmentManagerImpl.dispatchCreate(FragmentManager.java:1848)
	at android.app.Activity.onCreate(Activity.java:902)
	at android.preference.PreferenceActivity.onCreate(PreferenceActivity.java:523)
	at org.mozilla.gecko.preferences.GeckoPreferences.onCreate(GeckoPreferences.java:339)
	at android.app.Activity.performCreate(Activity.java:5231)
	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1087)
	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2169)
	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2264)
	at android.app.ActivityThread.access$800(ActivityThread.java:144)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1205)
	at android.os.Handler.dispatchMessage(Handler.java:102)
	at android.os.Looper.loop(Looper.java:136)
	at android.app.ActivityThread.main(ActivityThread.java:5139)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:515)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:796)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:612)
	at dalvik.system.NativeStart.main(Native Method)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1078395
tracking-fennec: ? → 35+
Updating status to match that of bug 1078395.
status-firefox35: --- → affected
status-firefox36: affected → fixed
You need to log in before you can comment on or make changes to this bug.