Closed Bug 1090273 Opened 7 years ago Closed 7 years ago

Attempting to merge mozilla-central to project repo metro never completes

Categories

(Developer Services :: Mercurial: hg.mozilla.org, defect)

x86_64
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jimm, Unassigned)

References

Details

Attachments

(1 file)

885.57 KB, application/x-zip-compressed
Details
STR:

1) checkout the metro project repo
2) merge mozilla-central over
3) hg push

result:

$ hg push
pushing to ssh://hg.mozilla.org/projects/metro
searching for changes

I see a burst of upload traffic for about thirty seconds, then transfers seem to stall. I've let this sit for about three hours without the push completing.

There are some engineers working with the metro repo on touch input, so it would be great if we could this looked at asap. We haven't been able to merge it for about three months due to bugs on mc. Those have all been fixed, now we just need to get mc merged over so we have a stable build via the metro repo.
If need be the metro repo can be blown away and recloned off mc.
Whiteboard: [kanban:engops:https://kanbanize.com/ctrl_board/6/600]
Please attach console output from all broken hg command invocations. In this case, `hg push` or `hg --debug push` (although the latter will be very verbose). I'd like to see at what point things are hanging. I have my suspicions...
Flags: needinfo?(jmathies)
Blocks: 1090345
Attached file push.zip
I waited until the uplifting stopped, and the log stopped growing.
Flags: needinfo?(jmathies)
This smells like the Mercurial server being lethargic. I already filed one bug that could be the root cause (and we should fix regardless). The other root cause is repository sync is running synchronously and being very slow.

Let this run for at least 15 minutes (if not longer). I have a suspicion that it will eventually complete.
(In reply to Gregory Szorc [:gps] from comment #4)
> This smells like the Mercurial server being lethargic. I already filed one
> bug that could be the root cause (and we should fix regardless). The other
> root cause is repository sync is running synchronously and being very slow.
> 
> Let this run for at least 15 minutes (if not longer). I have a suspicion
> that it will eventually complete.

Hrm, I already tried that, for about two hours this morning. I'll try again when I have a really big time window.
I was able to push a merge just fine. It took 10 minutes. But it went through. https://hg.mozilla.org/projects/metro/pushloghtml?changeset=478f5dc91b6f

What version of Mercurial are you using? I'm on 3.2rc. If you are anything older than 3.1.2, please upgrade ASAP.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(jmathies)
Resolution: --- → WORKSFORME
(In reply to Gregory Szorc [:gps] from comment #6)
> I was able to push a merge just fine. It took 10 minutes. But it went
> through.
> https://hg.mozilla.org/projects/metro/pushloghtml?changeset=478f5dc91b6f
> 
> What version of Mercurial are you using? I'm on 3.2rc. If you are anything
> older than 3.1.2, please upgrade ASAP.

Hmm, I guess I'm out of date, although I'm pretty sure I'm using the latest mozilla-build.

$ hg --version
Mercurial Distributed SCM (version 2.9.1)
(see http://mercurial.selenic.com for more information)

Copyright (C) 2005-2014 Matt Mackall and others
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


Regardless, thank you for the help!
Flags: needinfo?(jmathies)
Whiteboard: [kanban:engops:https://kanbanize.com/ctrl_board/6/600]
You need to log in before you can comment on or make changes to this bug.