Zooming does not work properly and the background is black in Google Maps while HWA is enabled

RESOLVED FIXED in Firefox 34

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: cbadau, Unassigned)

Tracking

34 Branch
mozilla36
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(firefox33+ wontfix, firefox34+ fixed, firefox35+ verified, firefox36+ fixed)

Details

Attachments

(1 attachment)

Reproducible on Firefox 34 Beta 4 (buildID: 20141027152126)
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

Steps to reproduce:
1. Launch Firefox.
2. Go to Google Maps (http://www.google.com/maps/preview/?force=webgl). 
3. Switch to Earth mode and zoom in/zoom out. 
4. Resize the Firefox window. 

Expected results: Map is zoomed in correctly and text labels, markers are displayed as expected.

Actual results: 
After step 3, with HWA enabled, zooming does not work properly in Earth mode: zooming only applies to the text (e.g. street names) displayed on top of the background (if HWA is disabled, zooming works properly in Earth mode). 
After step 4, the background of Earth mode is changed to a flat black while HWA is enabled. 
screencast: http://recordit.co/nX4upVQfqy. 

Additional informations: 
1. On Windows 7 64bit (NVIDIA GeForce 210):
- the bug is reproducible with Fx 33.0, Fx 34.0b2 as well (HWA enabled)
- the bug is NOT reproducible with  Fx 32.0.1 (build2 / buildID: 20140911151253, HWA enabled)
2. On Windows 7 64 bit (NVIDIA GeForce 610), the bug is not reproducible on Firefox 34.0b4.  
3. On Windows 8.1 64 bit (Intel HD 2500):
- the bug is reproducible with Fx 33.0, Fx 33.0.2, Fx 34.0b3 as well (HWA enabled)
- the bug is NOT reproducible with Fx 31.0(build2), Fx 32.0.3
4. On Windows 8.1 32 bit (ATI Radeon 3000):
- the bug is reproducible with Fx 34.0b1, Fx 34.0b2, Fx 34.0b3 as well (HWA enabled)
- the bug is NOT reproducible with Fx 31.0(build2), Fx 32.0.3, Fx 33.0, Fx 33.0.2(build2)
[Tracking Requested - why for this release]: This seems likely to affect many users.
status-firefox34: --- → affected
tracking-firefox34: --- → ?
status-firefox33: --- → affected
status-firefox35: --- → affected
status-firefox36: --- → affected
tracking-firefox33: --- → +
tracking-firefox34: ? → +
tracking-firefox35: --- → +
tracking-firefox36: --- → +
Milan - Another Google Maps graphics related issue. Related to bug 1085203?
Flags: needinfo?(milan)
I imagine so.  Long discussion on mozilla-google-discuss on this.
Flags: needinfo?(milan)
We need to see if this related to the ANGLE update.
Keywords: regressionwindow-wanted

Comment 5

4 years ago
Reproducible on Firefox 33.1 (buildID: 20141106120505)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Windows 7 64bit (Intel® HD Graphics 2000).

Comment 6

4 years ago
Created attachment 8521189 [details]
Black background on AMO

Comment 7

4 years ago
The problem is not limited to Google Maps, it occurs at many locations. I've just uploaded a screenshot of the AMO entry of AdBlockPlus where you can see black background at the left and the right. This background vanishs after 2 seconds. I had also problems writing a private message in a phpBB powered forum. This was just not possible because the text was overlayed every now and then by a black layer.
We released 33.1. I don't think it is a driver for a 33.1.1.
status-firefox33: affected → wontfix
Testit, thanks for the further report!  What hardware and OS are you using, and which version of Firefox?
Flags: needinfo?(frfxtst)

Comment 10

4 years ago
(In reply to Liz Henry :lizzard from comment #9)
> Testit, thanks for the further report!  What hardware and OS are you using,
> and which version of Firefox?

I'm using a Dell Inspiron 580 with Windows 7 and Firefox 33.1.
Flags: needinfo?(frfxtst)
This seems to be the same as the issue reported in bug 1089139 (marked as a duplicate of 1085203), which seems to have gone away in Firefox 34 Beta 10 with the fix for 1085203. Does that make any sense?
Camelia - Can you still reproduce with 34 beta10?
Flags: needinfo?(camelia.badau)

Comment 13

4 years ago
I just tried ff 34 beta 10. The problem seems to be solved.
The issue is no longer reproducing with Firefox 34 Beta 10. It seems to be resolved.
Flags: needinfo?(camelia.badau)
I verified the issue 
- using latest Nightly 36.0a1(buildID: 20141119030200) - it works ok 
- using latest Firefox Developer Edition 35.0a2 (buildID: 20141119144355) - it doesn't work (zooming does not work properly and the background is black in Google Maps)

I've tested on Windows 7 64bit (Intel HD 2500), Windows 7 64bit (ATI Radeon 3000) and Windows 8.1 32bit (ATI Radeon 3000).
status-firefox34: affected → fixed
Marking this bug as fixed based on comment 15. Note that Aurora is still affected.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox36: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Does this still reproduce in Beta 35?  It looks like bug 1085203 is verified and so this shouldn't be reproducing.
Flags: needinfo?(camelia.badau)
The issue is no longer reproducing with Firefox 35 Beta 5.

I've tested on Windows 7 64bit (Intel HD 2500, ATI Radeon 3000 and NVIDIA GeForce 210), Windows 8.1 32bit (ATI Radeon 3000) and Windows 8.1 64bit (Intel HD 2500).
Flags: needinfo?(camelia.badau)
Marking as Verified on 35 based on comment 17 and comment 18.
status-firefox35: affected → verified
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.