Closed Bug 1090384 Opened 7 years ago Closed 3 years ago

crash in libskia.so@0xfea10

Categories

(Firefox for Android Graveyard :: General, defect)

All
Android
defect
Not set
critical

Tracking

(firefox33 affected, firefox34 affected, firefox35 affected, firefox36 affected)

RESOLVED WONTFIX
Tracking Status
firefox33 --- affected
firefox34 --- affected
firefox35 --- affected
firefox36 --- affected

People

(Reporter: u279076, Unassigned)

Details

(Keywords: crash, topcrash-android-armv7)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-cb593c35-d80e-4fa6-b2d7-f64e92141021.
=============================================================
Ø 0 	libskia.so 	libskia.so@0xfea10 	
Ø 1 	libskia.so 	libskia.so@0x1c72c6 	
Ø 2 	libskia.so 	libskia.so@0xfe70f 	
Ø 3 	libskia.so 	libskia.so@0xfdc8d 	
Ø 4 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x725cd6 	
Ø 5 	libandroid_runtime.so 	libandroid_runtime.so@0x7a1df 	
Ø 6 	libandroid_runtime.so 	libandroid_runtime.so@0xae36a 	
Ø 7 	libandroid_runtime.so 	libandroid_runtime.so@0xad36e 	
Ø 8 	libandroid_runtime.so 	libandroid_runtime.so@0xad216 	
Ø 9 	libandroid_runtime.so 	libandroid_runtime.so@0xad22e 	
Ø 10 	libandroid_runtime.so 	libandroid_runtime.so@0xad376 	
Ø 11 	libandroid_runtime.so 	libandroid_runtime.so@0xad35e 	
Ø 12 	libbinder.so 	libbinder.so@0x1999b 	
Ø 13 	libbinder.so 	libbinder.so@0x22429 	
Ø 14 	libbinder.so 	libbinder.so@0x18d51 	
Ø 15 	libbinder.so 	libbinder.so@0x20455 	
Ø 16 	binder 	binder@0x5a 	
Ø 17 	libbinder.so 	libbinder.so@0x20475 	
Ø 18 	binder 	binder@0x56 	
Ø 19 	libbinder.so 	libbinder.so@0x204bd 	
Ø 20 	binder 	binder@0x56 	
Ø 21 	libbinder.so 	libbinder.so@0x1da07 	
Ø 22 	libbinder.so 	libbinder.so@0x1d323 	
Ø 23 	libbinder.so 	libbinder.so@0x20767 	
Ø 24 	binder 	binder@0x56 	
Ø 25 	binder 	binder@0x5a 	
Ø 26 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x5cc04e 	
Ø 27 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x5cc04e 	
Ø 28 	libc.so 	libc.so@0x10f29 	
Ø 29 	libc.so 	libc.so@0xfe8f 	
Ø 30 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x5cc04e 	
Ø 31 	libc.so 	libc.so@0xdcc7 	
Ø 32 	libstdc++.so 	libstdc++.so@0x91d 	
Ø 33 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x5cc04e 	
Ø 34 	libandroid_runtime.so 	libandroid_runtime.so@0x7a2f1 	
Ø 35 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x5cc04e 	
Ø 36 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc (deleted)@0xc6786 	
Ø 37 	libdvm.so 	libdvm.so@0x1ea12 	
Ø 38 	system@framework@framework.jar@classes.dex 	system@framework@framework.jar@classes.dex@0x5b0ec4 	
Ø 39 	dalvik-zygote (deleted) 	dalvik-zygote (deleted)@0x5f126 	
Ø 40 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x6d9c6e 	
Ø 41 	libdvm.so 	libdvm.so@0x4f6d1 	
Ø 42 	system@framework@framework.jar@classes.dex 	system@framework@framework.jar@classes.dex@0x5b0ebf 	
Ø 43 	libandroid_runtime.so 	libandroid_runtime.so@0x7a28f 	
Ø 44 	libdvm.so 	libdvm.so@0xb22c6 	
Ø 45 	libdvm.so 	libdvm.so@0xb22c6 	
Ø 46 	libdvm.so 	libdvm.so@0x749e7 	
Ø 47 	libdvm.so 	libdvm.so@0xadc7a 	
Ø 48 	libdvm.so 	libdvm.so@0xb22c6 	
Ø 49 	libdvm.so 	libdvm.so@0x2b0ba 	
Ø 50 	libdvm.so 	libdvm.so@0xb22c6 	
Ø 51 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x64fd2e 	
Ø 52 	libdvm.so 	libdvm.so@0xadc7a 	
Ø 53 	dalvik-zygote (deleted) 	dalvik-zygote (deleted)@0x17fe 	
Ø 54 	libdvm.so 	libdvm.so@0x6a889 	
Ø 55 	system@framework@framework.jar@classes.dex 	system@framework@framework.jar@classes.dex@0x2aa082 	
Ø 56 	dalvik-zygote (deleted) 	dalvik-zygote (deleted)@0x5f126 	
Ø 57 	libdvm.so 	libdvm.so@0x1eb7e 	
Ø 58 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x6d9c6e 	
Ø 59 	libdvm.so 	libdvm.so@0x27ea2 	
Ø 60 	libdvm.so 	libdvm.so@0x2f396 	
Ø 61 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc (deleted)@0x5eae 	
Ø 62 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0xc55c3e 	
Ø 63 	libdvm.so 	libdvm.so@0x2f3e6 	
Ø 64 	libdvm.so 	libdvm.so@0xb22c6 	
Ø 65 	libdvm.so 	libdvm.so@0x2f396 	
Ø 66 	libdvm.so 	libdvm.so@0x2ca4a 	
Ø 67 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x668ffe 	
Ø 68 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x2300efe 	
Ø 69 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc (deleted)@0x5eae 	
Ø 70 	system@framework@core.jar@classes.dex 	system@framework@core.jar@classes.dex@0x1fb27a 	
Ø 71 	libdvm.so 	libdvm.so@0x61aff 	
Ø 72 	libdvm.so 	libdvm.so@0x712e1 	
Ø 73 	libdvm.so 	libdvm.so@0xb22c6 	
Ø 74 	libdvm.so 	libdvm.so@0xb25da 	
Ø 75 	libdvm.so 	libdvm.so@0xb25d6 	
Ø 76 	libdvm.so 	libdvm.so@0x61b23 	
Ø 77 	libdvm.so 	libdvm.so@0x5681d 	
Ø 78 	dalvik-mark-stack (deleted) 	dalvik-mark-stack (deleted)@0x9d34f6e 	
Ø 79 	icudt51l.dat 	icudt51l.dat@0xb2b12b 	
Ø 80 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x1f840266 	
Ø 81 	libdvm.so 	libdvm.so@0x5677b 	
Ø 82 	libdvm.so 	libdvm.so@0x5677b 	
Ø 83 	libc.so 	libc.so@0xd242 	
Ø 84 	libc.so 	libc.so@0xd3da 
=============================================================
More reports: https://crash-stats.mozilla.com/report/list?product=FennecAndroid&signature=libskia.so%400xfea10	

This crash currently affects all versions but is highest in Release and Aurora. It is #2 in Aurora @ 5.49% and rising.

All reports currently are with Samsung Nexus 10.
Aaron, Kevin, do either of you have a Nexus 10 to test?
Flags: needinfo?(kbrosnan)
Flags: needinfo?(aaron.train)
These libskia@<address> bugs are a dime a dozen (search Bugzilla); historically trying to reproduce them without steps to reproduce is rather futile.
Flags: needinfo?(aaron.train)
I have a N10 but was not able to reproduce crashing with using Nightly or Aurora. Leaving the needinfo to check loading URLs when I get back to the Bay Area where the device is.

That being said aurora does not have enough users to properly rank the priority of crashes.
I was not able to reproduce this crash using URLs from the last 28 days.
Flags: needinfo?(kbrosnan)
Closing because no crashes reported for 12 weeks.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.