inbox size is large without mail in inbox

VERIFIED WORKSFORME

Status

MailNews Core
Database
VERIFIED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Michael Zimmermann, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5+) Gecko/20011106
BuildID:    20011107

In general most of my mails end up in the inbox folder of the primary
pop3-account. From there mails get deleted or moved to subfolders of "Local Folders"

Moving mails from the inbox to another location doesn't shrink the inbox file
size. Without any mails in the inbox file size is about 33 Mb! Compacting
folders or deleting the .msf-file doesn't help.

This happens with an account that I deleted and reconfigured a while ago. So
there are 2 folder:
- mail.mydomain.abc
- mail.mydomain-1.abc

Looking at the inbox file is seems as if mail-news doesn't delete the old
deleted / moved messages but somehow (how?) marks them as obsolte - do not show.

Reproducible: Didn't try
Steps to Reproduce:

Comment 1

16 years ago
If compacting doesn't help, then there's a problem with compacting -> Navin.
Assignee: bienvenu → naving
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Reporter,
Since you have deleted and recreated this account in that same profile. I hope 
you are looking at the inbox file from the most current which is 
mail.mydomain-1.
How are you compacting that folder.  Have you checked the pref to compact after 
certain size? Or you are using this from the menu item or compact this folder.  

I tried this myself on 2001110709 build on win98. I had my prefs checked to 
compact folder when I start up after the threshold limit exceeds 25kb.  I 
deleted large messages from first pop account inbox as well as 2nd pop account 
inbox. After the compaction I checked the size and the folder was indeed 
compacted.  But I have not reconfigured this profile for these accounts.  I will 
try to do that and report here.

In the meantime can you give some information as to how many accounts you have 
in that profile.  And the prefs that you checked vs unchecked in accounts and 
settings/server?
QA Contact: esther → sheelar
(Assignee)

Comment 3

16 years ago
Are you looking at the correct profile directory? you can verify that by going 
to Edit | MailNews Account settings | Server settings | local directory
(Reporter)

Comment 4

16 years ago
Just checked it:
- My current inbox file is in the mydomain.XYZ folder 
  (and not in   mydomain-1.XYZ)
  Strange....
- Compacting is done using the File -> Compact Folders option; 
  folders are not compacted after they reach a certain size

and

- yes, I am looking at the correct profile directory (there is only one)

My configuration:
3 pop3-accounts; 2 smtp-servers; 
as far as I can tell all prefs in accounts and settings/server are set to
default (Sheela: what prefs are you interested in?)

Comment 5

16 years ago
I don't think this matters what the size of your inbox is. I have a inbox which 
is 48MB and 16MB. I have two pop accounts.  Here is what's happening. We have 
two different scenarios were compaction is not working properly: 

Compact folders is working for the first account.  Because I moved and deleted 
messages from first account inbox as well as second account inbox.  After using 
compact folders from the menu item only first account inbox is compacted

The other scenario I noticed compact folders not working at all on all the 
accounts is when you have focus on any of the local folders we enable compact 
folders. But we don't do anything. In this scenario compaction is not working at 
all.  

commercial build: 2001-11-08-06 win98
(Reporter)

Comment 6

16 years ago
The account mentioned is the first account. Compacting was done while my inbox
of this account was focused. Just tried Compact Folders with the account not
having focus 
-> voila, it worked.

So, we don't have a problem with the inbox size, but rather a bug with compact
folder. 

Regarding scenario 1:
My 2nd pop3-account gets compacted when this account has focus. Could this be a
feature and not a bug?  i. e., onsecond thought, only compacting the account
having focus could make sense....

Comment 7

16 years ago
I was under the impression that menu item Compact Folders would compact all the
folders which needs compaction. Regardless of where the focus is.  We should be
compacting any folders in any account that needs compaction right?

"Compact this folder" with a right click menu should compact only that folder
where the focus is. This could be your local folder, 1st account inbox, 2nd
account inbox etc.  

(Assignee)

Comment 8

16 years ago
Marking this bug as worksforme, given that the reporter can compact his folders
It will compact all folders using File | Compact Folders, but you must have
selected a folder on that account.  
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

16 years ago
If we use right click to compact the selected folder and 'menu->compact folders'
to compact all necessary folders in all accounts then I would suggest to rename
the second to 'compact all folders' This would make it more clear that really
all existing accounts will be affected.

Well, thanks a lot for the fast response and solution and keep up the great work
:) Michael

Comment 10

16 years ago
Reporter,
Log a separate bug for as a request to rename the menu item. Verifying this as 
worksforme since this has worked for the reporter. 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.