Closed Bug 1090504 Opened 6 years ago Closed 6 years ago

Loop-Push — Please deploy pushgo 1.4 to Prod

Categories

(Cloud Services :: Operations: Deployment Requests - DEPRECATED, task)

task
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: rpapa, Assigned: oremj)

References

Details

No description provided.
Depends on: 1082188
Maybe this needs to be called Loop-Push (same with bug 1082188) ?
:rpapa are you wanting Loop-Push Stage and Prod or Simple Push Stage and Prod?
I agree, Loop-Push makes more sense.  changing....
Summary: SimplePush — Please deploy pushgo 1.4 to Prod → Loop-Push — Please deploy pushgo 1.4 to Prod
Should I deploy 1.4rc or 1.4rc2?
Assignee: nobody → oremj
1.4rc2, please. There are fixes for a few regressions caught by the Python tests.
Duplicate of this bug: 1085663
I'll get this going Monday morning. I need to buy an certificate before proceeding.
Note, this is essentially still a testing endpoint.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
(In reply to Jeremy Orem [:oremj] from comment #9)
> Note, this is essentially still a testing endpoint.

Jeremy - 

I realize we'll eventually need to do things like test that load-balancing is working correctly (Bug 1055139#c55), but since we don't really have a working config yet, is there anything I can start to verify here  (i.e. for the push and update endpoints)?
Flags: needinfo?(oremj)
soft-release of 1.4 rc2 planned for next Mon.,11/17
so closing this ticket
Status: RESOLVED → VERIFIED
We are currently on 1.4rc5, which should be deployed to staging/prod.
Ben -
I just realized yesterday that JR had created a ticket for rc2: Bug 1091208 
so I closed out this one.  rc2 is already on stage.
Is there an rc5?  I only see an rc2:  https://github.com/mozilla-services/pushgo/tags
Flags: needinfo?(bbangert)
(In reply to Richard Pappalardo [:rpapa][:rpappalardo] from comment #10)
> (In reply to Jeremy Orem [:oremj] from comment #9)
> > Note, this is essentially still a testing endpoint.
> 
> Jeremy - 
> 
> I realize we'll eventually need to do things like test that load-balancing
> is working correctly (Bug 1055139#c55), but since we don't really have a
> working config yet, is there anything I can start to verify here  (i.e. for
> the push and update endpoints)?

I think we just need to test that the endpoint is working as expected.
Flags: needinfo?(oremj)
The rc5 was cut and deployed. It just needs to be tested to ensure that delivery and internal routing are fully configured and working.
Flags: needinfo?(bbangert)
You need to log in before you can comment on or make changes to this bug.