Intermittent test_bug311007.xul | application crashed [@ XPCNativeSet::Mark()]

RESOLVED DUPLICATE of bug 1061896

Status

()

Core
XPConnect
RESOLVED DUPLICATE of bug 1061896
3 years ago
3 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({crash, intermittent-failure})

Trunk
x86
Windows XP
crash, intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
17:22:05     INFO -  327 INFO TEST-PASS | chrome://mochitests/content/chrome/docshell/test/chrome/test_bug311007.xul | Error page's URI (1)
17:22:05     INFO -  328 INFO TEST-PASS | chrome://mochitests/content/chrome/docshell/test/chrome/test_bug311007.xul | DocShell loaded a document (1)
17:22:05     INFO -  329 INFO TEST-PASS | chrome://mochitests/content/chrome/docshell/test/chrome/test_bug311007.xul | This page is an error page.
17:22:05     INFO -  330 INFO TEST-PASS | chrome://mochitests/content/chrome/docshell/test/chrome/test_bug311007.xul | This is not a secure page (1)
17:22:05     INFO -  331 INFO TEST-PASS | chrome://mochitests/content/chrome/docshell/test/chrome/test_bug311007.xul | A URI on HTTPS (2)
17:22:05     INFO -  332 INFO TEST-PASS | chrome://mochitests/content/chrome/docshell/test/chrome/test_bug311007.xul | DocShell loaded a document (2)
17:22:05     INFO -  333 INFO TEST-PASS | chrome://mochitests/content/chrome/docshell/test/chrome/test_bug311007.xul | This page is not an error page.
17:22:05     INFO -  334 INFO TEST-PASS | chrome://mochitests/content/chrome/docshell/test/chrome/test_bug311007.xul | This is a secure page (2)
17:22:05     INFO -  335 INFO TEST-PASS | chrome://mochitests/content/chrome/docshell/test/chrome/test_bug311007.xul | hashchange on HTTPS (3)
17:22:05     INFO -  336 INFO TEST-PASS | chrome://mochitests/content/chrome/docshell/test/chrome/test_bug311007.xul | We are in the same document as before (3)
17:22:05     INFO -  337 INFO TEST-PASS | chrome://mochitests/content/chrome/docshell/test/chrome/test_bug311007.xul | This page is not an error page.
17:22:05     INFO -  338 INFO TEST-PASS | chrome://mochitests/content/chrome/docshell/test/chrome/test_bug311007.xul | This is a secure page (3)
17:22:05     INFO -  339 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/docshell/test/chrome/test_bug311007.xul | application terminated with exit code 1
17:22:05     INFO -  runtests.py | Application ran for: 0:01:47.211000
17:22:05     INFO -  zombiecheck | Reading PID log: c:\docume~1\cltbld~1.t-x\locals~1\temp\tmpvrhmftpidlog
17:22:14     INFO -  mozcrash Saved minidump as C:\slave\test\build\blobber_upload_dir\0ac5eff4-e073-479f-90a7-7ecffaec1569.dmp
17:22:14     INFO -  mozcrash Saved app info as C:\slave\test\build\blobber_upload_dir\0ac5eff4-e073-479f-90a7-7ecffaec1569.extra
17:22:14  WARNING -  PROCESS-CRASH | chrome://mochitests/content/chrome/docshell/test/chrome/test_bug311007.xul | application crashed [@ XPCNativeSet::Mark()]
17:22:14     INFO -  Crash dump filename: c:\docume~1\cltbld~1.t-x\locals~1\temp\tmp8gc2jo.mozrunner\minidumps\0ac5eff4-e073-479f-90a7-7ecffaec1569.dmp
17:22:14     INFO -  Operating system: Windows NT
17:22:14     INFO -                    5.1.2600 Service Pack 3
17:22:14     INFO -  CPU: x86
17:22:14     INFO -       GenuineIntel family 6 model 30 stepping 5
17:22:14     INFO -       8 CPUs
17:22:14     INFO -  Crash reason:  EXCEPTION_ACCESS_VIOLATION_WRITE
17:22:14     INFO -  Crash address: 0x114076e
17:22:14     INFO -  Thread 0 (crashed)
17:22:14     INFO -   0  xul.dll!XPCNativeSet::Mark() [XPCInlines.h:908b844c13c8 : 452 + 0x5]
17:22:14     INFO -      eip = 0x015d02ed   esp = 0x0012f4f0   ebp = 0x0012f504   ebx = 0x00000010
17:22:14     INFO -      esi = 0x03870480   edi = 0x00008000   eax = 0x01140766   ecx = 0x03870478
17:22:14     INFO -      edx = 0x00000114   efl = 0x00010206
17:22:14     INFO -      Found by: given as instruction pointer in context
17:22:14     INFO -   1  xul.dll!XPCWrappedNativeProto::Mark() [xpcprivate.h:908b844c13c8 : 1874 + 0xa]
17:22:14     INFO -      eip = 0x015d0308   esp = 0x0012f4fc   ebp = 0x0012f504
17:22:14     INFO -      Found by: call frame info
17:22:14     INFO -   2  xul.dll!WrappedNativeProtoMarker [XPCWrappedNativeScope.cpp:908b844c13c8 : 555 + 0xa]
17:22:14     INFO -      eip = 0x015fd170   esp = 0x0012f504   ebp = 0x0012f504
17:22:14     INFO -      Found by: call frame info
17:22:14     INFO -   3  xul.dll!PLDHashTable::Enumerate(PLDHashOperator (*)(PLDHashTable *,PLDHashEntryHdr *,unsigned int,void *),void *) [pldhash.cpp:908b844c13c8 : 723 + 0x8]
17:22:14     INFO -      eip = 0x010c8d9d   esp = 0x0012f50c   ebp = 0x0012f540
17:22:14     INFO -      Found by: call frame info
17:22:14     INFO -   4  xul.dll!PL_DHashTableEnumerate(PLDHashTable *,PLDHashOperator (*)(PLDHashTable *,PLDHashEntryHdr *,unsigned int,void *),void *) [pldhash.cpp:908b844c13c8 : 774 + 0xd]
17:22:14     INFO -      eip = 0x010c9e97   esp = 0x0012f548   ebp = 0x0012f550
17:22:14     INFO -      Found by: call frame info
17:22:14     INFO -   5  xul.dll!XPCWrappedNativeScope::MarkAllWrappedNativesAndProtos() [XPCWrappedNativeScope.cpp:908b844c13c8 : 565 + 0x10]
17:22:14     INFO -      eip = 0x015f6152   esp = 0x0012f558   ebp = 0x0012f584
17:22:14     INFO -      Found by: call frame info
17:22:14     INFO -   6  xul.dll!WrappedNativeMapDumpEnumerator [XPCWrappedNativeScope.cpp:908b844c13c8 : 786 + 0x1]
17:22:14     INFO -      eip = 0x015fd137   esp = 0x0012f56c   ebp = 0x0012f584
17:22:14     INFO -      Found by: call frame info
17:22:14     INFO -   7  xul.dll!js::gc::GCRuntime::callFinalizeCallbacks(js::FreeOp *,JSFinalizeStatus) [jsgc.cpp:908b844c13c8 : 1643 + 0x1a]
17:22:14     INFO -      eip = 0x031ed25b   esp = 0x0012f58c   ebp = 0x0012f5a8
17:22:14     INFO -      Found by: call frame info
17:22:14     INFO -   8  xul.dll!js::gc::GCRuntime::endSweepPhase(bool) [jsgc.cpp:908b844c13c8 : 5266 + 0x7]
17:22:14     INFO -      eip = 0x031ff5ea   esp = 0x0012f5b0   ebp = 0x0012f6d0
17:22:14     INFO -      Found by: call frame info
Comment hidden (Treeherder Robot)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1061896
You need to log in before you can comment on or make changes to this bug.