Fix browser_901207_searchbar_in_panel.js to work on e10s.

RESOLVED FIXED in Firefox 47

Status

()

Firefox
Toolbars and Customization
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 47
Points:
5
Dependency tree / graph
Bug Flags:
firefox-backlog +
in-testsuite +
qe-verify -

Firefox Tracking Flags

(e10s+, firefox47 fixed)

Details

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #1080787 +++



There seem to be focus issues at play here, where the panel opens correctly but because of whatever kind of race (AFAICT, with the page in the tab loading), the search input box is never focused...
Flags: qe-verify-
Flags: in-testsuite+
Flags: firefox-backlog+
The problem is likely related to _adjustFocusAfterTabSwitch. With e10s, when a remote tab is switched to, we wait until it fires the MozAfterRemotePaint event before actually flipping the deck to show the tab content. After we flip the deck, we (maybe) adjust focus for the tab we're switching to.

This is likely what's stealing the focus from your input box.

I wonder if we should have our test framework wait until focus handling has finished before executing - maybe by firing an event when _adjustFocusAfterTabSwitch is completed, or somehow else detecting that focus has changed and settled.

Comment 3

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/8198d0071f5d
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox47: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
You need to log in before you can comment on or make changes to this bug.