Flash Player has unuseable controls on Lenovo Pro 2 (High DPI)

RESOLVED DUPLICATE of bug 975885

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 975885
3 years ago
2 years ago

People

(Reporter: Matt Dickey, Unassigned)

Tracking

33 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8513151 [details]
screen shot.jpg

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141011015303

Steps to reproduce:

Flash player controls are very very small and unuseable in firefox on a high DPI Lenovo Yoga Pro 2. Any time flash is started on a website the controls are tiny. When trying to bring up the Flash menu with right clicking within the FLash player it locks up the player and crashes.


Actual results:

Flash player controls are very very small and unuseable in firefox on a high DPI Lenovo Yoga Pro 2. Any time flash is started on a website the controls are tiny. When trying to bring up the Flash menu with right clicking within the FLash player it locks up the player and crashes.


Expected results:

The controls (play, volume, settings, etc.) should be the same size as all other windows controls.

Comment 1

3 years ago
Is Flash up to date on your machine?
Is it better if you set the screen resolution to 100% in Win 8.1?
Type about:support in the location bar and paste the "graphics" section, please.
Flags: needinfo?(jmdickey2007)
(Reporter)

Comment 2

3 years ago
Created attachment 8513532 [details]
graphics screnshot from firefox
Flags: needinfo?(jmdickey2007)
(Reporter)

Comment 3

3 years ago
(In reply to Loic from comment #1)
> Is Flash up to date on your machine?
> Is it better if you set the screen resolution to 100% in Win 8.1?
> Type about:support in the location bar and paste the "graphics" section,
> please.

Thank you. I have tried EVERY possible combination with the screen resolution and "change the size of all items" settings. it doesnt matter if i scale the magnification up and/or the resolution down.

I have uninstalled and reinstalled Flash at least three times. 

From looking online in various places I understand that there are still significant scaling issues with the high DPI screens but will be surprised if there isnt a solution to this given the ubiquity of Flash.

Please let me know what else i can provide to assist.

Comment 4

3 years ago
There is one thing you can test, it's disabling the protected mode of Flash:
https://forums.adobe.com/thread/1018071 (read the ยง "last resort", use Notepad as admin to edit mms.cfg)
Restart FF to apply.
Changing component. If this component is not correct please change.
Component: Untriaged → Graphics
Product: Firefox → Core
I don't think Firefox is able to control the size of in-plugin content. Does this work differently in other browsers?
Probably a dupe of bug 975885.

(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #6)
> Does this work differently in other browsers?

Other browsers' behavior does not help much because different browsers use different plug-in technologies (NPAPI for Firefox, PPAPI for Chrome, ActiveX for IE).
I still assert that this isn't a Firefox bug because we don't have control of plugin content. That said this is definitely just another instance of bug 975885, thanks for finding it :emk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 975885
You need to log in before you can comment on or make changes to this bug.