"ElfLoader.cpp:692:23: error: 'AT_PHDR' was not declared in this scope" with NDK r10c if target version is greater than 19

RESOLVED FIXED in mozilla36

Status

()

Core
mozglue
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: rnewman, Assigned: glandium)

Tracking

Trunk
mozilla36
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
18:54:23 < glandium> rnewman: so, they changed their elf headers
18:54:53 < glandium> rnewman: ... in 21. 19 should work
18:56:05 < glandium> rnewman: confirmed, 19 builds
(Assignee)

Comment 1

3 years ago
Created attachment 8513152 [details] [diff] [review]
Use elf.h instead of linux/elf.h when building with android API version >= 21
Attachment #8513152 - Flags: review?(nfroyd)
(Assignee)

Updated

3 years ago
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Component: Build Config & IDE Support → mozglue
Product: Firefox for Android → Core
(Assignee)

Updated

3 years ago
Summary: Build fails with NDK r10c if target version is greater than 19 → "ElfLoader.cpp:692:23: error: 'AT_PHDR' was not declared in this scope" with NDK r10c if target version is greater than 19
Attachment #8513152 - Flags: review?(nfroyd) → review+
(Assignee)

Comment 2

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/f7bcbc253429
https://hg.mozilla.org/mozilla-central/rev/f7bcbc253429
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.