[Flame][Woodduck][v2.0][Message]Two buttons will flash about 0.5s at bottom after you confirm no contact can be added as message recipient.

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: lixia, Assigned: lchang)

Tracking

({polish})

unspecified
ARM
Gonk (Firefox OS)
polish
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0M+, b2g-v2.0 affected, b2g-v2.0M verified, b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8513165 [details]
logcat_flame_2154.txt

[1.Description]:
Two buttons flash about 0.5s in the bottom after you tap "OK" to confirm no contact can be added as message recipient.
Attch:logcat_flame_2154.txt and flame_2154.mp4.

[2.Testing Steps]: 
Initial condition:Have no contact in Contacts.

1.Open Messages.
2.New a message.
3.Tap "+" to add a contact.
4.When pop up "Can't add to contact as your contact list is empty",tap "OK" .

[3.Expected Result]: 
4.Two buttons shouldn't appear after you tap "OK".

[4.Actual Result]: 
4.Two buttons flash about 0.5s in the bottom.


[5.Reproduction build]: 
Flame version:
Gaia-Rev        86d83f4b4111ca45ebc92ca779348cc966f43cff
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/f8432250efb7
Build-ID        20141023160201
Version         32.0
Device-Name     flame-kk
FW-Release      4.4.2
FW-Incremental  34
FW-Date         Tue Sep 30 14:06:36 CST 2014
Bootloader      L1TC00011840

Woodduck version: 
Gaia-Rev        fdb8236d7d99061ef6bedc021fd6b482e1af3f5a
Gecko-Rev       3d95c1683ef5eb017bd15bc38ba111ddb1ad792e
Build-ID        20141024050313
Version         32.0
Device-Name     soul35
FW-Release      4.4.2
FW-Incremental  1414098327
FW-Date         Fri Oct 24 05:05:49 CST 2014

[6.Reproduction Frequency]: 
Always Recurrence,5/5
(Reporter)

Comment 1

4 years ago
Created attachment 8513170 [details]
flame_2154.MP4
This is happening in Contacts.

If this is happening in Flame, maybe we should file a separate public bug, or make this bug public?
Component: Gaia::SMS → Gaia::Contacts
(Reporter)

Updated

4 years ago
Summary: [MGSEI][Flame][Woodduck][v2.0][Message]Two buttons will flash about 0.5s at bottom after you confirm no contact can be added as message recipient. → [Flame][Woodduck][v2.0][Message]Two buttons will flash about 0.5s at bottom after you confirm no contact can be added as message recipient.
NI Francisco
Flags: needinfo?(francisco)
+1 to create the public bug.

I think we had the same problem in dialer, probably related with visibility
Flags: needinfo?(francisco)
Duplicate of this bug: 1096762
status-b2g-v2.0: --- → affected
status-b2g-v2.0M: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → unaffected

Comment 6

4 years ago
No confidential data in this bug. Make this public.
Group: woodduck-confidential

Comment 7

4 years ago
Hi Julien,
DO you know who can take this bug? Do you think bug 1096762 dup this one? 
Thanks!
Flags: needinfo?(felash)

Updated

4 years ago
See Also: → bug 1096762
Bug 1096762 does not have a video so it's difficult to really say but this looks to be related.

Since it's a Contacts issue, Francisco will know better than me.
Flags: needinfo?(felash) → needinfo?(francisco)

Updated

4 years ago
Duplicate of this bug: 1096762
Yup, we will take care
Flags: needinfo?(francisco)

Updated

4 years ago
blocking-b2g: --- → 2.0M?

Comment 11

4 years ago
Dear Luke,
Can you also help to check this issue? Thanks!
Flags: needinfo?(lchang)

Updated

4 years ago
Blocks: 1107999
(Assignee)

Comment 12

4 years ago
Created attachment 8537132 [details] [review]
Pull request  to v2.0m

Hi Francisco,

It's an issue related to "shared/js/confirm.js". Could you please help to take a look? Thanks.
Assignee: nobody → lchang
Status: NEW → ASSIGNED
Flags: needinfo?(lchang)
Attachment #8537132 - Flags: review?(francisco)
Comment on attachment 8537132 [details] [review]
Pull request  to v2.0m

Working like charm :)
Attachment #8537132 - Flags: review?(francisco) → review+

Comment 14

4 years ago
HI Kai-Zhen,
Can yo help to land this patch on 2.0M? Thanks!
Flags: needinfo?(kli)

Updated

4 years ago
blocking-b2g: 2.0M? → 2.0M+

Updated

4 years ago
Keywords: checkin-needed
(Assignee)

Comment 15

4 years ago
Hi Francisco, Thanks for the review.

landed on v2.0m: https://github.com/mozilla-b2g/gaia/commit/cfd72eae2568e91c37d93eb4174344f715594b84
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.0M: affected → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Flags: needinfo?(kli)
(Assignee)

Comment 16

4 years ago
Hi Josh,

This is a UI polish bug. I'm not sure should we fix it in v2.1. What do you think?
(Assignee)

Updated

4 years ago
Flags: needinfo?(jocheng)

Comment 17

4 years ago
[Blocking Requested - why for this release]:
Hi Steven,
This is somewhat polish issue but nice to have in 2.1. Can you or Bhavana decide whether to fix on 2.1? Thanks!
blocking-b2g: 2.0M+ → 2.1?
Flags: needinfo?(jocheng) → needinfo?(styang)
Keywords: polish
This was fixed in master in bug 1095785, but denied the uplift cause was too late to make it to 2.1

We think the same, don't want to add any possible error in this stage of 2.1
blocking-b2g: 2.1? → 2.0M+
Created attachment 8539885 [details]
video

The problem is verified not happen on Woodduck 2.0
See attachment: Woodduck2.0_Verify.MP4
Reproducing rate: 0/10

Woodduck 2.0 Build:
Gaia-Rev        ef37eb354bbde5837211b22dfdc0eed9623ade0e
Gecko-Rev       c9a727cb1d1ea0b5a82c64a360c03dbc35421d59
Build-ID        20141222050313
Version         32.0
status-b2g-v2.0M: fixed → verified

Updated

4 years ago
Flags: needinfo?(styang)

Updated

4 years ago
Blocks: 1080481
You need to log in before you can comment on or make changes to this bug.