no error message if download fails due to permissions

VERIFIED DUPLICATE of bug 27609

Status

Core Graveyard
File Handling
--
critical
VERIFIED DUPLICATE of bug 27609
17 years ago
2 years ago

People

(Reporter: Alex Chaffee, Assigned: Bill Law)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012
BuildID:    2001101201

When you click on a link to a file that will be downloaded instead of  displayed
in the  browser (e.g. a link to an RPM), and you try to save it to a directory
you don't have permission to write to, it will appear to succeed, but actually
fail. 

Silent failure on download is a critical error (critical = "causes you to lose
data")


Reproducible: Always
Steps to Reproduce:
* Click on a link to a file that will not be displayed in the browser (e.g. a
link to an RPM)
* See "Downloading foo.rpm" dialog box ("Save this file to Disk"
selected)
* click "OK"
* "Enter name of file to save to..." file dialog 
* Browse to a directory that is visible, but not writeable
(e.g. permissions drwxrwxr-x where user is not in group and is not
owner)
* Click "Save" 
* File dialog disappears
* See "Saving file" dialog
* "Progress" bar advances, completes to 100%, everything looks good
* but the file has not been saved!



Actual Results:  File not saved

Expected Results:  Display appropriate detailed error message, e.g. "The file
could not be saved because user alex does not have permission to write to
directory /home/alex/bad"


Similar to <a href="http://bugzilla.mozilla.org/show_bug.cgi?id=30784">30784</a>
(but not identical)

Note that it looks like you did fix this for the "Save as..." case, but not the
instant-download case

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 27609 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.