[Settings] Dialogs in settings are not responding

RESOLVED FIXED

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: arthurcc, Assigned: arthurcc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

This was regressed by bug 107600 where we removed the hash of the launch path and added logic blocking the click events from dialogs to prevent from refreshing. The logic should be removed as it prevents some of the dialogs from functioning.
Duplicate of this bug: 1088201
Created attachment 8513221 [details]
link to https://github.com/mozilla-b2g/gaia/pull/25594

Could you help review the patch based on what we've discussed? Thanks.
Attachment #8513221 - Flags: review?(ejchen)
Duplicate of this bug: 1088323
Arthur, can you tell me which kinds of form doesn't work before applying this patch ?

Thanks
Flags: needinfo?(arthur.chen)
(In reply to Arthur Chen [:arthurcc] from comment #0)
> This was regressed by bug 107600 where we removed the hash of the launch
> path and added logic blocking the click events from dialogs to prevent from
> refreshing. The logic should be removed as it prevents some of the dialogs
> from functioning.

I meant bug 1007600.
Flags: needinfo?(arthur.chen)
Comment on attachment 8513221 [details]
link to https://github.com/mozilla-b2g/gaia/pull/25594

Thanks Arthur, I just tested on browser and this seems an interesting tweak to prevent refreshing pages from submitting forms.

r+
Attachment #8513221 - Flags: review?(ejchen) → review+
master: 0bb1d2b49bf728230d0a4f05e83c445c6c7c695f
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.