Closed Bug 1090744 Opened 7 years ago Closed 7 years ago

Anonymous ruby frames have incorrect display value after switching the pref

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1068477

People

(Reporter: xidorn, Assigned: xidorn)

References

Details

Attachments

(1 file)

The values of "display" property of anonymous ruby frames are loaded from ua.css. However, ua.css is loaded after loading profile, and the content won't change when pref is switched during running.

Since the default value of "layout.css.ruby.enabled" is false, in a new profile, the display values for ruby won't be properly parsed in the UA sheet. This causes various problems in reftests. But I have no idea what's the best way to fix it.
Attached patch patchSplinter Review
I guess we should find a more elegant way, but I have no idea.
Assignee: nobody → quanxunzhen
Status: NEW → ASSIGNED
Attachment #8513237 - Flags: feedback?(dholbert)
No longer blocks: 1087872
Bug 1068477 is filed on fixing this in general.

I'm not sure it's worth trying to take a targeted fix for just this one pref / just this one set of properties -- it's likely better to fix the general bug.
(In reply to Daniel Holbert [:dholbert] from comment #2)
> Bug 1068477 is filed on fixing this in general.
> 
> I'm not sure it's worth trying to take a targeted fix for just this one pref
> / just this one set of properties -- it's likely better to fix the general
> bug.

I'm happy to see there exists a bug about this.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1068477
Comment on attachment 8513237 [details] [diff] [review]
patch

Setting the previous comment aside (and acknowledging that I'm unfamiliar with nsLayoutStylesheetCache -- this probably wants review from a style-system peer), this patch seems potentially reasonable, given that the only ruby-related ua.css rules are for anonymous elements, which I think cannot exist unless the ruby pref is enabled.

So, I think this can only have an effect if the ruby pref is enabled...? As long as that's true, this seems possibly reasonable.

There might be a small perf cost from calling Preferences::Get/SetBool() here, though I'm not sure how significant that is.

In any case, I'd probably prefer we address this by fixing Bug 1068477.  (Sounds like you agree.)
Attachment #8513237 - Flags: feedback?(dholbert) → feedback+
You need to log in before you can comment on or make changes to this bug.