Closed Bug 1090752 Opened 7 years ago Closed 3 years ago

The contact name displayed in contacts list and contact details view are different if you fill only a name and a company

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(tracking-b2g:backlog, b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

RESOLVED WONTFIX
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: jihao, Assigned: arcturus, NeedInfo)

References

Details

Attachments

(6 files)

Attached image contacts details.png
[1.Description]:
The  contact name displayed in contacts list  is different from that in contact details view when the contact only has company and mobile info.
Attachment: logcat_woodduck_0959.txt contacts_list.png and contacts_details.png
Occurrence time: 09:59

[2.Testing Steps]: 
1. Launch Contacts.
2. Tap "+" button.
3. Fill  Company and Mobile field info.
4. Tap "Done" button and come back to contacts list.
5. Tap contact and view contact details.

[3.Expected Result]: 
5.The contact name displayed in contacts list and contact details should be consistent.

[4.Actual Result]: 
5.The contact name displayed in contacts list and contact details are different .

[5.Reproduction build]: 
Flame build:
Gaia-Rev        86d83f4b4111ca45ebc92ca779348cc966f43cff
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/f8432250efb7
Build-ID        20141023160201
Version         32.0

Woodduck bulid: 
Gaia-Rev        fdb8236d7d99061ef6bedc021fd6b482e1af3f5a
Gecko-Rev       3d95c1683ef5eb017bd15bc38ba111ddb1ad792e
Build-ID        20141024050313
Version         32.0
Device-Name     soul35
FW-Release      4.4.2
FW-Incremental  1414098327
FW-Date         Fri Oct 24 05:05:49 CST 2014


[6.Reproduction Frequency]: 
Always Recurrence,5/5
Attached image contacts list.png
Reproduced on master.
Gaia-Rev        35e87ac4324f0f3abd93dcc70d61c9f37256a0f5
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/7e3c85754d32
Build-ID        20141029040208
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880
The contact list row display have a set of rules to displaying the info per contact, and we try to show different fields, if the present of the most important ones is not there.


So the order of preference to show is:
given name + surname (if not given we show surname and viceversa)
company
email
phone number

That is, if a contact doesn't have given name and surname, but has company, the displayed information will be the org field (company). That's done per desing since version 1.0.1

What we should do here is make sure that we follow the same rules for displaying the info in the contacts list and the title of the detail view.

Thanks for spotting this!
QA Contact: francisco
Assignee: nobody → francisco
QA Contact: francisco → nobody
Summary: [MGSEI][Woodduck][Flame][v2.0][Contacts]The contact name displayed in contacts list and contact details view are different. → [Woodduck][Flame][v2.0][Contacts]The contact name displayed in contacts list and contact details view are different.
I was able to reproduce this issue on latest Flame 2.0/2.1/2.2,Woodduck 2.0
See New Log: 

Device Info:
Flags: needinfo?(hlu)
Please ignore comment #5
Flags: needinfo?(hlu)
I was able to reproduce this issue on latest Flame 2.0/2.1/2.2,Woodduck 2.0
See New Log: logcat_woodduck_0143.txt

Device Info:
Flame 2.0 build:
Gaia-Rev        01c32dcdc08b3c8fc8b3082870439fa2c1089f4f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/b41c344ed82d
Build-ID        20141225000210
Version         32.0
----------------------
Flame 2.1 build:
Gaia-Rev        17c7ad2e4919a994f0844239b483116090412dee
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/39dfb662c82a
Build-ID        20141225001203
Version         34.0
---------------------
Flame 2.2 build:
Gaia-Rev        ab41c35eed35404b632a4841714b81b56364ba32
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2acb12da9813
Build-ID        20141225010202
Version         37.0a1
---------------------
woodduck 2.0 build:
Gaia-Rev        add38992bbfb2bafca52ac1ce7f6231ac702675f
Gecko-Rev       8d951d9c4988e218ec08c6118a35c7faeb70af49
Build-ID        20141225143517
Version         32.0
Flags: needinfo?(hlu)
The problem is verified still exist on on latest Flame 2.0/2.1/2.2/3.0 Woodduck 2.0m build
See Attachment:contacts details.png & contacts list.png

Step:
1. Launch Contacts.
2. Tap "+" button.
3. Fill  Company and Mobile field info.
4. Tap "Done" button and come back to contacts list.
5. Tap contact and view contact details.

Expected Result
5.The contact name displayed in contacts list and contact details should be consistent.

Actual Result
5.The contact name displayed in contacts list and contact details are different.

Woodduck 2.0m version:
Build ID               20150227050313
Gaia Revision          a1b5959728c8bc2a82354e197bb161922d419866
Gaia Date              2015-02-13 09:00:02
Gecko Revision         d9b299dc1087f23c83321b4dccc92e0f52309e8e
Gecko Version          32.0
Device Name            jrdhz72_w_ff
Firmware(Release)      4.4.2
Firmware(Incremental)  1424984723
Firmware Date          Fri Feb 27 05:05:41 CST 2015

Flame 2.0 version:
Build ID               20150226000206
Gaia Revision          366aaa19ac474dc58b79d62a91cff41756ae9dfe
Gaia Date              2015-02-22 20:25:01
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/cfaa08622d8d
Gecko Version          32.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150226.032904
Firmware Date          Thu Feb 26 03:29:15 EST 2015
Bootloader             L1TC000118D0

Flame 2.1 version:
Build ID               20150226001720
Gaia Revision          5d3479fdd438412adee4452720856b6b771fe5cd
Gaia Date              2015-02-25 18:20:09
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/0390c73a827b
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150226.035206
Firmware Date          Thu Feb 26 03:52:17 EST 2015
Bootloader             L1TC000118D0

Flame 2.2 version:
Build ID               20150226002503
Gaia Revision          bf24aa57fa7760260ab05d1f53242c8d8ae59e83
Gaia Date              2015-02-26 01:52:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/363123044e61
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150226.040038
Firmware Date          Thu Feb 26 04:00:49 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 version:
Build ID               20150226010233
Gaia Revision          7894b929f1b0394f3c997f72a6482bc7813e758d
Gaia Date              2015-02-25 20:50:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd6353d61993
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150226.043500
Firmware Date          Thu Feb 26 04:35:10 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(whsu)
Group: woodduck-confidential
Summary: [Woodduck][Flame][v2.0][Contacts]The contact name displayed in contacts list and contact details view are different. → The contact name displayed in contacts list and contact details view are different if you fill only a name and a company
Inconsistent behavior.
Suggest to improve on latest branch.

Many thanks.
Flags: needinfo?(whsu)
Hi Carrie,

do you think we should change the current behaviour, and follow with the suggestion of making both, the contacts list and detail title the same? Or should we leave it as it is

Thanks!
Flags: needinfo?(cawang)
Hi Francisco, 

I'm fine with the rules of the info displayed on the contact list, but I think the title of the contact details should be consistent with the title of the entry point (the contact list). So if we display the company name on the contact list, then it should appear as the title of the contact details as well. Thanks!
Flags: needinfo?(cawang)
Attached file logcat_Flame_1125.txt
Hi Hermes,
This issue still exists on latest Nightly Nexus 5 2.2 & 3.0, Flame 2.0 & 2.1 & 2.2 & 3.0 and Woodduck 2.0m build by the STR in Comment 0. Could you please find someone to help with it? Many thanks!

Fail rate:5/5
Found time:11:25
See Attachment: 1125.3gp and logcat_Flame_1125.txt

Device information: 
Woodduck Build ID: 20150612050212

Flame 2.0 Build ID: 20150611000206

Flame 2.1 Build ID: 220150611161205

Flame 2.2 Build ID: 220150611162501

Flame 3.0 Build ID: 220150611160204

Nexus 5_2.2 Build ID: 20150611162501

Nexus 5_3.0 Build ID: 20150611160204
Flags: needinfo?(hcheng)
Attached video 1125.3GP
QA Whiteboard: [MGSEI-Triage+]
Flags: needinfo?(hcheng) → needinfo?(francisco)
[Tracking Requested - why for this release]:

By decision there is an algorithm to try to fill the contacts list:

- First if name + surname (or the other way around if the order is changed)
- If not present: mail
- If not present: company
- If not present: phone number
- If nothing: No name

And in the contact details we use the value of the field: 'name'.

So I'm going to add this to the backlog, as it's a feature change request.
Flags: needinfo?(francisco)
Priority: -- → P2
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.