Malformed meta-http equiv refresh line causes infinite loading loop

RESOLVED DUPLICATE of bug 170021

Status

()

RESOLVED DUPLICATE of bug 170021
17 years ago
16 years ago

People

(Reporter: L.Wood, Assigned: jag-mozilla)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091323

If a meta http-equiv line is malformed, mozilla can be made
to loop and load the page an infinite number of times.
mozilla should not do anything in this situation.
(Netscape 4.7 has the same behaviour.)

Reproducible: Always
Steps to Reproduce:
Malform a refresh line in the head of a page:
<META HTTP-EQUIV="refresh" CONTENT="URL=http://www.mozilla.org">
instead of
<META HTTP-EQUIV="refresh" CONTENT="0; URL=http://www.mozilla.org">
to cause an infinite loop.

Actual Results:  Browser loops and reloads the source page (before displaying
it!) an infinite number of times instead of going to the specified destination.

Expected Results:  Either nothing, or go to destination while complaining about
syntax. Here's a minimal example:

<CODE>

<HTML>
<HEAD>
<TITLE>infinite loop</TITLE>
<META HTTP-EQUIV="refresh" CONTENT="URL=http://www.mozilla.org">
<!-- notice not 0; URL=... -->
<BODY>
This demonstrates how a broken refresh command leads to an infinite loop.
</BODY>
</HTML>

</CODE>
jag, this is a dup of one of yours, right?
Whiteboard: DUPEME
related to bug 62742?
(Assignee)

Comment 3

17 years ago
I can't find the bug this is a dupe of, so I'll just take it for now.

Btw, NS4 doesn't deal with this all too nicely either.
Assignee: neeti → jaggernaut
Status: UNCONFIRMED → NEW
Component: Networking → Browser-General
Ever confirmed: true
(Assignee)

Comment 4

17 years ago
Reducing severity, targetting for 0.9.9.
And yes, it's related to but not the same as bug 62742.
Severity: critical → normal
Target Milestone: --- → mozilla0.9.9

Comment 5

17 years ago
I just went to this site:
http://www.92ndsty.org/
It refreshes infinitely and never finishes loading.  The meta tag didn't look
obviously invalid, but had a very large number of seconds in it; maybe it
overflowed Mozilla.

Can a preference be added to disable meta refreshes?
(Assignee)

Comment 6

17 years ago
The line in question:

<meta HTTP-EQUIV="refresh" CONTENT="432000;URL=http://www.92ndsty.org">

Tested on my linux and w2k boxen, WFM.

Comment 7

17 years ago
I have this line on a web page:
<META HTTP-EQUIV="Refresh" CONTENT="1800">
And it works correctly most of the times. Sometimes though it's like
having CONTENT="0" and it doesn't get fixed even after quitting/restarting mozilla.

I think this happened on the latest nightlys..

Comment 8

17 years ago
The "infinite zero-time reload" problem on meta refresh tags seems to be a
sporadic, hard to predict thing that comes and goes -- I reported it earlier
with the http://www.92ndsty.org/ site, but others said it "WFM"... while it kept
doing the problem for me through several builds.  But now I tried that site and
it works for *me*... but meanwhile somebody else has reported the same problem
happening on a different site.  There must be some hidden factor that's causing
this to happen, and it won't be solved until that factor is identified.

Comment 9

17 years ago
I'm experiencing something similar using Build 2002020208 on Windows 98
(4.10.1998).  

When I load http://sports.yahoo.com/ncaab/scores/20020202/sbfkaf.html the page
will halfway load and then start a refresh.  The refresh tag looks like: <meta
http-equiv=refresh content=1200>.  I know that there's no standard for the meta
refresh tag, but it seems that a content of 1200 should mean to refresh after 20
minutes.
(Assignee)

Updated

17 years ago
Keywords: nsbeta1

Comment 10

17 years ago
Running Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
the infinite refresh (without displaying) seems to occur on this page when the
number of seconds between refreshes is greater than aproximately 1 hour (3600):

http://www1.burtonsys.com/mozilla_bug.html

Comment 11

17 years ago
Bug 116361 deals with infinite reloading on what seem to be valid meta refresh
tags.  So, I guess, if this one isn't considered a dupe, it should be regarded
as dealing more specifically with the case of infinitely reloading on *invalid*
meta refresh tags, a related but distinct issue.

Comment 12

17 years ago
nsbeta1+ per ADT triage team
Keywords: nsbeta1 → nsbeta1+
(Assignee)

Comment 13

17 years ago
On content="URL=...":

NS4 and current Mozilla builds do the same thing: reload the current page
infinitely. IE6 does nothing at all. The expected behaviour is to load the url
imediately, but do realize that this will only work in Mozilla, if we decide to
fix this, instead of following IE6's lead and doing nothing.

On content="1200":

As far as I can tell, my code is working fine there. When we don't find anything
after the 1200, we assume the current uri as the one to reload. We could be
parsing the 1200 incorrectly, or somehow timers overflow on your system, if it's
still happening, please file a new bug on that.
(Assignee)

Comment 14

17 years ago
-> 1.0
Target Milestone: mozilla0.9.9 → mozilla1.0

Updated

17 years ago
Keywords: nsbeta1+ → nsbeta1-

Comment 15

17 years ago
nsbeta1- per ADT

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.1

Comment 16

16 years ago
Duping.

*** This bug has been marked as a duplicate of 170021 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Target Milestone: mozilla1.1alpha → ---

Comment 17

16 years ago
The dupe is in docshell, but I'm sending this to http for routing to the correct
component. Components have changed a lot since I routed my last meta tag bug....
Component: Browser-General → Networking: HTTP
QA Contact: benc → httpqa
You need to log in before you can comment on or make changes to this bug.