[STK]The phone can not setup 2 calls by STK command normally.

RESOLVED DUPLICATE of bug 1091483

Status

Firefox OS
General
P2
normal
RESOLVED DUPLICATE of bug 1091483
4 years ago
4 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

8.17 MB, application/octet-stream
Details
7.51 MB, application/zip
Details
5.07 MB, application/zip
Details
(Reporter)

Description

4 years ago
DEFECT DESCRIPTION:[STK]The phone can not setup 2 calls by STK command normally.
 
  REPRODUCING PROCEDURES:
 1. Load a simcard to the phone which can send "setup call";
 2. Go to "settings->...->stk",execute "Setup Call->STN03002->OnHold+Redial",
    firstly, "888" will dialed out, connect the call;
    secondly,"+33155663989" will dialed out, but the MMI can not come out.--ko
    
 
  EXPECTED BEHAVIOUR:
 2. Go to "settings->...->stk",execute "Setup Call->STN03002->OnHold+Redial",
    firstly, "888" will dialed out, connect the call;
    secondly,"+33155663989" will dialed out, the MMI should come out normally and the call can be connect correct.
 
 Reporter's phonenumber: 0752-2639695
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

4 years ago
Created attachment 8513278 [details]
SETUPCALL-OnHold+Redial.rar

Comment 2

4 years ago
(In reply to sync-1 from comment #1)
> Created attachment 8513278 [details]
> SETUPCALL-OnHold+Redial.rar

Update what I found first,

// First setup call proactive command.
> 01-01 01:20:30.360   170   170 I Gecko   : -*- RILContentHelper: Received message 'RIL:StkCommand': {"clientId":0,"data":{"commandNumber":1,"typeOfCommand":16,"commandQualifier":3,"rilMessageType":"stkcommand","options":{"confirmMessage":"Short Number >>> 888","address":"888"},"rilMessageClientId":0}}

// Gaia replies the user confirmation.
> 01-01 01:20:31.106   170   684 I Gecko   : RIL Worker: [0] Received chrome message {"hasConfirmed":true,"resultCode":0,"command":{"commandNumber":1,"typeOfCommand":16,"commandQualifier":3,"rilMessageType":"stkcommand","options":{"confirmMessage":"Short Number >>> 888","address":"888"},"rilMessageClientId":0},"rilMessageClientId":0,"rilMessageToken":19,"rilMessageType":"sendStkTerminalResponse"}

// Second setup call proactive command.
> 01-01 01:21:53.636   170   170 I Gecko   : -*- RILContentHelper: Received message 'RIL:StkCommand': {"clientId":0,"data":{"commandNumber":1,"typeOfCommand":16,"commandQualifier":2,"rilMessageType":"stkcommand","options":{"confirmMessage":"Number + DTMF >>> +3315566XXXXP*P1234*5678","address":"+33155663732"},"rilMessageClientId":0}}

// Gecko receives the user confirmation in 50s later.
> 01-01 01:22:42.916   170   684 I Gecko   : RIL Worker: [0] Received chrome message {"hasConfirmed":true,"resultCode":0,"command":{"commandNumber":1,"typeOfCommand":16,"commandQualifier":2,"rilMessageType":"stkcommand","options":{"confirmMessage":"Number + DTMF >>> +3315566XXXXP*P1234*5678","address":"+33155663732"},"rilMessageClientId":0},"rilMessageClientId":0,"rilMessageToken":31,"rilMessageType":"sendStkTerminalResponse"}

Comment 3

4 years ago
(In reply to sync-1 from comment #0)
> DEFECT DESCRIPTION:[STK]The phone can not setup 2 calls by STK command
> normally.
>  
>   REPRODUCING PROCEDURES:
>  1. Load a simcard to the phone which can send "setup call";
>  2. Go to "settings->...->stk",execute "Setup Call->STN03002->OnHold+Redial",
>     firstly, "888" will dialed out, connect the call;
>     secondly,"+33155663989" will dialed out, but the MMI can not come
> out.--ko

Hi Reporter,

I have some questions needs your help to clarify first,

1. Does "The MMI can not come out" mean no user confirmation dialog pop out?
2. What is the foreground app after triggering second call? Callscreen or STK menu or ...?

If you can provide a video, that will be really great.
Thank you

>     
>  
>   EXPECTED BEHAVIOUR:
>  2. Go to "settings->...->stk",execute "Setup Call->STN03002->OnHold+Redial",
>     firstly, "888" will dialed out, connect the call;
>     secondly,"+33155663989" will dialed out, the MMI should come out
> normally and the call can be connect correct.
>  
>  Reporter's phonenumber: 0752-2639695
>  
>   ASSOCIATE SPECIFICATION:
>  
>   TEST PLAN REFERENCE:
>  
>   TOOLS AND PLATFORMS USED:
>  
>   USER IMPACT:
>  
>   REPRODUCING RATE:
>  
>   For FT PR, Please list reference mobile's behavior:
Flags: needinfo?(sync-1)
(Reporter)

Comment 4

4 years ago
(In reply to comment #2)
 > Comment from Mozilla:(In reply to sync-1 from comment #0)
 > > DEFECT DESCRIPTION:[STK]The phone can not setup 2 calls by STK command
 > > normally.
 > >  
 > >   REPRODUCING PROCEDURES:
 > >  1. Load a simcard to the phone which can send "setup call";
 > >  2. Go to "settings->...->stk",execute "Setup Call->STN03002->OnHold+Redial",
 > >     firstly, "888" will dialed out, connect the call;
 > >     secondly,"+33155663989" will dialed out, but the MMI can not come
 > > out.--ko
 > 
 
 So sorry I forgot this PR.I will catch the video after the Validation co-worker finishing the meeting. 
 
 > Hi Reporter,
 > 
 > I have some questions needs your help to clarify first,
 > 
 > 1. Does "The MMI can not come out" mean no user confirmation dialog pop out?
 The description is"+33155663989" will dialed out,so the dialing screen should come out.
 > 2. What is the foreground app after triggering second call? Callscreen or STK
 > menu or ...?
 as example device show there are two call in the same screen, one is on the top and  the other is on the bottom
 > 
 > If you can provide a video, that will be really great.
 > Thank you
 >
(Reporter)

Comment 5

4 years ago
Created an attachment (id=1005353)
 example_device
 
 I found the video is too large, so I take shortcut.
 The file example_device_android.zip provides to you to compare fire2, which is right behavior
(Reporter)

Comment 6

4 years ago
Created an attachment (id=1005353)
 example_device
 
 I found the video is too large, so I take shortcut.
 The file example_device_android.zip provides to you to compare fire2, which is right behavior
(Reporter)

Comment 7

4 years ago
Created attachment 8517293 [details]
example_device

Created an attachment (id=1005353)
 example_device
 
 I found the video is too large, so I take shortcut.
 The file example_device_android.zip provides to you to compare fire2, which is right behavior
(Reporter)

Comment 8

4 years ago
Created an attachment (id=1005413)
 fire2_2
 
 part 2 of fire2 test
(Reporter)

Comment 9

4 years ago
Created an attachment (id=1005413)
 fire2_2
 
 part 2 of fire2 test
(Reporter)

Comment 10

4 years ago
Created attachment 8517302 [details]
fire2_2

Created an attachment (id=1005413)
 fire2_2
 
 part 2 of fire2 test

Updated

4 years ago
Flags: needinfo?(echen)

Comment 11

4 years ago
I thought the problem is about the user confirmation message. But from the screenshot and the descrption in comment #4, looks like the problem is about the state of first call, it should be in onhold after secound stk setupcall command, but it's dropped .

// First setup call proactive command.
> 01-01 01:20:30.340   170   170 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"commandNumber":1,"typeOfCommand":16,"commandQualifier":3,"rilMessageType":"stkcommand","options":{"confirmMessage":"Short Number >>> 888","address":"888"},"rilMessageClientId":0}

// User confirms 'yes'.
> 01-01 01:20:31.106   170   684 I Gecko   : RIL Worker: [0] Received chrome message {"hasConfirmed":true,"resultCode":0,"command":{"commandNumber":1,"typeOfCommand":16,"commandQualifier":3,"rilMessageType":"stkcommand","options":{"confirmMessage":"Short Number >>> 888","address":"888"},"rilMessageClientId":0},"rilMessageClientId":0,"rilMessageToken":19,"rilMessageType":"sendStkTerminalResponse"}

// Modem sends UNSOLICITED_RESPONSE_CALL_STATE_CHANGED event with one call (888).
> 01-01 01:20:31.124   170   684 I Gecko   : RIL Worker: [0] Handling parcel as UNSOLICITED_RESPONSE_CALL_STATE_CHANGED
> 01-01 01:20:31.139   170   170 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"callStateChange","call":{"state":2,"callIndex":1,"toa":129,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"888","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isOutgoing":true,"isEmergency":false,"isConference":false},"rilMessageClientId":0}
> 01-01 01:20:33.343   170   684 I Gecko   : RIL Worker: [0] Handling parcel as UNSOLICITED_RESPONSE_CALL_STATE_CHANGED
> 01-01 01:20:33.355   170   170 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"callStateChange","call":{"state":3,"callIndex":1,"toa":129,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"888","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isOutgoing":true,"isEmergency":false,"isConference":false},"rilMessageClientId":0}
> 01-01 01:20:33.876   170   684 I Gecko   : RIL Worker: [0] Handling parcel as UNSOLICITED_RESPONSE_CALL_STATE_CHANGED
> 01-01 01:20:33.883   170   170 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"callStateChange","call":{"state":0,"callIndex":1,"toa":129,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"888","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isOutgoing":true,"isEmergency":false,"isConference":false,"started":1262308833881},"rilMessageClientId":0}

// Second setup call proactive command.
> 01-01 01:21:53.610   170   170 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"commandNumber":1,"typeOfCommand":16,"commandQualifier":2,"rilMessageType":"stkcommand","options":{"confirmMessage":"Number + DTMF >>> +3315566XXXXP*P1234*5678","address":"+33155663732"},"rilMessageClientId":0}

// User confirms 'yes'.
> 01-01 01:22:42.916   170   684 I Gecko   : RIL Worker: [0] Received chrome message {"hasConfirmed":true,"resultCode":0,"command":{"commandNumber":1,"typeOfCommand":16,"commandQualifier":2,"rilMessageType":"stkcommand","options":{"confirmMessage":"Number + DTMF >>> +3315566XXXXP*P1234*5678","address":"+33155663732"},"rilMessageClientId":0},"rilMessageClientId":0,"rilMessageToken":31,"rilMessageType":"sendStkTerminalResponse"}

// Modem sends UNSOLICITED_RESPONSE_CALL_STATE_CHANGED event, but with only one call (+33155663732).
// The first call is gone. 
> 01-01 01:22:42.967   170   684 I Gecko   : RIL Worker: [0] Handling parcel as UNSOLICITED_RESPONSE_CALL_STATE_CHANGED
> 01-01 01:22:42.978   170   170 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"callStateChange","call":{"state":2,"callIndex":1,"toa":145,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"+33155663732","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isOutgoing":true,"isEmergency":false,"isConference":false},"rilMessageClientId":0}
> 01-01 01:22:45.320   170   684 I Gecko   : RIL Worker: [0] Handling parcel as UNSOLICITED_RESPONSE_CALL_STATE_CHANGED
> 01-01 01:22:45.332   170   170 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"callStateChange","call":{"state":3,"callIndex":1,"toa":145,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"+33155663732","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isOutgoing":true,"isEmergency":false,"isConference":false},"rilMessageClientId":0}
> 01-01 01:22:45.658   170   684 I Gecko   : RIL Worker: [0] Handling parcel as UNSOLICITED_RESPONSE_CALL_STATE_CHANGED
> 01-01 01:22:45.668   170   170 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"callStateChange","call":{"state":0,"callIndex":1,"toa":145,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"+33155663732","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isOutgoing":true,"isEmergency":false,"isConference":false,"started":1262308965667},"rilMessageClientId":0}

We need partner's help to explain why first call is dropped (maybe from modem point of view), did gecko do anything wrong? Thank you.
Flags: needinfo?(echen)
(Reporter)

Comment 12

4 years ago
(In reply to comment #7)
 > We need partner's help to explain why first call is dropped (maybe from modem
 > point of view), did gecko do anything wrong? Thank you.
 > 
 while we disconnected the first call, we found the MMI.
 But the MMI should come out after sending SET UP CALL command, like example device screenshot 4.png shows.

Comment 13

4 years ago
(In reply to sync-1 from comment #12)
> (In reply to comment #7)
>  > We need partner's help to explain why first call is dropped (maybe from
> modem
>  > point of view), did gecko do anything wrong? Thank you.
>  > 
>  while we disconnected the first call, we found the MMI.
>  But the MMI should come out after sending SET UP CALL command, like example
> device screenshot 4.png shows.

Ah, I see, so this should be the same issue as bug 1091483.

Updated

4 years ago
See Also: → bug 1091483
(Reporter)

Comment 14

4 years ago
(In reply to comment #9)
 > Comment from Mozilla:(In reply to sync-1 from comment #12)
 > > (In reply to comment #7)
 > >  > We need partner's help to explain why first call is dropped (maybe from
 > > modem
 > >  > point of view), did gecko do anything wrong? Thank you.
 > >  > 
 > >  while we disconnected the first call, we found the MMI.
 > >  But the MMI should come out after sending SET UP CALL command, like example
 > > device screenshot 4.png shows.
 > 
 > Ah, I see, so this should be the same issue as bug 1091483.
 > 
 furthermore,the screen should contain two call one is on hold and the other is active when we connect the second call.

Comment 15

4 years ago
(In reply to sync-1 from comment #14)
> (In reply to comment #9)
>  > Comment from Mozilla:(In reply to sync-1 from comment #12)
>  > > (In reply to comment #7)
>  > >  > We need partner's help to explain why first call is dropped (maybe
> from
>  > > modem
>  > >  > point of view), did gecko do anything wrong? Thank you.
>  > >  > 
>  > >  while we disconnected the first call, we found the MMI.
>  > >  But the MMI should come out after sending SET UP CALL command, like
> example
>  > > device screenshot 4.png shows.
>  > 
>  > Ah, I see, so this should be the same issue as bug 1091483.
>  > 
>  furthermore,the screen should contain two call one is on hold and the other
> is active when we connect the second call.

(In reply to sync-1 from comment #14)
> furthermore,the screen should contain two call one is on hold and the other
> is active when we connect the second call.

I guess it is beacause the first call is already dropped, so you won't see the first call is on hold.
(Reporter)

Updated

4 years ago
Flags: needinfo?(sync-1)

Comment 16

4 years ago
Hi Edgar,
Per your comment 13. Should I dup this to bug 1091483?
Flags: needinfo?(echen)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(echen)
Resolution: --- → DUPLICATE
Duplicate of bug: 1091483
You need to log in before you can comment on or make changes to this bug.