[Messages][Drafts] Can't save message draft with attachment

VERIFIED FIXED

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: azasypkin, Assigned: julienw)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [sms-sprint-2.1S8])

Attachments

(2 attachments, 1 obsolete attachment)

4.43 KB, text/plain
Details
46 bytes, text/x-github-pull-request
steveck
: review+
Details | Review
Posted file logcat.txt
STR:

* Open Messages app and go to Message Composer;
* Tap on "Add attachment" button and choose any video or image attachment;
* Tap on back button and try to accept saving a draft;

Expected result: draft is saved and user is forwarded to Inbox panel;

Actual result: Tapping on "Save as Draft" menu item doesn't have any effect.

Gaia-Rev        b48f66220dff75f767eddf28a1d58192fc811410
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/53d84829b2b8
Build-ID        20141028160206
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
Hey Ben,

Could you please help to understand the issue we have? "DataCloneError: The object could not be cloned." exception is thrown when we try to put Blob to IndexedDB (via asyncStorage, see logcat). Not sure whether it's Blob or IndexedDB related issue, but I believe you have more insights about that.

Thanks!
Flags: needinfo?(bent.mozilla)
Assignee

Updated

5 years ago
blocking-b2g: --- → 2.2?
QA Contact: jmitchell
B2G-Inbound Regression Window:

Last Working:
Device: Flame 2.2
Build ID: 20141027195229
Gaia: 2f12df3ab3ff0c34bf1796906ca032796508a085
Gecko: fa76c5bf7c8c
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken:
Device: Flame 2.2
Build ID: 20141028003729
Gaia: d8394ec06c77325e1aa1f0ed2214b0c3a1f402d2
Gecko: f86eb7c94b2a
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


Gaia/Gecko Swap
Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: 2f12df3ab3ff0c34bf1796906ca032796508a085
Gecko: f86eb7c94b2a
First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: d8394ec06c77325e1aa1f0ed2214b0c3a1f402d2
Gecko: fa76c5bf7c8c

Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/2f12df3ab3ff0c34bf1796906ca032796508a085...d8394ec06c77325e1aa1f0ed2214b0c3a1f402d2

----------------------------------------------------------------------------------------------------

Most likely broken by Bug 1071514 -  can you take a look Julien?
Flags: needinfo?(felash)
QA Contact: jmitchell
Assignee

Comment 3

5 years ago
I confirm that backing out bug 1071514 make it work again.
Assignee

Comment 4

5 years ago
And actually, I see that attaching an image using the camera is broken too (I see the placeholder).

And I have those errors in logcat when I finish the attaching process:
10-30 14:43:47.132  3412  3412 W Gallery : [JavaScript Error: "IndexedDB UnknownErr: IDBDatabase.cpp:776"]
10-30 14:48:22.702  4128  4128 W Camera  : [JavaScript Error: "IndexedDB UnknownErr: IDBDatabase.cpp:776"]


(I don't see these in Oleg's log though, so something else might happen on my side).

When I attach from Camera before the patch, I clearly see that the first display (before we resize) is what I have now (which is perfectly logical, since now we don't change after resize).

So maybe the patch in bug 1071514 actually exposed an issue in Gecko.
Assignee

Comment 5

5 years ago
Even with the patch from bug 1071514 reverted, I get IDB errors on logcat. For example with this STR:
* open gallery
* open an image
* press share
* press messages
* press home once messages is loaded

=>
10-30 14:54:08.132  3869  3869 W Messages: [JavaScript Error: "IndexedDB UnknownErr: IDBRequest.cpp:304"]
10-30 14:54:08.152  3869  3869 W Messages: [JavaScript Error: "IndexedDB UnknownErr: IDBDatabase.cpp:776"]


And when I kill/open Messages app I have twice the same draft. Which looks like bug 1079824 which I thought was fixed by bug 1079546?
(In reply to Julien Wajsberg [:julienw] from comment #5)
> 10-30 14:54:08.132  3869  3869 W Messages: [JavaScript Error: "IndexedDB
> UnknownErr: IDBRequest.cpp:304"]
> 10-30 14:54:08.152  3869  3869 W Messages: [JavaScript Error: "IndexedDB
> UnknownErr: IDBDatabase.cpp:776"]

These mean that the page doing the idb request is being navigated before waiting for the transaction to complete. The transaction is therefore being aborted and rolled back.
Flags: needinfo?(bent.mozilla)
Assignee

Comment 7

5 years ago
Posted file github PR (obsolete) —
Does not have unit tests yet
Assignee: nobody → felash
Flags: needinfo?(felash)
Assignee

Updated

5 years ago
Depends on: 1071514
Assignee

Updated

5 years ago
Whiteboard: [sms-sprint-2.1S8]
triage: identifiable regression
blocking-b2g: 2.2? → 2.2+
Assignee

Comment 9

5 years ago
Posted file github PR
I'd like to test how the increased limit feels like on a Flame with less memory.
Attachment #8514452 - Attachment is obsolete: true
Assignee

Updated

5 years ago
Blocks: 1071514
No longer depends on: 1071514
Assignee

Comment 10

5 years ago
Comment on attachment 8515007 [details] [review]
github PR

tried with 5 times this image: http://asia.olympus-imaging.com/products/dslr/e520/sample/images/sample_01.jpg

looks good to me, even if it's slightly slow. Sometimes we clearly see the resized image is available even before the thumbnail is displayed. I think bug 1088526 will make this better.
Attachment #8515007 - Flags: review?(schung)
Looks good overall, I only left some comments on githud. Just want to make sure about the assertion and clear comment for property description.
Flags: needinfo?(felash)
Assignee

Comment 12

5 years ago
answered on github and pushed a follow-up for the nit !
Flags: needinfo?(felash)
Comment on attachment 8515007 [details] [review]
github PR

Thanks for your explain! I think maybe we might have another choice about the place for defining property, but I'm fine for both.
Attachment #8515007 - Flags: review?(schung) → review+
Assignee

Comment 14

5 years ago
master: e2e8c193cfdb1357f6c875e5fec3422305f7f6a8
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED

Comment 15

5 years ago
issue is veryified fixed on 2.2 flame 

User can now save messages to local draft even when message has an attachment.

Flame 2.2
Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141121040204
Gaia: 25388c6bce932657ebf93adedf31881bfaf88c15
Gecko: 3366c0fcf9c2
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

5 years ago
See Also: → 1071514
You need to log in before you can comment on or make changes to this bug.