unable to send images via bluetooth to Mac OS X Yosemite

RESOLVED DUPLICATE of bug 1094774

Status

Firefox OS
Bluetooth
RESOLVED DUPLICATE of bug 1094774
4 years ago
3 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Flame, nightly channel (master+m-c), Oct 28

Logcat for two tries:

W/GeckoConsole(  207): [JavaScript Error: "TypeError: this.element is null" {file: "app://system.gaiamobile.org/js/app_window.js" line: 232}]
I/GeckoBluetooth(  207): OnError: BluetoothSocketInterface::Accept failed: 5
I/GeckoBluetooth(  207): OnSocketConnectSuccess: [client]
I/GeckoBluetooth(  207): OnSocketDisconnect: [client]
I/GeckoBluetooth(  207): ProcessNextBatch: REMOVE. 0 remaining
I/GeckoDump(  207): XXX FIXME : Got a mozContentEvent: activity-choice
I/GeckoBluetooth(  207): OnError: BluetoothSocketInterface::Accept failed: 5
I/Gecko   (  207): 
I/Gecko   (  207): ###!!! [Child][OnMaybeDequeueOne] Error: Channel error: cannot send/recv
I/Gecko   (  207): 
I/GeckoBluetooth(  207): OnSocketConnectSuccess: [client]
I/GeckoBluetooth(  207): OnSocketDisconnect: [client]
I/GeckoBluetooth(  207): ProcessNextBatch: REMOVE. 0 remaining
I/Gecko   ( 6233): ###################################### forms.js loaded
I/Gecko   ( 6233): ############################### browserElementPanning.js loaded
I/Gecko   ( 6233): ######################## BrowserElementChildPreload.js loaded
I/GeckoDump(  207): XXX FIXME : Got a mozContentEvent: activity-choice
I/GeckoBluetooth(  207): OnError: BluetoothSocketInterface::Accept failed: 5
I/GeckoBluetooth(  207): OnSocketConnectSuccess: [client]
I/GeckoBluetooth(  207): OnSocketDisconnect: [client]
I/GeckoBluetooth(  207): ProcessNextBatch: REMOVE. 0 remaining

Comment 1

4 years ago
Did you enable bluetooth sharing on your mac? I cannot reproduce this bug on nightly channel (master+m-c), Oct 29.

--
5. Why can't I send a file to or receive a file from my Mac?

    If you would like to share files to Mac, the file-transfer function should be enabled beforehand. 

    1. Click the Bluetooth icon at the top-right corner of the screen 
    2. Select "Open Bluetooth Preferences" from the drop down menu, then click the "Sharing Setup..." button at the bottom right of the dialog that opens 
    3. Make sure the "Bluetooth Sharing" checkbox is enabled.
Flags: needinfo?(dietrich)
(Reporter)

Comment 2

4 years ago
Bluetooth sharing is enabled. I use this functionality quite often to send screenshots of bugs on Flame to my Mac to put in bug reports :)
Flags: needinfo?(dietrich)
(Reporter)

Comment 3

4 years ago
I'm updating to today's build now, will try again.
(Reporter)

Comment 4

4 years ago
Updated to today's build, still failed. Logcat:

I/GeckoDump(  209): XXX FIXME : Got a mozContentEvent: activity-choice
I/GeckoBluetooth(  209): OnError: BluetoothSocketInterface::Accept failed: 5
I/Gecko   ( 2098): ###################################### forms.js loaded
I/Gecko   ( 2098): ############################### browserElementPanning.js loaded
I/Gecko   ( 2098): ######################## BrowserElementChildPreload.js loaded
I/GeckoBluetooth(  209): OnSocketDisconnect: [client]
I/GeckoBluetooth(  209): DiscardBlobsToSend: idx 0
W/GeckoConsole(  209): [JavaScript Error: "TypeError: sendingFilesSchedule is undefined" {file: "app://system.gaiamobile.org/js/bluetooth_transfer.js" line: 501}]
I/GeckoBluetooth(  209): ProcessNextBatch: REMOVE. 0 remaining

Comment 5

4 years ago
Still unable to repro on 20141030 build. Does this bug always happen or require specific steps to repro?

https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-flame-kk-eng/2014/10/2014-10-30-16-02-00/
Flags: needinfo?(dietrich)
(Reporter)

Comment 6

4 years ago
I'm using the builds from the official Flame nightly channel, on v188 base. Should be exactly the same as what you're using. I updated to the most recent build and still cannot share an image from the Gallery to the Macbook Air.
Flags: needinfo?(dietrich)
(Reporter)

Comment 7

4 years ago
Setting qawanted for confirmation.
Keywords: qawanted
I also tested OPP file transfer, and sent pictures from the Gallery app to my Mac (Macbook pro, Yosemite 10.10), I can receive photo anyway.
I guess I can reproduce this bug.
I saw some Mac OS X boxes with this bug, it usually has incorrect default path to store files.
And it looks like bug of mac.

System Preference->Sharing->Blueototh Sharing 
 Make sure "Folder for accepted items: -", it shall not be '-' but actually indicate the correct path such Downloads folder.

After changing the path to store, Mac can receive files.
I'm not sure how this can happen but it actually caused by upgrading.
Flags: needinfo?(dietrich)
Summary: unable to send images to Mac OS X Yosemite → unable to send images via bluetooth to Mac OS X Yosemite
See Also: → bug 1094774
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1094774
(Reporter)

Comment 11

4 years ago
Yep, Yosemite bug!
Flags: needinfo?(dietrich)
Keywords: qawanted

Updated

3 years ago
See Also: → bug 1223329
You need to log in before you can comment on or make changes to this bug.