Closed Bug 1091166 Opened 5 years ago Closed 5 years ago

[Color Filter] When enabling the color filter, a grey screen displays

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 wontfix, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S9 (21Nov)
Tracking Status
b2g-v2.0 --- wontfix
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: psiphantong, Assigned: boris)

References

Details

(Whiteboard: [2.1-exploratory-3])

Attachments

(4 files, 1 obsolete file)

Attached file gs.txt
Description:
When enabling the color filter, a grey screen displays and if the user press the home or power button, user can't not disable the color filter

Setup Steps:
1) Flame device is set to 319mb

Repro Steps:
1) Update a Flame device to BuildID: 20141029001202
2) Go to Accessibility > tap color filter
3) Enable color filter > Turn the Contrast down
4) Disable color filter > Enable color filter


Actual:
grey screen displays

Expected:
screen display correctly

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141029001202
Gaia: eb0aab0f13c78c7ac378ad860e865c4b6eaf669f
Gecko: 318019f80a8e
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Note: pressing the home or power button, user can't not disable the color filter. Have to turn off/on phone again for the screen to display correctly


Repro frequency: 100%
See attached: screenshot, logcat
Attached image 2014-10-29-12-14-43.png
This issue also reproduces on the Flame 2.2 and the Flame 2.0, the grey screen displays.

Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141029040208
Gaia: 35e87ac4324f0f3abd93dcc70d61c9f37256a0f5
Gecko: 7e3c85754d32
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141029000205
Gaia: 9f5b6f025e528fabfcc068782cb9b492cb51a7f9
Gecko: de8cfd54bf93
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:

If the user does this then they will be stuck with a grey screen on the phone, until they restart the phone by holding the power button for 10 seconds or pull the battery.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:

Can we find out when this was landed? We do not see this feature on 20141103000201 2.0.

Anyway this feature should not be present on 2.0. pushing to 2.1 nomination.
blocking-b2g: 2.0? → 2.1?
Component: Gaia::Settings → Graphics
Product: Firefox OS → Core
blocking-b2g: 2.1? → 2.1+
Flags: needinfo?(pchang)
Boris, please help to check this issue.
Flags: needinfo?(pchang) → needinfo?(boris.chiou)
(In reply to peter chang[:pchang][:peter] from comment #5)
> Boris, please help to check this issue.

OK, I am trying to figure out what happens. The most important question is: which level you turn the Contrast down to?
I can reproduce this problem only if I moved the contrast bar to the left-most level (minimum level). After I rebooted the device, the Contrast level on the screen was different from what I set in the Settings. I have to re-adjust (re-enable) color filter, and then the contrast level became the same level as what I set. Anyway, I think we should fix the minimum contrast level in the Settings to make sure it will not got to full gray and color filter is still correct after we reboot the device.
Flags: needinfo?(boris.chiou)
Assignee: nobody → boris.chiou
(In reply to Wayne Chang [:wchang] from comment #4)
> [Blocking Requested - why for this release]:
> 
> Can we find out when this was landed? We do not see this feature on
> 20141103000201 2.0.
> 
> Anyway this feature should not be present on 2.0. pushing to 2.1 nomination.

This option was added in Bug 1049824. Thanks.
(In reply to Boris Chiou [:boris] from comment #7)
> (In reply to Wayne Chang [:wchang] from comment #4)
> > [Blocking Requested - why for this release]:
> > 
> > Can we find out when this was landed? We do not see this feature on
> > 20141103000201 2.0.
> > 
> > Anyway this feature should not be present on 2.0. pushing to 2.1 nomination.
> 
> This option was added in Bug 1049824. Thanks.

And the grahics part: Bug 1055891 - Contrast for accessibility.
Depends on: 1049824
Depends on: 1055891
Attachment #8519751 - Flags: review?(ejchen)
Attachment #8519751 - Flags: review?(alive)
Comment on attachment 8519751 [details] [review]
pull request #25987 - Fix the color contrast value when enabling it

Bypass to :eeejay since he knows this best
Attachment #8519751 - Flags: review?(alive) → feedback?(eitan)
Attachment #8519751 - Attachment is obsolete: true
Attachment #8519751 - Flags: review?(ejchen)
Attachment #8519751 - Flags: feedback?(eitan)
Attachment #8519772 - Flags: review?(ejchen)
Attachment #8519772 - Flags: feedback?(eitan)
Comment on attachment 8519772 [details] [review]
pull request #25993 - Fix the color contrast value when enabling it

As what alive said, this is a change in system app instead of settings app, passed to Eitan :)
Attachment #8519772 - Flags: review?(ejchen)
Comment on attachment 8519772 [details] [review]
pull request #25993 - Fix the color contrast value when enabling it

Indeed that is a bug, and this patch is correct.
Attachment #8519772 - Flags: feedback?(eitan) → feedback+
Attachment #8519772 - Flags: review?(fabrice)
Comment on attachment 8519772 [details] [review]
pull request #25993 - Fix the color contrast value when enabling it

No need for my review here.
Attachment #8519772 - Flags: review?(fabrice)
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #10)
> Comment on attachment 8519751 [details] [review]
> pull request #25987 - Fix the color contrast value when enabling it
> 
> Bypass to :eeejay since he knows this best

Hi Alive,

sorry, I'm not familiar with gaia bug, do you know who can also review this bug? Thanks.
Flags: needinfo?(alive)
Comment on attachment 8519772 [details] [review]
pull request #25993 - Fix the color contrast value when enabling it

r+ because :eeejay confirmed.
Flags: needinfo?(alive)
Attachment #8519772 - Flags: review+
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #16)
> Comment on attachment 8519772 [details] [review]
> pull request #25993 - Fix the color contrast value when enabling it
> 
> r+ because :eeejay confirmed.

Thank you so much :)
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/6ef8ecb5f58a2c0d1245566bbb358d21777212c2

Please request Gaia v2.1 approval on this when you get a chance.
Status: NEW → RESOLVED
Closed: 5 years ago
Component: Graphics → Gaia::System
Flags: needinfo?(boris.chiou)
Keywords: checkin-needed
Product: Core → Firefox OS
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S9 (21Nov)
This issue is verified fixed on 2.2.

Result: The screen returns to the menu screen properly after disabling and re-enabling the color filter.

Device: Flame 2.2 (319mb, KK, Shallow Flash)
BuildID: 20141113040205
Gaia: be8b0151d2f9a4c41fc63952128e0b723cd1161d
Gecko: ab137ddd3746
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
============================================

Leaving verifyme for 2.1 patch uplift.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
(In reply to Boris Chiou [:boris] from comment #19)
> Comment on attachment 8519772 [details] [review]
> pull request #25993 - Fix the color contrast value when enabling it
> 
> [Approval Request Comment]
> [Bug caused by] (feature/regressing bug #):
> [User impact] if declined:
> [Testing completed]:
> [Risk to taking this patch] (and alternatives if risky):
> [String changes made]:

Boris, you need to answer the questions please...
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Comment on attachment 8519772 [details] [review]
pull request #25993 - Fix the color contrast value when enabling it

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1049824
[User impact] if declined: You can not disable/reset the color filter easily after turning the Contrast down in version 2.1, as Pete described. I believe "everything becomes gray" is not a good user experience.
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): No
[String changes made]: No

Hi Fabrice,
Sorry, my bad. Please check this request. Thank you so much.
Attachment #8519772 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
Attached video video of issue verify
This issue has been verified successfully on Flame 2.1
See attachment: verify_video.MP4
Reproducing rate: 0/5
Flame 2.1 versions:
Gaia-Rev        afdfa629be209dd53a1b7b6d6c95eab7077ffcd9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/dc3018cbdbe6
Build-ID        20141123001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141123.035029
FW-Date         Sun Nov 23 03:50:40 EST 2014
Bootloader      L1TC00011880
[Blocking Requested - why for this release]:

set 2.0? to see if it needs to be uplifted to 2.0
blocking-b2g: 2.1+ → 2.0?
no partner is requested this on 2.0 for now; suggesting to denominate it for now...
blocking-b2g: 2.0? → ---
refer to comment 27, mark v2.0 status as wontfix
You need to log in before you can comment on or make changes to this bug.