unordered <li> tags showing up as ordered <ol> tags, regardless of list-style. ie: All bulleted lists show up as numbered lists.

RESOLVED DUPLICATE of bug 1027647

Status

()

Core
General
RESOLVED DUPLICATE of bug 1027647
4 years ago
4 years ago

People

(Reporter: Lindsay Haeber, Unassigned)

Tracking

33 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141027150301

Steps to reproduce:

Visited to website http://www.industrialpwoerrental.ca/other.html


Actual results:

All unordered <li> lists within my table are showing as <ol>, regardless of list-type


Expected results:

should have shown as a list-type:bulleted. Instead shows as numbered list.
I assume you meant http://www.industrialpowerrental.ca/other.html

This has styles like so:

  list-style: outside none bulleted;

"bulleted" is not a built-in list style (were you thinking of "disc"?).  So this is treated as a custom page-provided list style, and if the page doesn't actually provide it that falls back to "decimal".

This is a change from CSS2.1 (which ignored unrecognized list styles) to CSS 3 (which introduces the ability to define custom list styles, and treats unrecognized ones as custom).
Blocks: 966166
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1027647
You need to log in before you can comment on or make changes to this bug.