Closed Bug 1091262 Opened 6 years ago Closed 4 years ago

problem with dmd.py with unescaped strings in stack frame names

Categories

(Core :: DMD, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1260329

People

(Reporter: mccr8, Unassigned)

Details

I ran dmd.py on a log I got locally, and the JSON decoder ended up throwing an exception while parsing this line:
    "MZd": "#00:  with unmangled suffix "ShouldIronwoodHotKeyLoadIM" (in HIToolbox) + 26",

Presumably the problem is that the string needs to be escaped.  I think it is being replaced by the stack symbolizer so that should be fun...
Whiteboard: [MemShrink]
The most direct fix is probably adding a new mode to fix_stack_frames that escapes any quotation marks in the string that is being inserted.
Whiteboard: [MemShrink]
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1260329
You need to log in before you can comment on or make changes to this bug.