Closed Bug 1091281 Opened 7 years ago Closed 7 years ago

[Everything.me] LinkedIn directs user to broken URL

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0M+, b2g-v2.0 verified, b2g-v2.0M verified, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
blocking-b2g 2.0M+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.0M --- verified
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: onelson, Assigned: jacques)

References

Details

(Whiteboard: [2.1-Daily-Testing])

Attachments

(3 files)

Description:
When the user attempts to navigate to LinkedIn via the ev.me app within the 'Social' Smart Collection, they will observe an error page immediately upon entering. The website the user is directed to is "https://touch.www.linkedin.com/login.html", which shows the user a:
"Oops! That page doesn't exist: Looks like something got mixed up." It has a link fromthis page to return to the homepage ["https://touch.www.linkedin.com/"].
   
Repro Steps:
1) Update a Flame device to BuildID: 20141029001202
2) Open Smart Collection: 'Social'
3) Open "LinkedIn"
4) Observe webpage opened
  
Actual:
User is directed to a page that doesn't exist with link provided to return to home -> https://touch.www.linkedin.com/login.html
  
Expected: 
User is directed to a page that they can login immediately -> https://touch.www.linkedin.com/
  
**********************************************
Environmental Variables:
Device: Flame 2.1
BuildID: 20141029001202
Gaia: eb0aab0f13c78c7ac378ad860e865c4b6eaf669f
Gecko: 318019f80a8e
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

----------------------------------------------
Device: Flame 2.2
BuildID: 20141029040208
Gaia: 35e87ac4324f0f3abd93dcc70d61c9f37256a0f5
Gecko: 7e3c85754d32
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
----------------------------------------------

**********************************************  
  
Repro frequency: 10/10
See attached: 
screenshot
logcat
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Attached image linkedin_SS.png
I don't see this on Flame using:

Gaia   0dfc1996eb583c8b507a82bf6b8319624bba23ea
SourceStamp 80e18ff7c7b2
BuildID 20141030040201
Version 36.0a1
v188

It works on the 2.1 branch as well. This should likely be WFM.
Adding qawanted to see if they can reproduce this issue.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Contact: ckreinbring
Able to repro on Flame 2.2, 2.1, 2.0 and 2.0 base engineering with shallow flash.
Actual result: Tapping the LinkedIn icon in the Everything.Me Social screen will take the user to LinkedIn's error page as shown in the screenshot.

Flame 2.2
BuildID: 20141030065218
Gaia: cddf7f505c4c280bacb74c22af3fa4959ccb555a
Gecko: 675913ddbb55
Platform Version: 36.0a1
Firmware Version: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.1
BuildID: 20141030065818
Gaia: 04379be42b1bf38817370a276d90931b53257706
Gecko: 601d265ad3aa
Platform Version: 34.0
Firmware Version: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0
BuildID: 20141030084016
Gaia: 7b8df9941700c1f6d6d51ff464f0c8ae32008cd2
Gecko: 4c06748190b7
Platform Version: 32.0
Firmware Version: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 2.0 Base
BuildID: 20141016183911
Gaia: 8c5c956ee6909408e29f375cc7d843a03d92f3d8
Gecko: 
Platform Version: 32.0
Firmware Version: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
NI to e.me owner for a blocking decision. It is not a regression but seems bad as Linked-in is a pretty popular app.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(mozillamarcia.knous)
QA Contact: ckreinbring
I still cannot reproduce this on Flame with a recent user build - 2.1 and 2.2 - is it being seen on both user and engineering builds? Comment 4 mentions an engineering build.
Flags: needinfo?(mozillamarcia.knous) → needinfo?(jmitchell)
QA-Wanted to investigate comment 6
Flags: needinfo?(jmitchell)
Keywords: qawanted
Issue DOES reproduce in both user and engineering builds when full flashed or shallow flashed.  Marcia are you using the LinkedIn icon that is under the Social Smart Collection, not searching with rocketbar?

Environmental Variables:
Device: Flame 2.2  User build shallow flash
BuildID: 20141031061804
Gaia: a07994714f0552f89801d6097982308d8b0a1ee1
Gecko: 6bd2071b373f\
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Environmental Variables:
Device: Flame 2.2 Engineering build shallow flash
BuildID: 20141031062029
Gaia: a07994714f0552f89801d6097982308d8b0a1ee1
Gecko: 21fbf1e35090
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Environmental Variables:
Device: Flame 2.2 User build full flash
BuildID: 20141031061804
Gaia: a07994714f0552f89801d6097982308d8b0a1ee1
Gecko: 6bd2071b373f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Environmental Variables:
Device: Flame 2.2 Engineering build full flash
BuildID: 20141031062029
Gaia: a07994714f0552f89801d6097982308d8b0a1ee1
Gecko: 21fbf1e35090
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
blocking-b2g: --- → 2.0M?
I can see this on 2.1 as well with linkedin in the social smart collection. Seems like a link has to get updated on the server side?
Flags: needinfo?(ran)
probably. Assigning to jacques who handles content related issues.
Assignee: nobody → jacques
Flags: needinfo?(ran)
Done
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
blocking-b2g: 2.0M? → 2.0M+
Keywords: verifyme
This issue is verified fixed on Flame 2.0, 2.1 and 2.2.

Result: LinkedIn page is displayed correctly when selected from the smart collection.

Device: Flame 2.0 (319mb, KK, Shallow Flash)
BuildID: 20141120000206
Gaia: 1ede2666f1e6c1b3fd3b282011caf0cbc59544b0
Gecko: 54f1b0ee07a6
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Flame 2.1 (319mb, KK, Shallow Flash)
BuildID: 20141120001207
Gaia: f8d3bf44029e0afc0124600a4bb34dba8fc1ad21
Gecko: f70a67a7f846
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 (319mb, KK, Shallow Flash)
BuildID: 20141120040205
Gaia: 1abe09b4925547699dfdb2d358aed019137c3aa6
Gecko: 6ce1b906c690
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Josh, Seem nothing to be landed for 2.0m. could you ask someone to verify on 2.0m?
Flags: needinfo?(jocheng)
Hi Norry,
Can you verify the Linkedin page for Woodduck 2.0M is correct? Thanks!
Flags: needinfo?(jocheng) → needinfo?(fan.luo)
Attached video Verify.mp4
This issue is verified fixed on Woodduck 2.0M

Woodduck build:
Gaia-Rev        8e17537f9e6d02b7271d92134671414d1fb88386
Gecko-Rev       71be912cc4fedd423869ad9dce72880de170851f
Build-ID        20141128050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1417122322
FW-Date         Fri Nov 28 05:05:45 CST 2014
Flags: needinfo?(fan.luo)
You need to log in before you can comment on or make changes to this bug.