Closed Bug 10913 Opened 21 years ago Closed 19 years ago

[RFE] reload button sugestions

Categories

(Core :: Networking: HTTP, enhancement, P3)

enhancement

Tracking

()

VERIFIED INVALID
Future

People

(Reporter: csbooton, Assigned: mpt)

References

Details

(Keywords: helpwanted)

This is something that can likley wait, but you know how in 4.xx , when you
press reload it will not auto reload forms , images and such (I think it justs
reloads the html files and .css .js files). Anyway, I think that it should be
made that forms should be reloaded when the reload button is pressed without
aditonal buttons having to be pressed (ie to reload a form you should not have
to hold down the shift key).

Also for the feature, how about making so that when you press reload a small box
appears below it asking to either reload only html files,forms and such or to do
a full reload, you would choose one of them by clicking on it. This could be
very usefull.
Summary: [enhancement] reload button sugestions → [RFE] reload button sugestions
Target Milestone: M14
It would be nice to have that feature, but instead of making the box appearing
by default, I suggest to place a small button with an arrow next to the reload
button. When the reload buton pressed, a default reloading will be done, but
when the small button is pressed, a menu will popup (like the right-click menu)
like this one:
  * Full page reload
  * Reload noly images
  * Reload only text
  * Reload only forms
Also advanced options like 'reload scripts' could be added.
That's good.  Dialogs are bad, but a drop down menu would be nice, if only to
not have to touch the keyboard to get a full reload.
You might want to do something with applets too.
Escpecially, "reload frame" is missing just right now.
Move to M20.
Component: Browser-General → XPApps
QA Contact: leger → paulmac
Updating Component
qa to claudius
QA Contact: paulmac → claudius
I would like to have an 'auto reload' ability as well. This is how I imagine it
would work:

Pressing the small button, the menu would appear. At the bottom I would also get
a check box entitled 'auto reload' and another box for the auto-reload time in
seconds. If I check the box, I can enter a time. Then, whatever option I select,
e.g. 'reload entire page', will happen _every time_ the interval I've entered
passes.

This would be very useful for pages of rapidly changing information, e.g. stock
quotes; you could think of this as a user controlled meta-refresh.
Move to "Future" milestone.
Target Milestone: M20 → Future
*** Bug 57792 has been marked as a duplicate of this bug. ***
this would be really nifty!
Keywords: helpwanted
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy
nav triage team:

Yup, real nifty, but won't do for beta1, marking nsbeta1-
Keywords: nsbeta1-
-> UI:DF
Assignee: vishy → mpt
Component: XP Apps → User Interface: Design Feedback
QA Contact: claudius → zach
If you tried hard enough, for every button on the toolbar, you could think of 
related commands which could go in a popup menu next to that button. But that 
doesn't mean that every button on the toolbar *should* have a popup menu (see 
bug 63042, for example). The toolbar is not, and should not be, just a 
graphical menu bar; it should provide *one*-click access to the most common 
commands. (Back and Forward are an exception only because we use them so much 
more than the other buttons on the toolbar.)

> Anyway, I think that it should be made that forms should be reloaded when the
> reload button is pressed without aditonal buttons having to be pressed (ie to
> reload a form you should not have to hold down the shift key).

This was fixed with bug 46845.

> Also for the feature, how about making so that when you press reload a small
> box appears below it asking to either reload only html files,forms and such
> or to do a full reload, you would choose one of them by clicking on it.

You can't really pick one or the other. When you reload the HTML, the form 
elements in that new HTML might be totally different from those which you 
edited in the previous version of the page. So your form data could be 
completely lost, even though the existence of a separate `Reload Forms' item 
led you to expect that they would remain -- and that would be Bad.

One of max10's suggestions could work, though. Once `Load Images' is 
implemented (bug 57505), a new RFE could be filed on making that menu item
context-sensitive -- changing the item (once images have been loaded the first 
time) to `Reload Images' (actually, I've just noticed Internet Explorer for Mac 
OS does this). Similarly, the item could change to `Load Selected Images' or 
`Reload Selected Images', if the user has selected one or more of the images in 
the page. This would be useful for a Webcam, for example, where you only wanted 
to reload the Webcam picture and not the whole of the page.

Gabriel's `auto-reload' feature should be filed as a separate RFE.

So in summary, this bug contains three suggestions: the first is already fixed, 
the second is impossible without a risk of dataloss, and the third belongs in a 
separate bug. So I'm resolving this bug as invalid.
Status: NEW → RESOLVED
Closed: 19 years ago
OS: other → All
Hardware: PC → All
Resolution: --- → INVALID
Opened bug 75165 for the auto reload idea.
*** Bug 118625 has been marked as a duplicate of this bug. ***
Component: User Interface Design → Browser-General
-> networking
Component: Browser-General → Networking
QA Contact: zach → benc
seems to really only care about http. reload button bugs are often protocol
specific...
Component: Networking → Networking: HTTP
QA Contact: benc → tever
Marked invalid 20 months ago. Verified. Please open new bugs with only one
enhancement request each.
Status: RESOLVED → VERIFIED
QA Contact: tever → junruh
You need to log in before you can comment on or make changes to this bug.