aa.com - American Airlines's Flight Date display incorrectly

VERIFIED FIXED in Future

Status

()

P1
normal
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: alam, Assigned: rods)

Tracking

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Build Used: N6.2 RTM

Step to reproduce:

1. Go to www.aa.com
2. Under the "Plan your trip" section, click on a day that has two digit (eg. 
23) in the little calendar on the right hand side.

Notify that the Departure date's day drop down list box shows only the first 
digit. Example: if you click 23, it only shows '2' in the drop down list box.

Also, the day list box is not aligned with the month and time list box in one 
line like it did in Communicator and IE.

Comment 1

17 years ago
This page does have problems with unquoted attributes and such, but why do you
think this is evangelism and not a browser bug?

I saved the page to disk, added a base href back to aa and could repro the
behavior you describe. I ran tidy over it and even then on initial display,
double digit dates only displayed the first digit, but on a refresh the digits
appeared fine. 

Priority: -- → P1
Summary: American Airlines's Flight Date display incorrectly → aa.com - American Airlines's Flight Date display incorrectly

Comment 2

17 years ago
PS I used NS62rtm and Mozilla trunk 2001110803 on win2k

Comment 3

17 years ago
back to browser. will attach test case.
Assignee: bclary → rods
Component: English: US → HTML Form Controls
Priority: P1 → --
Product: Tech Evangelism → Browser
QA Contact: zach → madhur
Version: unspecified → other

Comment 4

17 years ago
Created attachment 58430 [details]
test case for disappearing option values

tested with mozilla trunk 2001 11 14 03/win2k
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0.1
(Assignee)

Updated

17 years ago
Priority: -- → P1
Target Milestone: mozilla1.0.1 → Future
(Assignee)

Comment 5

17 years ago
works for me
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
v with 2002 04 08 03/win2k
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.