N621 & M099 crash installing Java plugin [@ KERNEL32.DLL | ntdll.dll - nsXPInstallManager::OnInstallDone | nsXPInstallManager::FinalStatus]

VERIFIED WORKSFORME

Status

--
critical
VERIFIED WORKSFORME
17 years ago
3 years ago

People

(Reporter: greer, Assigned: dprice)

Tracking

({crash, topcrash-})

Trunk
mozilla1.0
x86
Windows 98
crash, topcrash-

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3] (JC), crash signature)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
N6.20 users are crashing at the end of the installation process. User comments
point to downloading java plugins and the JRE.   
      
     Count   Platform List 
     45   Windows 98 4.10 build 67766446
     32   Windows 98 4.90 build 73010104
     17   Windows 98 4.10 build 67766222
 
     Count   Build Id List 
     94   2001102218
 
     No of Unique Users        94
 
 Stack trace(Frame) 

         KERNEL32.DLL + 0xb992 (0xbff7b992)  
         nsXPInstallManager::FinalStatus
[d:\builds\seamonkey\mozilla\xpinstall\src\nsXPInstallManager.cpp  line 956] 
         nsTopProgressListener::FinalStatus
[d:\builds\seamonkey\mozilla\xpinstall\src\nsTopProgressNotifier.cpp  line 193] 
         nsInstall::FinalizeInstall    
[d:\builds\seamonkey\mozilla\xpinstall\src\nsInstall.cpp
line 891] 
         InstallFinalizeInstall
[d:\builds\seamonkey\mozilla\xpinstall\src\nsJSInstall.cpp  line
842] 
         js_Invoke      [d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 809] 
         js_Interpret   [d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 2720] 
         js_Execute     [d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 991] 
         JS_EvaluateUCScriptForPrincipals      
[d:\builds\seamonkey\mozilla\js\src\jsapi.c  line
3317] 
         JS_EvaluateUCScript    [d:\builds\seamonkey\mozilla\js\src\jsapi.c 
line 3298] 
         JS_EvaluateScript      [d:\builds\seamonkey\mozilla\js\src\jsapi.c 
line 3265] 
         RunInstallOnThread    
[d:\builds\seamonkey\mozilla\xpinstall\src\nsSoftwareUpdateRun.cpp
line 445]  
 
     (37729588) URL: www.madebig.com
     (37729588) Comments: uploading pictures
     (37721194) Comments: Java 2 Plugin finished installing.
     (37720378) Comments: installing Java2 for windows
     (37720038) Comments: I really don't know  I just lost netscape after
uploading Java Plug in
which had completed
     (37716709) Comments: logging onto another site
     (37704862) Comments: i was downloading the dutch spell checker
     (37680897) Comments: restart my computer
     (37653025) Comments: Installing Java 2 Runtime Environment for Windows
     (37626469) Comments: Downloading Java Plugging after upgrading to 6.20
     (37601577) Comments: Installing new speller languages  email composer and
navigator opened
     (37599742) Comments: don't know
     (37598870) Comments: I was just downloading your java2 why am i having
trouble with your
netscape 6 to use it?
     (37586969) Comments: JAVA was loading  I wasn't doing anything else.
     (37582122) Comments: go to internet explorer
     (37573965) Comments: installing java
     (37554337) Comments: entering site and program froze
     (37554244) Comments: Installing java plugin
     (37543544) Comments: downloading java
     (37541617) Comments: Just downloaded Java plugin but did not restart
netscape immediately then
crash just happened.By the way this browser is just what users have been waiting
for .I had
previously used it for 8 hrs contnously on Win 98 without a single crashCheers
     (37523989) URL: pogo.com
     (37523989) Comments: waiting on a game to load
     (37490933) Comments: trying to install the Java runtime package
     (37476012) Comments: Sometimes the browser just hang-up! And there are
times (illegal
operation) warning appears on the screen!Why is that so! Is there any option to
avoid that?
     (37462970) Comments: i wasn't at my computer
     (37457741) URL: http://www.uvsc.com
     (37457741) Comments: Downloading and installing the java 1.3.1 plug in for
windows
     (37449967) Comments: downlod
     (37425470) Comments: Downloading your JAVA applet
     (37424089) Comments: i keep getting erro illegal function
(Reporter)

Updated

17 years ago
Keywords: crash, topcrash
(Reporter)

Updated

17 years ago
Summary: N620 crash installing Java plugin [@ nsXPInstallManager::FinalStatus] → N620 crash installing Java plugin [@ KERNEL32.DLL - nsXPInstallManager::FinalStatus]
(Reporter)

Comment 1

17 years ago
summary update for talkback
Summary: N620 crash installing Java plugin [@ KERNEL32.DLL - nsXPInstallManager::FinalStatus] → N620 crash installing Java plugin [@ ntdll.dll - KERNEL32.DLL - nsXPInstallManager::FinalStatus]

Comment 2

17 years ago
This crash is showing up under both the KERNEL32.DLL and ntdll.dll stack
signatures.  The total amount of crashes for both of these crashes make this a
major crash for Netscape 6.20.  Here is some info for the ntdll.dll version of
this crash:

 Count   Offset    Real Signature
[ 10   ntdll.dll + 0x2e22a (0x77f7e22a) d64d71fa - nsXPInstallManager::FinalStatus ]
[ 4   ntdll.dll + 0x2e2ad (0x77f7e2ad) c7675ce3 - nsXPInstallManager::FinalStatus ]
[ 3   ntdll.dll + 0x2e22a (0x77f7e22a) 15cb6c87 - nsXPInstallManager::FinalStatus ]
[ 2   ntdll.dll + 0x754b (0x77f6754b) 770c207d - nsXPInstallManager::FinalStatus ]
 
     Crash date range: 2001-11-10 to 2001-11-18
     Min/Max Seconds since last crash: 269 - 177807
     Min/Max Runtime: 269 - 511686
     Keyword List :  
     Count   Platform List 
     17   Windows NT 5.1 build 2600
     2   Windows NT 4.0 build 1381
 
     Count   Build Id List 
     19   2001102218
 
     No of Unique Users        19
 
 Stack trace(Frame) 

	 ntdll.dll + 0x2e22a (0x77f7e22a)  
	 nsXPInstallManager::FinalStatus
[d:\builds\seamonkey\mozilla\xpinstall\src\nsXPInstallManager.cpp  line 956] 
	 nsTopProgressListener::FinalStatus
[d:\builds\seamonkey\mozilla\xpinstall\src\nsTopProgressNotifier.cpp  line 193] 
	 nsInstall::FinalizeInstall
[d:\builds\seamonkey\mozilla\xpinstall\src\nsInstall.cpp  line 891] 
	 InstallFinalizeInstall
[d:\builds\seamonkey\mozilla\xpinstall\src\nsJSInstall.cpp  line 842] 
	 js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 809] 
	 js_Interpret
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 2720] 
	 js_Execute
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 991] 
	 JS_EvaluateUCScriptForPrincipals
[d:\builds\seamonkey\mozilla\js\src\jsapi.c  line 3317] 
	 JS_EvaluateUCScript
[d:\builds\seamonkey\mozilla\js\src\jsapi.c  line 3298] 
	 JS_EvaluateScript
[d:\builds\seamonkey\mozilla\js\src\jsapi.c  line 3265] 
	 RunInstallOnThread
[d:\builds\seamonkey\mozilla\xpinstall\src\nsSoftwareUpdateRun.cpp  line 445] 
	 _PR_NativeRunThread
[../../../../../pr/src/threads/combined/pruthr.c  line 435] 
	 msvcrt.dll + 0x27fb8 (0x77c37fb8)  
	 kernel32.dll + 0x202ed (0x77e802ed)   
 
     (38028364)	Comments: sfsfssfs
     (37934960)	Comments: downloading

Adding qawanted keyword to see if we can get someone to reproduce this.
Keywords: qawanted
Summary: N620 crash installing Java plugin [@ ntdll.dll - KERNEL32.DLL - nsXPInstallManager::FinalStatus] → N620 crash installing Java plugin [@ KERNEL32.DLL | ntdll.dll - nsXPInstallManager::FinalStatus]

Comment 3

17 years ago
Adding M096 to summary, since there are a few crashes with Mozilla 0.9.6:

Count   Offset    Real Signature
[ 3   ntdll.dll + 0x2e22a (0x77f7e22a) d64d71fa - nsXPInstallManager::FinalStatus ]
 
     Crash date range: 2001-11-21 to 2001-11-27
     Min/Max Seconds since last crash: 484 - 154176
     Min/Max Runtime: 484 - 154176
     Keyword List :  
     Count   Platform List 
     3   Windows NT 5.1 build 2600
 
     Count   Build Id List 
     3   2001112012
 
     No of Unique Users         3
 
 Stack trace(Frame) 

	 ntdll.dll + 0x2e22a (0x77f7e22a)  
	 nsXPInstallManager::FinalStatus
[d:\builds\seamonkey\mozilla\xpinstall\src\nsXPInstallManager.cpp  line 958] 
	 nsTopProgressListener::FinalStatus
[d:\builds\seamonkey\mozilla\xpinstall\src\nsTopProgressNotifier.cpp  line 193] 
	 nsInstall::FinalizeInstall
[d:\builds\seamonkey\mozilla\xpinstall\src\nsInstall.cpp  line 890] 
	 InstallFinalizeInstall
[d:\builds\seamonkey\mozilla\xpinstall\src\nsJSInstall.cpp  line 858] 
	 js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 834] 
	 js_Interpret
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 2792] 
	 js_Execute
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 1014] 
	 JS_EvaluateUCScriptForPrincipals
[d:\builds\seamonkey\mozilla\js\src\jsapi.c  line 3380] 
	 JS_EvaluateUCScript
[d:\builds\seamonkey\mozilla\js\src\jsapi.c  line 3361] 
	 JS_EvaluateScript
[d:\builds\seamonkey\mozilla\js\src\jsapi.c  line 3328] 
	 RunInstallOnThread
[d:\builds\seamonkey\mozilla\xpinstall\src\nsSoftwareUpdateRun.cpp  line 443] 
	 _PR_NativeRunThread
[../../../../../pr/src/threads/combined/pruthr.c  line 435] 
	 msvcrt.dll + 0x27fb8 (0x77c37fb8)  
	 kernel32.dll + 0x202ed (0x77e802ed)   
 
     (38564395)	Comments: installing java

This hasn't been looked at for a while...and I'm hesitant to set a target
milestone...can someone please take a look and set the milestone?  Changine the
component to OJI, in case they know anything about this crash.
Assignee: syd → joe.chou
Component: Installer: XPI Packages → OJI
QA Contact: ktrina → pmac
Summary: N620 crash installing Java plugin [@ KERNEL32.DLL | ntdll.dll - nsXPInstallManager::FinalStatus] → N620 & M096 crash installing Java plugin [@ KERNEL32.DLL | ntdll.dll - nsXPInstallManager::FinalStatus]
I think this was reassigned in error. Although Java may be a very commonly
installed package, this crash is clearly during the XPInstall and isn't the
fault of the package being installed.
Assignee: joe.chou → syd
Component: OJI → Installer: XPInstall Engine
QA Contact: pmac → jimmylee
nsXPInstallManager::FinalStatus should be calling into
nsXPITriggerInfo::SendStatus, not something in ntdll.dll -- Could the install
manager somehow be deleted when we get the FinalStatus callback? Is the crash
always the same place in ntdll.dll?

Updated

17 years ago
Target Milestone: --- → M1

Updated

17 years ago
Target Milestone: M1 → Future

Comment 6

17 years ago
This continues to be a topcrasher with every new release or milestone.  Here is
some more data from Talkback that might help us find a solid testcase:

Netscape 6.21 (N621):

Count   Offset    Real Signature
[ 46   KERNEL32.DLL + 0xb992 (0xbff7b992) 5e0e19dc -
nsXPInstallManager::FinalStatus ]
[ 28   KERNEL32.DLL + 0xb9a6 (0xbff7b9a6) 31cbb794 -
nsXPInstallManager::FinalStatus ]
[ 20   KERNEL32.DLL + 0xbb07 (0xbff6bb07) aeb0b633 -
nsXPInstallManager::FinalStatus ]
[ 20   KERNEL32.DLL + 0xbaf3 (0xbff6baf3) eb93caec -
nsXPInstallManager::FinalStatus ]
[ 19   KERNEL32.DLL + 0xb983 (0xbff7b983) dfabd813 -
nsXPInstallManager::FinalStatus ]
[ 17   KERNEL32.DLL + 0xb997 (0xbff7b997) f1e621f2 -
nsXPInstallManager::FinalStatus ]
 
     Crash date range: 2002-01-03 to 2002-01-14
     Min/Max Seconds since last crash: 33 - 671246
     Min/Max Runtime: 33 - 1088992
     Keyword List : download(25), game(5), java(28), load(29), message(4),
netscape(9), plugin(5), install(8),  
     Count   Platform List 
     74   Windows 98 4.10 build 67766446
     40   Windows 98 4.90 build 73010104
     36   Windows 98 4.10 build 67766222
 
     Count   Build Id List 
     150   2001112815
 
     No of Unique Users       150
 
 Stack trace(Frame) 

	 KERNEL32.DLL + 0xb992 (0xbff7b992)  
	 nsXPInstallManager::FinalStatus
[c:\builds\seamonkey\mozilla\xpinstall\src\nsXPInstallManager.cpp  line 956] 
	 nsTopProgressListener::FinalStatus
[c:\builds\seamonkey\mozilla\xpinstall\src\nsTopProgressNotifier.cpp  line 193] 
	 nsInstall::FinalizeInstall
[c:\builds\seamonkey\mozilla\xpinstall\src\nsInstall.cpp  line 891] 
	 InstallFinalizeInstall
[c:\builds\seamonkey\mozilla\xpinstall\src\nsJSInstall.cpp  line 842] 
	 js_Invoke
[c:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 809] 
	 js_Interpret
[c:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 2720] 
	 js_Execute
[c:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 991] 
	 JS_EvaluateUCScriptForPrincipals
[c:\builds\seamonkey\mozilla\js\src\jsapi.c  line 3327] 
	 JS_EvaluateUCScript
[c:\builds\seamonkey\mozilla\js\src\jsapi.c  line 3308] 
	 JS_EvaluateScript
[c:\builds\seamonkey\mozilla\js\src\jsapi.c  line 3275] 
	 RunInstallOnThread
[c:\builds\seamonkey\mozilla\xpinstall\src\nsSoftwareUpdateRun.cpp  line 445]  
 
     (1664115)	Comments: i downloaded a  parody song  and my realplayer would not allow me
to listen to it so i dwnlded again and again  but still could not hear it but it
did show that it was playing . I cant understand it ive done this proceedure
many times before and never had
     (1664115)	Comments:  a problem in past
     (1662349)	Comments: Download a Java update
     (1659005)	Comments: went to play a game and had to download suntime java and i
recieved an error message the netscape has performed illegal operations  this
appeared after the installation ws complete of the java plug in
     (1656654)	Comments: I was unable to download the Java updated plug-in.  The system
crashed out with a close/ignore message.
     (1656033)	Comments: Downloading Java something
     (1651882)	Comments: It started when I downloaded Netscape 6.1
     (1643542)	Comments: downloading a Java plug-in for Netscape 6.2 caused the error message
     (1643532)	URL: www.multimap.com
     (1640659)	Comments: Iwas down loading java music kareoka
     (1609181)	Comments: It is acting crazy...always says we have performed an illeagal
operation
     (1607354)	Comments: im unable to return to previous page!
     (1603661)	Comments: NETSCP6 caused an invalid page fault inmodule KERNEL32.DLL at
0167:bff7b992.Registers:EAX=0000008c CS=0167 EIP=bff7b992
EFLGS=00010206EBX=00000000 SS=016f ESP=04b6f998 EBP=04b6fa20ECX=00000009 DS=016f
ESI=0000008c FS=0d8fEDX=819cee6c ES=016f
     (1603661)	Comments:  EDI=00000070 GS=0000Bytes at CS:EIP:80 3e 04 74 0f 33 c0 50 50 50
68 05 00 00 c0 e8 Stack dump:0493b0a0 601a3527 0000008c 040f6ca0 03f3c970
60216ae3 00000070 040f6ca0 03f17850 60216abc 03f3c970 039967f8 60b904dc 040f6ca0
039967b0 60202594 
     (1601790)	Comments: down loading java 2
     (1585933)	Comments: downloading
     (1578966)	URL: geocities.yahoo.com
     (1578966)	Comments: downloading java plug in
     (1571884)	Comments: I was downloading. It is not the first time. I think that
something is wrong with downloading. I would like to know what mayght be the
problem?
     (1570902)	URL: http://chat.yahoo.com
     (1570902)	Comments: it just killed itself
     (1567639)	Comments: I was downloading excite games.
     (1562918)	URL: www.azzaman.com
     (1562918)	Comments: browsing the net. prompt of complete instalation of java software
plugins for netscape 6.2
     (1556013)	Comments: instaling java so i can play yahoo games
     (1554830)	URL: www.acbl.com
     (1549654)	Comments: downloading a game
     (1536967)	Comments: Installing Java Plug IN
     (1513691)	Comments: downloaded java1.3 from netscape-netscape 6.2 crashed -
     (1511358)	Comments: non
     (1510085)	Comments: Dowloading the Java 2 plugin when I recieved an error
     (1506489)	Comments: DOWNLOADING JAVA
     (1504778)	Comments: downloading basic version of java 1 3
     (1492919)	URL: ftp://ftp.netscape.........
     (1492919)	Comments: geting a plugin for a litle jave chess program
     (1476697)	URL: www.acmequiz.com
     (1476697)	Comments: trying to download a file  
     (1471109)	Comments: POGO  GAMES
     (1443424)	URL: http://www.datek.com
     (1443424)	Comments: trying to activiate datek streamer
     (1441896)	URL: www.lycos.co.uk
     (1441896)	Comments: downloading Java
     (1396207)	URL: www.bih.net.ba
     (1396207)	Comments: ccc
     (1382719)	URL: Bellsouth.net
     (1382719)	Comments: Down loading JAVA
     (1378460)	Comments: Downloading Java for windows. Failed while trying to open JAR files
     (1373550)	Comments: downloading a java plug in
     (1367189)	Comments: i'll be on line and it will shut me down
     (1367050)	Comments: I Dont Know.
     (1366407)	URL: http://www.sun.com
     (1366407)	Comments: Loading a JAVA page which prompted 6.x to tell me I need to
download the latest JRE package  which I already had installed .. ;( (win98x as
you wil see from the easter egg transmission)anyhow resulted in a new JRE
download and a Netscape crash and
     (1366407)	Comments:  burn after (no Windows kill directly caused)Robin
     (1355347)	Comments: was finishing install of java 2 when illegal operation screen came up
     (1341964)	Comments: Checking e-mail and downloading Java 
     (1326789)	Comments: installing java plugin
     (1322022)	Comments: i was fucking myself in the head for downloading the netscape
browser which had no java as standard while downloading it got fucked up do
something abt it or iam getting internet explorer i dont think u care to
replykeep up this excellent service and
     (1322022)	Comments:  reputation
     (1321272)	URL: www.excite.com
     (1317325)	Comments: was installing a java 2 plugin when this error message
ocurred:Netscp6 has caused an error in Kernel32.dll.  Netscp6 will now close.
     (1312118)	Comments: I was using mIRC and reading some news on netscape that I accessed
from the Netscape Sidebar.  My ICQ was also active.
     (1308073)	Comments: netscape  6.2
     (1288161)	URL: www.ahamembership.com
     (1288161)	Comments: downloading a java 2 plug-in
     (1285280)	Comments: I was filling out an application for coupons 
     (1277593)	Comments: downloading java
     (1277257)	Comments: I was downloading JAVA
     (1272741)	Comments: installing flash2
     (1260170)	Comments: install jave 2 web cam browser


Mozilla 0.9.7 (M097):

 Count   Offset    Real Signature
[ 3   KERNEL32.DLL + 0xb992 (0xbff7b992) 5e0e19dc -
nsXPInstallManager::FinalStatus ]
[ 2   KERNEL32.DLL + 0xbaf3 (0xbff6baf3) eb93caec -
nsXPInstallManager::FinalStatus ]
[ 2   KERNEL32.DLL + 0xb9a6 (0xbff7b9a6) 31cbb794 -
nsXPInstallManager::FinalStatus ]
 
     Crash date range: 2002-01-10 to 2002-01-15
     Min/Max Seconds since last crash: 1358 - 77072
     Min/Max Runtime: 1358 - 155715
     Keyword List :  
     Count   Platform List 
     5   Windows 98 4.10 build 67766446
     2   Windows 98 4.90 build 73010104
 
     Count   Build Id List 
     7   2001122109
 
     No of Unique Users         7
 
 Stack trace(Frame) 

	 KERNEL32.DLL + 0xb992 (0xbff7b992)  
	 nsXPInstallManager::FinalStatus
[d:\builds\seamonkey\mozilla\xpinstall\src\nsXPInstallManager.cpp  line 959] 
	 nsTopProgressListener::FinalStatus
[d:\builds\seamonkey\mozilla\xpinstall\src\nsTopProgressNotifier.cpp  line 193] 
	 nsInstall::FinalizeInstall
[d:\builds\seamonkey\mozilla\xpinstall\src\nsInstall.cpp  line 890] 
	 InstallFinalizeInstall
[d:\builds\seamonkey\mozilla\xpinstall\src\nsJSInstall.cpp  line 856] 
	 js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 834] 
	 js_Interpret
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 2799] 
	 js_Execute
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 1014] 
	 JS_EvaluateUCScriptForPrincipals
[d:\builds\seamonkey\mozilla\js\src\jsapi.c  line 3358] 
	 JS_EvaluateUCScript
[d:\builds\seamonkey\mozilla\js\src\jsapi.c  line 3339] 
	 JS_EvaluateScript
[d:\builds\seamonkey\mozilla\js\src\jsapi.c  line 3306] 
	 RunInstallOnThread
[d:\builds\seamonkey\mozilla\xpinstall\src\nsSoftwareUpdateRun.cpp  line 443]  
 
     (1568823)	URL: ftp.netscape.com/pub/netscape6/english/6.2.1/windows/win32/xpi
     (1541936)	Comments: gone to jonttuz.net  it worked before.. nothing else happened
except just installed java2 without restarting mozilla  there were no java in
root on jonttuz.net
     (1514178)	URL:
http://www.speedbit.com/buy.asp?DAUI=51910720&DAPCode=T2228-P3019-H1282&Ref=1&V=5.0.0.1
Summary: N620 & M096 crash installing Java plugin [@ KERNEL32.DLL | ntdll.dll - nsXPInstallManager::FinalStatus] → N621 & M097 crash installing Java plugin [@ KERNEL32.DLL | ntdll.dll - nsXPInstallManager::FinalStatus]

Comment 7

17 years ago
Ccing Grace.

Comment 8

17 years ago
Seems like this topcrash bug should be assigned to you, Dan, so now it is.
Assignee: syd → dveditz

Comment 9

17 years ago
nominating topcrash bugs for nsbeta1. 
Keywords: nsbeta1

Comment 10

17 years ago
nsbeta1+
Keywords: nsbeta1 → nsbeta1+
I don't know why this would be crashing in the kernel based on what
nsXPInstallManager is doing there. Bug 108098 shows the same nsXPInstallManager
line in the stack but makes a lot more sense. If the mTriggers member got
trashed somehow it could be pointing at odd places, but in that case I wouldn't
expect the crash to be at a consistent address. I also don't see how the
FinalStatus call could come before the nsXPInstallManager object is deleted.
Status: NEW → ASSIGNED
Target Milestone: Future → mozilla1.0

Comment 12

17 years ago
crashing on M099 at offset 0x2e22a 

 Crash date range: 2002-03-11 to 2002-03-15
     Min/Max Seconds since last crash: 16231 - 48826
     Min/Max Runtime: 16231 - 48826
     Count   Platform List 
     4   Windows NT 5.1 build 2600
 
     Count   Build Id List 
     4   2002031106
 
     No of Unique Users         4
 
 Stack trace(Frame) 

	 ntdll.dll + 0x2e22a (0x77f7e22a)  
	 nsXPInstallManager::FinalStatus
[d:\builds\seamonkey\mozilla\xpinstall\src\nsXPInstallManager.cpp  line 959] 
	 nsTopProgressListener::FinalStatus
[d:\builds\seamonkey\mozilla\xpinstall\src\nsTopProgressNotifier.cpp  line 196] 
	 nsInstall::FinalizeInstall
[d:\builds\seamonkey\mozilla\xpinstall\src\nsInstall.cpp  line 876] 
	 InstallFinalizeInstall
[d:\builds\seamonkey\mozilla\xpinstall\src\nsJSInstall.cpp  line 856] 
	 js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 790] 
	 js_Interpret
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 2746] 
	 js_Execute
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 970] 
	 JS_EvaluateUCScriptForPrincipals
[d:\builds\seamonkey\mozilla\js\src\jsapi.c  line 3341] 
	 JS_EvaluateUCScript
[d:\builds\seamonkey\mozilla\js\src\jsapi.c  line 3322] 
	 JS_EvaluateScript
[d:\builds\seamonkey\mozilla\js\src\jsapi.c  line 3289] 
	 RunInstallOnThread
[d:\builds\seamonkey\mozilla\xpinstall\src\nsSoftwareUpdateRun.cpp  line 443] 
	 _PR_NativeRunThread
[../../../../../pr/src/threads/combined/pruthr.c  line 435] 
	 msvcrt.dll + 0x27fb8 (0x77c37fb8)  
	 kernel32.dll + 0x202ed (0x77e802ed)   
 

COMMENTS/URLs:

     (4015113)	Comments: installing java  downloading python  and browsing. Crashed at end
of java install.
     (3931524)	Comments: Installing Sun Java 2 Plugin
 
Summary: N621 & M097 crash installing Java plugin [@ KERNEL32.DLL | ntdll.dll - nsXPInstallManager::FinalStatus] → N621 & M099 crash installing Java plugin [@ KERNEL32.DLL | ntdll.dll - nsXPInstallManager::FinalStatus]

Updated

17 years ago
Blocks: 52869

Comment 13

17 years ago
adt3 per adt traige
Whiteboard: [adt3]
(Reporter)

Comment 14

17 years ago
Another comment turned up today with an identical stack to that in Jan's comment  
(#12) above:

     (4172329)  Comments: Doing a 'software installation' of java 1.3 on Windows 
2000 and selected a directory I did not have permission to write to.

That might provide a way to reproduce this one.
No longer blocks: 52869
(Reporter)

Comment 15

17 years ago
Created attachment 78011 [details]
Stacks from N622 and M099 that terminate at KERNEL.DLL with XPinstallManager::FinalStatus in the second frame

Current crashes: 15 in M099, 71 in N622, 0 in Trunk. 
  The M099 and N622 stacks differ, which I would expect from two different
product installations. All crashes listed are on Win98 or ME (listed as Windows
98 4.90), no NT platforms.  (There were two Trunk crashes at
nsXPInstallManager::OnInstallDone that are tacked on at the bottom.)

Because crashes/unique users is a 1/1 ratio I would guess a user encounters
this once and succeeds on a subsequent attempt (unless 100% give up entirely or

100% only submit one crash report). I can look deeper into specific users
systems (DLLs loaded, system memory, etc.) if more info will help pinpoint
the problem.
The "FinalStatus" notification was renamed "OnInstallDone" with the fix for bug
105085 so that's essentially the same place. You should only be seeing
OnInstallDone on the trunk, I'm pretty sure I missed 0.9.9 with that fix.

(the code path changed slightly, "FinalStatus" was combined with the
"AfterJavascriptExecution" notification.)

Comment 17

17 years ago
--> dprice to see if he can spend an hour or two and dupe this in a debug build.
Assignee: dveditz → dprice
Status: ASSIGNED → NEW

Comment 18

17 years ago
I was able to reproduce this on Win98 today - crashed at the end of Java plugin
install
steps to reproduce:
1. uninstall Java 
2. install recommended type
3. go to www.java.sun.com and click on applet
4. get the plugin and install

actual results: crash at end of Java install, crashed windows- no talkback.
after reboot was able to launch and use Java

expected results: Java install, relaunch and run Java

Comment 19

17 years ago
Grace has reproducible steps. Removing qawanted keyword   Grace, were you using
a trunk build?
Keywords: qawanted

Comment 20

17 years ago
Build: 2002-04-09-10-trunk(WIN)

I was not able to reproduce the crash on my Windows 98.  I used the steps that
Grace describes.
(Reporter)

Comment 21

17 years ago
Created attachment 78479 [details]
Grace's 4/9/02 crash

I only see one crash for Grace in today's talkback data. Unfortunately, it
doesn't have the same stack or signature.
(Reporter)

Comment 22

17 years ago
Since Grace's crash wasn't this one. ->qawanted.
Keywords: qawanted

Comment 23

17 years ago
my crash that had talkback data was on another install - testing install while 
QuickLaunch was running.
I did not get a talkback report with my crash for this problem

Comment 24

17 years ago
Non Reproducible, seems to be working fine on trunk 4-8-2002, using Win 98
This bug has *always* been nearly impossible to reproduce. Don't let that fool
you, the number of talkback reports shows it is very, very real.
Status: NEW → ASSIGNED

Comment 26

17 years ago
Here is the latest info for crashes on the Trunk (with new line numbers as
dprice requested):

Count   Offset    Real Signature
[ 3   ntdll.dll + 0x21e1 (0x77f821e1) a5f932ab - nsXPInstallManager::OnInstallDone ]
 
     Crash date range: 2002-04-07 to 2002-04-16
     Min/Max Seconds since last crash: 355 - 29527
     Min/Max Runtime: 355 - 29527
     Keyword List :  
     Count   Platform List 
     3   Windows NT 5.0 build 2195
 
     Count   Build Id List 
     1   2002041411
     1   2002041011
     1   2002040611
 
     No of Unique Users         3
 
 Stack trace(Frame) 

	 ntdll.dll + 0x21e1 (0x77f821e1)  
	 nsXPInstallManager::OnInstallDone
[d:\builds\seamonkey\mozilla\xpinstall\src\nsXPInstallManager.cpp  line 994] 
	 nsTopProgressListener::OnInstallDone
[d:\builds\seamonkey\mozilla\xpinstall\src\nsTopProgressNotifier.cpp  line 177] 
	 RunInstallOnThread
[d:\builds\seamonkey\mozilla\xpinstall\src\nsSoftwareUpdateRun.cpp  line 497] 

I don't see any crashes like this under the KERNEL32.DLL stack signature at this
time.

Comment 27

17 years ago
Changing nsbeta1+ [adt3] bugs to nsbeta1- on behalf of the adt.  If you have any
questions about this, please email adt@netscape.com.  You can search for
"changing adt3 bugs" to quickly find and delete these bug mails.
Keywords: nsbeta1-

Comment 28

17 years ago
Changing nsbeta1+ [adt3] bugs to nsbeta1- on behalf of the adt.  If you have any
questions about this, please email adt@netscape.com.  You can search for
"changing adt3 bugs" to quickly find and delete these bug mails.
Keywords: nsbeta1+

Updated

17 years ago
Whiteboard: [adt3] → [adt3] (JC)

Comment 29

17 years ago
I'm tempted to mark this bug worksforme.  I have not seen any crashes like this
in the last 3 Mozilla 1.0 release candidates or the Mach V preview release.  

I'm just going to mark it topcrash- and if we don't see any more crashes in
Mozilla 1.0 or Netscape 7, we should just make this worksforme.
Marking topcrash-, from comment 29 it sounds like that's what jpatel intended.
Keywords: topcrash → topcrash-

Comment 31

16 years ago
Marking this one worksforme.  I haven't seen this crash in any recent
MozillaTrunk or Gecko 1.0 Branch builds...and it was definitely NOT a topcrasher
with Mozilla 1.0 or Netscape 7.0 PR1.  

If this crash does show up again, please feel free to reopen.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 32

16 years ago
Updating the summary with nsXPInstallManager::OnInstallDone for future
reference, since that was the stack signature for the the most recent crash of
this kind.
Summary: N621 & M099 crash installing Java plugin [@ KERNEL32.DLL | ntdll.dll - nsXPInstallManager::FinalStatus] → N621 & M099 crash installing Java plugin [@ KERNEL32.DLL | ntdll.dll - nsXPInstallManager::OnInstallDone | nsXPInstallManager::FinalStatus]

Comment 33

16 years ago
Marking Verified.  No word on this continuing.
Status: RESOLVED → VERIFIED
Crash Signature: [@ KERNEL32.DLL | ntdll.dll - nsXPInstallManager::OnInstallDone | nsXPInstallManager::FinalStatus]
Keywords: qawanted
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.