When divs are shown and hidden, part of the content of the hidden div still shows. The window is not fully updated.

CLOSED WORKSFORME

Status

()

CLOSED WORKSFORME
17 years ago
8 years ago

People

(Reporter: dj, Assigned: attinasi)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
BuildID:    2001101117

This page uses the showing and hiding of divs to implement a tab navigation 
system.  DHTML is used to write content into one of the divs (the one that 
implements the "Form" tab).  When a tab is selected, its div is shown and the 
other one hidden.  The dynamic content on the hidden div is hot completely 
replaced by the shown tab's div content.

Reproducible: Always
Steps to Reproduce:
1. Visit http://www.oraclesmallbusiness.com/portal/portal.nl?mode=welcome
2. Log in as dj@oraclesb.com with password foobar1
3. Visit https://system.oraclesmallbusiness.com/crm/sales/leadcaptureform.nl?
id=1
4. Click the "Form" tab and see a list of items.
5. Click the "External" tab and see the page change.  Part of the "Form" tab 
contents still show.
6. Grab the lower right corner of the window and drag it slightly.

Actual Results:  When switching between tabs, screen content from the prior tab 
is not fully erased.  Resizing the page a bit or dragging other windows over 
the browser causes the needed offscreen buffer refresh.

Expected Results:  Clicking between tabs (hiding and showing divs) should 
result in the correct refresh and full display of the shown div's contents.

This page works properly in IE5.x, IE6.0 and Netscape 4.x.

Comment 1

17 years ago
Can't reproduce with the Nov 8th build (2001-11-08-03) under Windows 2000.
Please try with a newer build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

17 years ago
Agreed -- build 2001110803 does resolve the bug.  Thanks!
Status: RESOLVED → CLOSED
You need to log in before you can comment on or make changes to this bug.